Subnet using Switch-based Routing Cannot Access Internet

In the following configuration, can anyone tell me why clients on subnet are NOT able to access the internet?  The two other subnets are hitting the internet just fine.  I can't tell if the problem is on the firewall or the switch configuration, but internet access for this subnet is the ONLY communication problem I can detect.
Router (Cisco 2600 series)
Firewall (PIX 515E),
Switch (Cisco 3750e), ..... gateway set to ..... 1 VLAN (default) ..... routing enabled ..... static routes established for destination to gateway and destination to gateway ..... subnet assigned to port 3
Switch (Cisco 3750s), ..... gateway set to ..... 1 VLAN (default) ..... routing enabled ..... static route established for destination to gateway ..... subnet assigned to port 2 (
Clients on subnet using gateway

NOTE:  Subnet clients connected to the secondary switch are also able to access the internet.  The ONLY clients having a problem are on subnet

Thanks for any ideas!!!
Who is Participating?
Don JohnstonConnect With a Mentor InstructorCommented:
Are you running a routing protocol between the 3750's and the PIX? If not then I would say your problem is that the PIX doesn't have a route to the network.
JFrederick29Connect With a Mentor Commented:
Also, check to make sure the PIX is NAT'ing the traffic.
isdirectAuthor Commented:
Thanks guys!!  Both of you are agreeing with my instincts, but - I am not well-versed in the command-line interface for my PIX.  I can get log in and enable, and I know how to view the configuration, but I don't know what to look for to verify these things.  Can you tell me what lines to look for, and how to add the route and/or NAT lines for the .20 subnet?
Make sure you have a route like this:

route inside

Also, for the NAT, you should have commands similar to this:

nat (inside) 1 192.168.x.x

If you don't have a "nat" statement for the subnet, add this:

nat (inside) 1

If you have this "nat (inside) 1" or "nat (inside) 1" then it covers the subnets and you don't have to add anything nat related.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.