Eject not working for CD-ROM Drive.

Hi all,

Have recently noticed that our computer has a problem with using the eject button on the CD-ROM drive.

We have a Dell PC with Windows XP, with two logins (one for me and one for my wife).  When my wife is logged in, the eject button doesn't work at all.  Only when we're either logged in as me, or in the log-on screen can we get the CD-ROM drive to respond.

What I've done currently:

1)  Checked Device Manager to see whether anything is listed as being out of order (It says there's nothing wrong with it).

2)  And obviously, when I first noticed it, I checked on my login to see whether I could get the drive to work, and lo and behold, it did.

So it's rather a mystery to us why it's not working.  I was thinking perhaps some sort of a virus, but who knows?

So I thought I'd post to the good folks of Experts Exchange to see if anyone else had a better idea.

Any help would be appreciated.
iago_brothersAsked:
Who is Participating?
 
nobusbiljart fanCommented:
make another user for your wife, and besure to NOT delete the data from her previous user
0
 
cshepfamCommented:
uninstall the reinstall the driver for the cdrom


give that a try
0
 
iago_brothersAuthor Commented:
I just gave that a try.  Granted, I may have done it wrong - but it doesn't seem to have worked.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
lauchangkwangCommented:
>> When my wife is logged in, the eject button doesn't work at all.  Only when we're either logged in as me, or in the log-on screen can we get the CD-ROM drive to respond.

So is that mean when in your wife account pressing the "Eject" BUTTON, it doesn't work ?? Or "Right Click" the CD ROM under "My computer" > Select "Eject" doesn't work ??

If the problem is with the "Eject" Button in the CD ROM, I would suspect the "Eject" button is not functioning correctly. If it is just happended in your wife account, try delete your wife account and recreat a new account to see whether it solves the problem ...... Hope this help .......
0
 
iago_brothersAuthor Commented:
That worked, but is there any easy way to transfer the stuff from the old user account across to the new one (e.g. Internet settings, Start menu, etc. etc.)?
0
 
iago_brothersAuthor Commented:
Thanks for that!
0
 
lauchangkwangCommented:
(=..=) ............
0
 
iago_brothersAuthor Commented:
Should actually, say, to clear this up, that the real reason for the problem was actually nothing to do with Profiles.  We have a program that my wife downloaded called Toddler Keys, that allows you to lock off certain parts of the computer (like the keyboard) so that your toddler can have a play with a computer without actually breaking anything.

What we didn't realise was that even when it wasn't turned on to locking off the keyboard, if the program was active down in the right-hand corner menu, it was locking shut the CD-ROM drive.  As soon as I right-clicked on the program and turned off the "Lock CD-ROM drive option", it all started up again.

So thanks for the help - but really feel like we needed a Gregory House to work this one out . . .
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.