?
Solved

error message :You don't have permission to access . when i try to download ZIP file

Posted on 2007-10-20
9
Medium Priority
?
961 Views
Last Modified: 2013-12-21
Dear All,
I have SUN Solaris 10 websever  oracle -EBS 10-
There is a HTML page user can read documents though their browser its PDF.XLS and ZIP files
They can read PDF or XLS but when they trying to access ZIP file, the following error message they are facing:

304 Forbidden
You don't have permission to access (/OA_HTML/11idoc/acrobat/r115102ug.zip -as example) on this server


Even if I change the permission to 777 or to other will face same error message
But if I will change the extension  name  from xxx.zip to xxx.old for example and HTML code to point to the same file , I can download the file

Thanks
Nibal
0
Comment
Question by:nnnddd
  • 4
  • 3
  • 2
9 Comments
 
LVL 6

Accepted Solution

by:
javeedabdul earned 500 total points
ID: 20117777
do you have a zip package installed


you can find it here
www.sunfreeware.com

are you opening xxx.old in the same way as xxx.zip

can you able to extrat the zip file when opening xxx.old?

What command are you using to open zip?
Are you using GUI or CLI method?

these question answer will give me and other more information to solve the problem


Regards
Javeed Abdul
0
 

Author Comment

by:nnnddd
ID: 20124441
Thanks Javeed ,
How can I install zippackage?
Yes same way Im opening the xxx.old  as xxx.zip
Yes after download the file, I can extract it
Actually, its GUI through internet explorer or by other explorer like firefox   this I a windows client machine
and the Server is Solaris webserver  ,
Note: that same application is running under windows server with same HTML code with same client not given same problem and its working fine
Thanks
Nibal
0
 

Author Comment

by:nnnddd
ID: 20124553
its need to install zip package on server ?
I need to open zip file on the client computer not on server !
Thanks
Nibal
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 48

Expert Comment

by:Tintin
ID: 20126784
By default, Solaris 10 comes with zip/unzip.

It is in /usr/bin

Have a look in the webserver error log to see if it gives you some more clues as to why you are getting a 403 error.
0
 
LVL 6

Expert Comment

by:javeedabdul
ID: 20127995
>>>They can read PDF or XLS but when they trying to access ZIP file, the following error message they are facing:<<<

pdf you can open on Webbrowser with out downloading it
Not sure about XLS .. could be the same
but zip needs download on local system and then needs to be unzipped
As you saying same same zip file xxx.zip file if renamed to xxx.old then you having no problem

create another new zip file and see if the problem having to .ZIP extention or only to one file

>>>>>Note: that same application is running under windows server with same HTML code with same client not given same problem and its working fine<<<<
i didn't understood this line


Titin
Thanks for correcting me .
I think solaris 8 and 7 don't have zip by default

Question for you
How to determine what packages are  already installed by default in Solaris 10.?
How did you find out zip /unzip comes in solaris by Default

Thanks



0
 
LVL 48

Expert Comment

by:Tintin
ID: 20128152
Solaris 10 packages are just the same as any other Solaris version

pkginfo -l

will list all installed packages.

I know zip/unzip comes with Solaris by default as it is in /usr/bin on all the Solaris 10 systems I look after.
0
 

Author Comment

by:nnnddd
ID: 20131373
Thanx
SUNWzip package is installed !
Once click on the link for any zip file it gives this same error message that mean open or download same !!
I mean by windows server : same application is running on windows server but without error message zip files or PDF are accessible

thanks again
Nibal
0
 
LVL 48

Expert Comment

by:Tintin
ID: 20134616
I think to progress this any further, you're going to need to check the webserver error log to see if it has any more detail as to why it's getting a permission denied error.
0
 

Author Comment

by:nnnddd
ID: 20136738
Hi all,
i got the solution from Oracle

Cause
Starting with AD patch 2902755 going forward,
file apps_ux.conf and apps_nt.conf delivers version 115.30 or higher
which includes the fix for a security breach issue.

You can no longer open an attachment of type .zip, .class, and .java.
Fix
Resolution navigation:

Revised fron earlier version.

If you wish to defeat this security measure (not recommended),
go to the directory $FND_TOP/admin/template
and edit apps_ux.conf and or apps_nt.conf to remove any or all the file types
that are currently disallowed.

Stop all services (adstpall.sh)
Rerun adautocfg.sh
Start all services (adstrtal.sh)

Thanks ,
Nibal
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background In several of the companies I have worked for, I noticed that corporate reporting is off loaded from the production database and done mainly on a clone database which needs to be kept up to date daily by various means, be it a logical…
From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
This video shows how to Export data from an Oracle database using the Original Export Utility.  The corresponding Import utility, which works the same way is referenced, but not demonstrated.
This video shows how to configure and send email from and Oracle database using both UTL_SMTP and UTL_MAIL, as well as comparing UTL_SMTP to a manual SMTP conversation with a mail server.
Suggested Courses
Course of the Month14 days, 13 hours left to enroll

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question