?
Solved

wsock.dll  - several applications report the wsock.dll is the incorect version.  Cann't figure out what to do about it.

Posted on 2007-10-20
9
Medium Priority
?
457 Views
Last Modified: 2011-04-14
I have a windows Vista Buisness platform... on a Dell 1501... Life was good (well ok) until just recently.  There have been a few program's installed, I have backed them all out.. yet still have this damn wsock.dll error when I try to run nearly any application worth a crap... expamples would be: Telnet, Mozilla Firfox, Star Office....

I have tried several of the off the shelf programs that tout themselves as registry / dll fixer uppers.  I have ran scans from all but  none report any error with a wsock.dll.  

Anyone have any ideas on a suggested course of action?
0
Comment
Question by:caseygj
8 Comments
 
LVL 24

Expert Comment

by:Alan Henderson
ID: 20115760
Is this definitely wsock.dll or is it wsock32.dll?
Have you updated and run your antivirus program?
0
 

Author Comment

by:caseygj
ID: 20115771
you are corrct... it's wsock32.dll  
0
 
LVL 24

Accepted Solution

by:
Alan Henderson earned 500 total points
ID: 20115852
1.  Try Vista System File Checker:

Click Start » All Programs » Accessories.
Right click Command Prompt.
Select Run as Administrator.

At the command prompt type
sfc /scannow (dont miss the space before the /)
Click OK.

You may need your Vista DVD if prompted for SFC.

2.  If that doesn't work and a better solution isn't forthcoming:

Vista repair options don't include XP's Repair Installation.
However you can do something similar - instructions here:
http://vistasupport.mvps.org/repair_a_vista_installation_using_the_upgrade_option_of_the_vista_dvd.htm

0
[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

 

Author Comment

by:caseygj
ID: 20115906
Vallis:

Awesome, didn't know this tool existed... but... now I have a more basic question..  the scan sys it fixed some things and couldn't others but it created a file that I do not have permissions to view... I am administrator.. is there some trick to view this?

I am going to re-start now to see if it magically fixed my problem.   I have not checked out the link you sent yet but I will do that if all this does not help...

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 98% complete.Windows Resource Protection found corrupt files but wa
s unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

The system file repair changes will take effect after the next reboot.
0
 

Author Comment

by:caseygj
ID: 20115969
vallis:

The system file checker did the trick.... I am still very curious what files it was unable to repair.  Anyway.. I was able to run telnet, firefox and several other applications that I have not been able to get to run.

Thank you.

0
 
LVL 24

Expert Comment

by:Alan Henderson
ID: 20116001
You're welcome.

Have you tried right clicking on the log file and selecting Run as Administrator?

Previous versions of Windows didn't give that message in SFC  it was better not to know! It almost always comes up with unfixable files, but it's not usually anything to worry about.
0
 
LVL 59

Assisted Solution

by:LeeTutor
LeeTutor earned 500 total points
ID: 20116196
You can start Notepad by typing it in the Search dialog box of the Start Menu, right clicking on it at the top of the search items found list, selecting Run as Administrator, reply to the User Account Control prompt, then select the File menu, and Open, and browse to the cbs.log and be able to open it after typing the name in the file name box.
0
 
LVL 1

Expert Comment

by:Computer101
ID: 20302833
Forced accept.

Computer101
EE Admin
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The way I use Experts Exchange to assist me in analyzing and diagnosing a problem is I first enter a Verbose Question at Experts Exchange like: Office 2007 will hang when opening and saving files I then launch WordPad (any text editor will do) an…
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Suggested Courses

594 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question