Sonicwall is allowing VPN but no other internet access (users cannot access websites, mail is not coming in, etc...)

Posted on 2007-10-21
Last Modified: 2012-05-05
I have a Sonicwall Pro 2040 and I'm having the strangest issue. From our company site we cannot access websites, receive mail, or do any other external forms of traffic. However, I can easily connect to my server using the Sonicwall VPN from off site. If I remote desktop to a computer while doing the VPN I cannot access the internet (from that remote desktop) yet I can easily do all of it on mine (the one I'm connecting from).

Any ideas on what I should look at or anything else that might help describe the issue more? I've checked everything from the router to the access rules. What really threw me was that I can easily connect to our network from home. And yes, our internal networking is working fine.

Question by:KellyNaylor
    LVL 19

    Accepted Solution

    Are you sure this isn't a DNS problem? Try this from one of the PC's at the company site:
    At the command prompt, type: nslookup

    It should tell you which DNS server it is using and also give you some IP addresses associated with - I get addresses such as

    If nslookup isn't working, then check what is set as the Preferred DNS server on the company PC (ipconfig /all is useful for this).

    Author Comment

    Thanks Feptias, I accepted your answer since I fixed it right as you responded.

    It ended up being some sort of DNS issue. Every once in a while I'll have a Sonicwall issue where it locks up access, which made me to believe it may be the culprit. However after spending 2+ hours researching everything I came up with the idea it might be a DNS issue. I did everything I could think of including restarting the servers. Finally I decided to remove the forwarders in the DNS setup. After that I tried a DNS lookup once more using the CMD prompt and right away it found (always a good website to use for testing).

    Once again my network is working. Now if only I knew why this happened suddenly would I be happy.

    Thanks again for the response - it's never fun to spend hours playing with DNS on a Sunday.

    LVL 19

    Expert Comment

    Could it simply be that a problem arose with the DNS servers you were forwarding to? I see this happen from time to time with various external DNS servers, even those provided by large ISP's - it is useful to keep a list of several DNS servers so you can quickly move an alternative to the top of the list of forwarders if needed. I know that some of the experts on EE recommend not having any forwarders and just letting your Windows DNS server do recursive lookups for any domain that is not defined in the local forward lookup zones.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
    This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now