• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1644
  • Last Modified:

Eclipse sql explorer plugin, mysql, and connector/j not working

I just installed Fedora RHEL 7.0.  I ahave the latest verson of eclipse....the fedora version, MySQL, and the SQl Explorer eclipse plugin.  java version is 1.5.0.  I downloaded the latest version of connector/j.

In the preferences for mysql I added the extra classpath to point to the location of where I have the connector/j jar file installed.

My SQL port is on 3306.

When I try to make a connection to a test database I get the following error.....its much longer then what I have written..

Error during query: Unexpected Exception:
java.io.CharConversionException message given: null

Nested Stack Trace:

**BEGIN NESTED EXCEPTION**

java.IO.CharConversionException

STACKTRACE:

java.io.CharConversionexception
  ........................

0
dmontgom
Asked:
dmontgom
  • 2
  • 2
  • 2
2 Solutions
 
msmolyakCommented:
Based on this thread
(http://forums.mysql.com/read.php?39,142452,143612#msg-143612)
the version of Java Eclipse uses may be different than Java 5. Please make sure you indeed use that version of Java.
0
 
adrpoCommented:

Hi,

You seem to be using gjc insead of java-sun.
See more here about the same problem:
http://forums.mysql.com/read.php?39,99174,99174

Cheers,
za-k/
0
 
dmontgomAuthor Commented:
OK,,,,,how do I tell eclipse to not use gjc java?  and to use java5 instead?

Thanks
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
msmolyakCommented:
Window->Preferences->Java->Compiler. Make sure Compliance Level of 5.0 is selected on that dialog.
0
 
adrpoCommented:

There are several java virtual machines available from:
- GNU GCC
- IBM
- SUN
You will need the one from SUN to be installed and in your path before you run Eclipse.

You need to install java-sun on your computer and use that java when you start eclipse.
You might already have it installed. You could see what java you have by typing:
$ which java

Also have a look into /usr/ib/ and /usr/lib/jvm
You should have something like jre...sun or java...sun in there.
If you have something like that, then just add its bin directory to the front of the PATH, then start eclipse.
If you don't have it, just install it using your package manager or so.

Cheers,
za-k/
0
 
dmontgomAuthor Commented:
Wanted to post coment regarding solution for others.

Basically....I got rid of the fedora eclipse version that ships with Fedore RHEL 7.0.  I also uninstalled java gjc.  I installed eclipse classic from the ecipse.org webiste and installed java from the sun website.  Within SQL Explorer Eclipse, pointed the classpath to where connector/j is and all worked fine....
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now