Avatar of garykunes
garykunesFlag for United States of America asked on

Unable to change Internet Explorer proxy settings

I have inherited a Windows 2000 Server configured as a domain server.  There was a previous proxy server in place that is no longer in use.  Internet Explorer automatically configures itself, no matter the user, with proxy settings that can NOT be changed.

I have looked at local and network policies via poledit.exe and gpedit.msc, plus everywhere else I can think of, to no avail.

Even logged on as the domain admin, I can not change the proxy settings.  They are just greyed out.

How can I get this fixed?

All info is greatly appreciated.
Windows NetworkingWeb BrowsersOS Security

Avatar of undefined
Last Comment
johnb6767

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
johnb6767

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
rpartington

Im guessing what you should be looking at is within your group policy settings.
Theres a couple of places to look, but it all depends which policy its in.
By your discription that the proxy settings are greyed out I would go for:

User Config>
Admin Templates>
Windows Components>
Internet Explorer>
Within here you may notice some settings which are enabled, these are the ones you should look at.
Check out
DISABLE CHANGING PROXY SETTINGS
DISABLE CHANGING CONNECTION SETTINGS
If you find the policy which has this setting enabled you can disable it.
However this would allow everyone to turn the proxy off.

Your actual proxy ip if its being set will be in
User Configuration
Windows Settings
Internet Explorer maintenance
Connection
In here you have the proxy setting which will hold the proxy ip and port but again this depends on which Group policy its held in.

However the above would effect all users so I would take the easy option and login as a user in a test OU and then go into the Group Policy management snap in and right click on this OU with your test user in or admin user and select Block Inheritance then reboot your pc or server and try the proxy then, if this activates it you know the setting is in one of your policies.

Then just decide which OU to put your user or users in without that particular policy assigned to that OU but leave it assigned on all other users so they dont have access to change the proxy in IE where as you will be able to.
When testing this you may have to reboot a couple of times along with running gpupdate /force
ASKER
garykunes

The registery edit worked great.  I had already tried the Policy fixes, with no success.  As I said though, the registery edit advice was just the ticket.

Thanks so much for your help and prompt response.
johnb6767

Your welcome!
Your help has saved me hundreds of hours of internet surfing.
fblack61