We help IT Professionals succeed at work.
Get Started

fsck bad or duplicate block(s)

ed987
ed987 asked
on
3,252 Views
Last Modified: 2013-12-16
at boot disk gets scanned,  bad or duplicate block(s) are reported.
it says i have to run fsck manually.

what fsck arguments should i use ?
i used "fsck /dev/sda1" "fsck -f /dev/sda1" "fsck -c /dev/sda1" but it just displayed some short data, filesystem modified and exited.
after reboot it scans again, with same errors :(

i tried tried removing problematic files manually, umount /dev/sda1 .... mount -o rw,remount /dev/sda1 , but it displays "read only filesystem".

Comment
Watch Question
CERTIFIED EXPERT
Most Valuable Expert 2014
Top Expert 2015
Commented:
This problem has been solved!
Unlock 2 Answers and 10 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE