Link to home
Get AccessLog in
Avatar of WizPrang
WizPrangFlag for United Kingdom of Great Britain and Northern Ireland

asked on

DNS forwarding

Hey,

I'm running Small Business Server 2003 and we've just replaced server. However, when some users try to access files in shared areas it's still looking for the old server.

I assume one way to solve this problem is to create a DNS record somewhere, which, when they try to access to old server (\\pluto) it would look to the new server (\\neptune).

I tried create a New Host (A)..  in the Forward Lookup Zones, which at first seemed to work, as when I pinged pluto it would ping the IP address of the new server. However, when I try to access \\pluto, it asks for username and password, of which it fails to authenticate.

Thanks in advance for your help
Avatar of Chris Dent
Chris Dent
Flag of United Kingdom of Great Britain and Northern Ireland image


Hey,

There are a couple of built in security checks in Server 2003 that cause those type of errors.

You can find full documentation of the Registry values you need to set here (just the one, DisableStrictNameChecking).

http://support.microsoft.com/kb/281308

And this one as well if you need the same thing to work from the server itself:

http://support.microsoft.com/kb/926642

Do those, then reboot and the problem should go away.

HTH

Chris
"I assume one way to solve this problem is to create a DNS record somewhere"
No, that wouldn't be the right solution in an SBS environment.  All DNS is configured automatically on SBS.  You would be putting a Band-Aid on the problem rather than resolving it.

So, please explain:  "we've just replaced server"

What was there before?

Jeff
TechSoEasy
Avatar of WizPrang

ASKER

an old, borken server. The files were transfered across.

Could I use lmhosts.sam?

No, LMHosts isn't the answer. You don't have a problem resolving the name, you just have a problem with the security settings on the server that stop it responding on anything but it's real name.

Add the registry key for Strict Name Checking then reboot. It will fix it.

Chris
The problem only occurs of *some* of the machines.

I think they're using some sort of mail merge, because when they open some Word Documents it's trying to pull information from another document. The problem is that it looks to the old server for the file and errors (ie. it looks in "\\pluto\Documents..."  rather than "\\neptune\Documents...")

First I looked in the settings of MS Word to see if it was defaulted to looking in pluto, but I found nothing. Then I tried to create a DNS forwarding record so that when it tries to access pluto, it will actually go to the IP address of neptune. This didn't work, so I figured I did something wrong..?

No, you've done it correctly.

You just need to give neptune the chance to answer as Pluto. You have the DNS part, you just need to add the registry key on the server, it's that security check that's stopping it working.

CHris
It doesn't error that it can't access the file on neptune due to authentication, it errors that it can't find pluto. Perhaps, like you said, it's because it can't authenticate; I'll try what you said.
Which one am I adding?
DisableStrictNameChecking or DisableLoopbackCheck or BackConnectionHostNames? - Those were the ones on the website you posted

DisableStrictNameChecking from the first article.

You only need to disable the Loopback check if you want to access the servers as \\Pluto when logged onto Neptune.

As it looks like you just want your network clients to be able to use \\Pluto then you don't need to worry beyond the value above.

Chris
"an old, borken server. The files were transfered across."

WAIT.

Do you mean you had a PREVIOUS SBS 2003?

You built a NEW SBS 2003 with a NEW NAME?

Then you need to remove your workstations from the OLD domain (even if you named it the same it's still the OLD domain in the eyes of those computers) and join them to the NEW domain using the SBS method of http://neptune/connectcomputer

Jeff
TechSoEasy
The old server wasn't SBS 2003; it was 2000. All the computers have been moved to the new domain.

I am currently waiting for them to go on their lunch break so I can restart the server.
The registry hack didn't work.

Any other ideas? The error states

FILENAME is a mail merge main document. Word cannot find its data source, \\Pluto\...\Merge Letmerge.doc

Now, I could select the new data source for *every file*, but isn't their an easier approach?
Make sure that there isn't a hard-coded Host entry in the workstation's SYSTEM32\Drivers\Etc\HOSTS file.

Jeff
TechSoEasy
There's nothing in the HOSTS file.

I was mistaken when I said that this problem is only affecting a couple of PC's, it's actually all of them. Could I use the HOSTS or LmHOSTS file to redirect them when they try to access \\pluto?
I tried to use lmhosts using the code:

10.10.10.3        pluto

...didn't work. Any other suggestions?
No, as stated above lmhosts is NOT the solution here.

Let's go back to your statement, " However, when some users try to access files in shared areas it's still looking for the old server."

How, EXACTLY, are they trying to access files in "shared areas"?

Jeff
TechSoEasy
They either browse to the folder through a \\neptune\Documents... and click on the file, or they do exactly the same via Word.

Basically, when they open the file, Word is seeking for another document (on pluto), because of mail merge or something. Is there any easy way for Word to look at neptune, instead of pluto, without having to redirect the source of every document?
Well, it may not have anything to do with a "mail merge or something".  What is configured as the default "TEMPLATE" directory in Word?  Because perhaps the "normal.dot" template was stored in \\pluto?  

normal.dot is the default settings template for all word documents.

See http://support.microsoft.com/kb/826839 if you are using Word 2003.

or http://office.microsoft.com/en-us/word/HP030827251033.aspx for Word 2007

Jeff
TechSoEasy



Yeah, I've tried looking for that, but all the locations are local (ie. on the individual computers).

I think there must be something each of the files that reference the other files, that search for the file using the full pathname.
ie. When a file is opened, it tries to reference another file, which is on pluto. That's why I was wondering if there a way for it to point to neptune when it looks up pluto.
ASKER CERTIFIED SOLUTION
Avatar of WizPrang
WizPrang
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This content is only available to members.
To access this content, you must be a member of Experts Exchange.
Get Access