troubleshooting Question

How to direct VoIP traffic to correct router interface

Avatar of myin68
myin68Flag for United States of America asked on
RoutersVoice Over IPSwitches / Hubs
4 Comments1 Solution1333 ViewsLast Modified:
I have a VoIP box that connects to a Cisco 2950 switch that connects to my internet router, a Cisco 2620XM with 2 WAN interfaces.  I've configured the router with"ip load-sharing per-packet" on each WAN interface to split my outgoing traffic 50-50 between my 2 ISP providers.  I think that's causing problems with my VoIP because during business hours (8-5 PM EST), VoIP conversations are really choppy or non-functional.  After hours it works normally.  I'm thinking I need to direct all my VoIP across only 1 interface instead of splitting it... what do you think?  If you agree, how do I configure my router to not load-share only VoIP traffic?  I've included my current sanitized router config ommitting the stuff I thought wasn't relevant ....

version 12.4
!
resource policy
!
clock timezone est -5
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
class-map match-any SDMTrans-Serial0/0
 match protocol citrix
 match protocol finger
 match protocol notes
 match protocol novadigm
 match protocol pcanywhere
 match protocol secure-telnet
 match protocol sqlnet
 match protocol sqlserver
 match protocol ssh
 match protocol telnet
 match protocol xwindows
class-map match-any SDMTrans-Serial0/1
 match protocol citrix
 match protocol finger
 match protocol notes
 match protocol novadigm
 match protocol pcanywhere
 match protocol secure-telnet
 match protocol sqlnet
 match protocol sqlserver
 match protocol ssh
 match protocol telnet
 match protocol xwindows
class-map match-any SDMVoice-Serial0/0
 match protocol rtp audio
class-map match-any SDMVoice-Serial0/1
 match protocol rtp audio
class-map match-any SDMScave-Serial0/0
 match protocol napster
 match protocol fasttrack
 match protocol gnutella
class-map match-any SDMScave-Serial0/1
 match protocol napster
 match protocol fasttrack
 match protocol gnutella
class-map match-any SDMRout-Serial0/0
 match protocol bgp
 match protocol egp
 match protocol eigrp
 match protocol rip
 match protocol rsvp
class-map match-any SDMRout-Serial0/1
 match protocol bgp
 match protocol egp
 match protocol eigrp
 match protocol rip
 match protocol rsvp
class-map match-any SDMBulk-Serial0/0
 match protocol exchange
 match protocol ftp
 match protocol irc
 match protocol nntp
 match protocol pop3
 match protocol printer
 match protocol secure-ftp
 match protocol secure-irc
 match protocol secure-nntp
 match protocol secure-pop3
 match protocol smtp
 match protocol tftp
class-map match-any SDMBulk-Serial0/1
 match protocol exchange
 match protocol ftp
 match protocol irc
 match protocol nntp
 match protocol pop3
 match protocol printer
 match protocol secure-ftp
 match protocol secure-irc
 match protocol secure-nntp
 match protocol secure-pop3
 match protocol smtp
 match protocol tftp
class-map match-any SDMManage-Serial0/1
 match protocol dhcp
 match protocol dns
 match protocol imap
 match protocol kerberos
 match protocol ldap
 match protocol secure-imap
 match protocol secure-ldap
 match protocol snmp
 match protocol socks
 match protocol syslog
class-map match-any SDMManage-Serial0/0
 match protocol dhcp
 match protocol dns
 match protocol imap
 match protocol kerberos
 match protocol ldap
 match protocol secure-imap
 match protocol secure-ldap
 match protocol snmp
 match protocol socks
 match protocol syslog
class-map match-any SDMIVideo-Serial0/0
 match protocol rtp video
class-map match-any SDMIVideo-Serial0/1
 match protocol rtp video
class-map match-any SDMSVideo-Serial0/0
 match protocol cuseeme
 match protocol netshow
 match protocol streamwork
 match protocol vdolive
class-map match-any SDMSVideo-Serial0/1
 match protocol cuseeme
 match protocol netshow
 match protocol streamwork
 match protocol vdolive
!
!
policy-map SDM-Pol-Serial0/0
 class SDMManage-Serial0/0
  bandwidth remaining percent 5
  set dscp cs2
 class SDMRout-Serial0/0
  bandwidth remaining percent 5
  set dscp cs6
 class SDMTrans-Serial0/0
  bandwidth remaining percent 50
  set dscp af21
 class SDMVoice-Serial0/0
  priority percent 58
  set dscp ef
policy-map SDM-Pol-Serial0/1
 class SDMManage-Serial0/1
  bandwidth remaining percent 5
  set dscp cs2
 class SDMRout-Serial0/1
  bandwidth remaining percent 5
  set dscp cs6
 class SDMTrans-Serial0/1
  bandwidth remaining percent 50
  set dscp af21
 class SDMVoice-Serial0/1
  priority percent 58
  set dscp ef
!
!
interface FastEthernet0/0
  ip address xxx
 ip flow ingress
 ip flow egress
 speed 100
 full-duplex
 no cdp enable
!
interface Serial0/0
  bandwidth 1544
 ip address xxx
 ip load-sharing per-packet
 ip nbar protocol-discovery
 encapsulation ppp
 ip route-cache flow
 no dce-terminal-timing-enable
 no cdp enable
 service-policy output SDM-Pol-Serial0/0
!
interface Serial0/1
 bandwidth 1544
 ip address xxx
 ip load-sharing per-packet
 ip nbar protocol-discovery
 encapsulation ppp
 ip route-cache flow
 no dce-terminal-timing-enable
 no cdp enable
 service-policy output SDM-Pol-Serial0/1
!
router bgp xxx
 bgp log-neighbor-changes
  !
 address-family ipv4
 no auto-summary
 no synchronization
 network xxx
 exit-address-family
 !
 address-family nsap
 maximum-paths 4
 no synchronization
 exit-address-family
!
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 Serial0/1
ip route xxx Serial0/0
!
control-plane
!
end

ASKER CERTIFIED SOLUTION
greekstones

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 4 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros