Solved

Allow Microsoft VPN Access Through ASA5505

Posted on 2007-11-13
2
1,089 Views
Last Modified: 2010-08-05
Hello,

I am behind an ASA5505 and need to access a customers network using the standard Microsoft VPN Client.

Please can you help with my config - see below :

asdm image disk0:/asdm521.bin
no asdm history enable
: Saved
:
ASA Version 7.2(1)
!
hostname LynxsAU
domain-name LynxsAU.Local
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group Lynxs
 ip address pppoe setroute
!
interface Ethernet0/0
 switchport access vlan 2
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/1
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/2
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/4
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/5
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/6
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/7
 no nameif
 no security-level
 no ip address
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone EST 10
clock summer-time EDT recurring last Sun Oct 2:00 last Sun Mar 3:00
dns server-group DefaultDNS
 domain-name LynxsAU.Local
same-security-traffic permit intra-interface
object-group service TTMessenger tcp-udp
 description TT Messenger Protocols
 port-object range 10822 10822
 port-object range 5059 5061
object-group service uTorrent tcp-udp
 description uTorrent Ports
 port-object range 51958 51958
access-list inside_nat0_outbound extended permit ip any 10.1.1.128 255.255.255.192
access-list inside_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_cryptomap extended permit ip any 10.1.1.128 255.255.255.192
access-list inside_access_in extended permit tcp host 10.1.1.251 any eq smtp
access-list inside_access_in extended permit tcp any any eq www
access-list inside_access_in extended permit tcp any any eq domain
access-list inside_access_in extended permit tcp any any eq pop3
access-list inside_access_in extended permit tcp any any eq https
access-list inside_access_in extended permit udp any any eq domain
access-list inside_access_in extended permit tcp host 192.168.10.201 eq 49221 host 10.1.1.201 eq 49221
access-list inside_access_in extended permit tcp host 192.168.10.201 eq 49221 host 192.168.10.201 eq 49221
access-list inside_access_in extended permit tcp any any eq 3101
access-list inside_access_in extended permit tcp any any eq pptp
access-list inside_access_in extended permit gre any any
access-list inside_access_in extended permit udp any any eq isakmp
access-list inside_access_in extended permit udp any any eq 4500
access-list inside_access_out extended permit tcp any host 121.x.x.xeq smtp
access-list inside_access_out extended permit tcp host 10.1.1.201 eq 49221 host 192.168.10.201 eq 49221
access-list inside_access_out extended permit tcp host 10.1.1.251 any eq 3101
access-list outside_access_in extended permit tcp any any eq 3101 inactive
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit gre any interface outside
access-list outside_access_in extended permit tcp any interface inside eq pptp
access-list outside_20_cryptomap extended permit ip 10.1.1.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_cryptomap_1 extended permit ip any 10.1.1.128 255.255.255.192
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN-DIAL 10.1.1.150-10.1.1.160 mask 255.255.255.0
asdm image disk0:/asdm521.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 10.1.1.251 smtp netmask 255.255.255.255
static (inside,outside) tcp interface www 10.1.1.251 www netmask 255.255.255.255
static (inside,outside) tcp interface https 10.1.1.251 https netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route inside 10.1.2.1 255.255.255.255 10.1.2.201 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy Adaptec internal
group-policy Adaptec attributes
 vpn-tunnel-protocol IPSec
group-policy LynxsAU internal
group-policy LynxsAU attributes
 wins-server value 10.1.1.250
 dns-server value 10.1.1.1 10.1.1.250
 vpn-tunnel-protocol IPSec
 default-domain value LynxsAU.Local
username password encrypted privilege 15
username attributes
 vpn-group-policy LynxsAU
http server enable
http 10.1.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set peer x.x.x.x
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 40 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group LynxsAU type ipsec-ra
tunnel-group LynxsAU general-attributes
 address-pool VPN-DIAL
 default-group-policy LynxsAU
tunnel-group LynxsAU ipsec-attributes
 pre-shared-key *
tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
 pre-shared-key *
tunnel-group Adaptec type ipsec-ra
tunnel-group Adaptec general-attributes
 address-pool VPN-DIAL
 default-group-policy Adaptec
tunnel-group Adaptec ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
vpdn group Lynxs request dialout pppoe
vpdn group Lynxs localname
vpdn group Lynxs ppp authentication pap
vpdn username password store-local
dhcpd auto_config outside
!
dhcpd address 10.1.1.2-10.1.1.129 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
client-update enable
prompt hostname context
Cryptochecksum:571940f6c18a2feb36763de8a8f3aab1
: end

0
Comment
Question by:nickbeentjes1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 20276409
Issue the following commands from config mode:

policy-map global_policy
class inspection_default
inspect pptp
0
 

Author Comment

by:nickbeentjes1
ID: 20276465
Nice - Thx
0

Featured Post

Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question