Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

OWA works with VPN, but not without... also changes the URL in the browser

Posted on 2007-11-13
6
Medium Priority
?
522 Views
Last Modified: 2012-05-05
Ugh... getting Exchange 2007 to work has not been fun for me, and if it wasn't for you experts, I'd have already unloaded several .45 rounds into the server. I have but on final problem left: using OWA without VPN. I'm getting the same problem as this fellow was having, although his solution isn't working for me:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21605131.html

Let's pretend that my exchange server is named "headache" and the domain name in question is "patheticpay.com"

When attempting to access OWA via the web browser with a VPN connection to the network, I can access it just fine using the old OWA address that worked with Exchange 2003: https://mail.patheticpay.com/exchange

However I notice that it immediately changes the URL in address bar to: https://headache.domain.local/owa

That works fine, because of the VPN connection... however... when using https://mail.patheticpay.com/exchange without a VPN connection to the network, it immediately brings up a login box asking for name and password. After inputting them correctly, it does this again. So inputing it correctly a second time, the address bar immediately changes into https://headache.domain.local/owa - and that won't work without VPN.

So I tried using the solution that jwmorgan77 said worked for him  changing the internal OWA address (changing it from https://headache.domain.local/owa to https://mail.patheticpay.com/exchange in this example)  but it causes a crazy error for me: the browser (if it's IE) starts to infinitely call on https://mail.patheticpay.com/exchange until the ISA server bombs out and tells the browser it's making too many requests in too short a time... basically no go. Firefox says the browser is making a request that will never complete.

So the OWA works with VPN... but not without.  Where do I begin my search to fix this last problem of mine?
0
Comment
Question by:Nargrakhan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 22

Expert Comment

by:ATIG
ID: 20276450
sounds like you have CAS and MBX insatlled on the 07 server?

do you only have a single 2003 server?

There is a know issue when installing CAS/mbx on the same server and proxing to the 2003 server the dll will not work properly and will use the internal name which it appears you are seeing and is the reason you can access it via vpn.

If you test logon to a 2007 mbx it will work because you are not being redirected
0
 
LVL 22

Accepted Solution

by:
ATIG earned 2000 total points
ID: 20276467
0
 

Author Comment

by:Nargrakhan
ID: 20276545
That's exactly my problem!

So the only solution is to buy another license of Exch2007 and install it? Ugh... that is not gonna make the boss happy. In fact, I'm 100% certain he will throw a fit and order the reinstall of Exch2003. It was already hell to get the $$$ for a new server and the software.

 Not pretty... not pretty at all... *sigh*

Ah well... asked a question, got the answer. So points are yours.

I officially hate Microsoft for this though... they never mentioned I needed TWO servers in the seminar...
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:Nargrakhan
ID: 20276594
Oh! Wait a sec... something just dawned on me though... does this only apply when you have a 2003 AND a 2007 running? Because I only have a 2007 - the 2003 server blew up shortly after the 2007 was brought online and migrated the mailboxes and public folders over.

It seems - at least from how I'm reading it - that my Exch2007 still thinks there's a 2003 around. If this is case, is there a way I can stop that?
0
 

Author Comment

by:Nargrakhan
ID: 20276664
Ah! Nevermind!

After reading more into the article you provided, I found this:

http://technet.microsoft.com/en-us/library/bb310763.aspx

Then I learned that doing https://mail.patheticpay.com/owa will work.

Thanks ATIG! Would have totally gone on the wrong track without ya (and probably broken something).
0
 
LVL 22

Expert Comment

by:ATIG
ID: 20277241
once you move everyone to 2007 you wont have this problem any more, its just the the exprox can not do the redirect to the 2003 server properly when the mbx role is on the box.....

you could setup 1 url for 2003 and 1 for 2007 as an interm or .... start moving users to 2007 and once everyone is on 07 you will be fine.

0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
This video discusses moving either the default database or any database to a new volume.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question