• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 430
  • Last Modified:

Prevent Blue Border on Linked Image

Hi all.

How do I prevent the blue border showing on a linked image?  An example of the problem is here.
http://www.ashley-wedding-cars.co.uk/wedding-information-center/best-man/template.php

Many thanks
0
jezella
Asked:
jezella
  • 3
  • 3
  • 3
  • +3
3 Solutions
 
mrichmonCommented:
<img style="border-width: 0px;" ... />

or add a class in your stylesheet, or apply to all images:

img { border: solid 0px #FFFFFF; }

We do that and then override on the images we do want a border, but that causes no border by default on all images, unless they have an overriding class/style.
0
 
cezarFCommented:
try
<style type="text/css">
<!--
A{text-decoration:none}
-->
</style>
0
 
gamebitsCommented:
add

border="0"

to the tag
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
cezarFCommented:
0
 
cezarFCommented:
oops sorry, didn't notice linked image at first.
0
 
jezellaAuthor Commented:
Tried those as here.

div.Wrapper div.Head div.RightImage
      {
      float:    right;
      position: relative;
      border:0;
      border-width:0;
      }
      
      a{text-decoration:none}
0
 
oceanbeachCommented:
Hello jezella,

If none of the above suggestions work, try adding this css...

img { border: none; }

I hope this helps!

oceanbeach
0
 
rucky544Commented:
it will need to be:

.RightImage img
      {
      float:    right;
      position: relative;
      border:none;
      }

Assuming the img is inside a div with the class RightImage
0
 
mrichmonCommented:
Setting the width to 0px is better than none, because for some reason there is a bug in IE that causes problems with no border, but accepts a width of 0px.
0
 
jezellaAuthor Commented:
Most answers were good. Part of my problem was that my DOCTYPE is strict.  I've now sorted this with the following.

.RightImage img
      {
      float:    right;
      position: relative;
      border:none;
      }

Many thanks

AJ
0
 
jezellaAuthor Commented:
Many thanks to all as usual. I also had another problem but the answers you have provided have helped me understand CSS better.

Many thanks all.

AJ
0
 
mrichmonCommented:
I am suprised that you did not split with my comment as well.  Instead you picked two duplicate answers, which are known to have some issues.  Wouldn't a split between two different answerws have been better?

Oh well.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 3
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now