?
Solved

Remove Passport Authentication from IIS6

Posted on 2007-11-13
5
Medium Priority
?
795 Views
Last Modified: 2008-02-01
Hi

I have a webserver running IIS 6. I was trying to use .NET Passport authentication for a site, but I decided that its not what I want. I unticked the box, but now all of my sites on that server are coming up with the .NET authentication box!

Normally that wouldnt be a problem, because you can just enter the full account name (i.e. username@domain.com) and it works, except my users dont know this and will try to enter their email addresses which will fail.

Can someone please tell me how to get rid of it and get it back to Standard Windows Authentication?



Thanks

Elliot Segler
0
Comment
Question by:elliotsegler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 2

Accepted Solution

by:
deankas earned 1000 total points
ID: 20277839
Not sure why its happening, but the good thing is you can easily restore your iis 6.0 settings to whatever they were before because iis 6.0 automatically creates a backup each time you make changes and keeps ten history files from which you can do a restore. Determine what time you made the change and follow these instructions for restoring. http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/cc0b0c9c-f078-4a58-8898-19c9d6aa8ee4.mspx?mfr=true

Once you have restored to version of the metabase before you enabled .net passport authentication the problem will be fixed.
0
 
LVL 3

Author Comment

by:elliotsegler
ID: 20278017
Thanks for the response, except I cant afford to loose the configuration I have now (I kept on configuring things after it happened) and its taken me hours...

Is there any other way to fix it?
0
 
LVL 2

Assisted Solution

by:deankas
deankas earned 1000 total points
ID: 20284580
Check your web.config file for the tag <authentication> as shown below:


<authentication mode=Passport>

Try replacing passport with none.

0
 
LVL 3

Author Comment

by:elliotsegler
ID: 20287117
I cannot find a web.config file on my IIS 6 Server
0
 
LVL 3

Author Comment

by:elliotsegler
ID: 20287198
Hi

This has been resloved. I will award points for contributions
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question