Solved

Backup Exchange 2007 won't flush logs using 11D

Posted on 2007-11-13
23
986 Views
Last Modified: 2013-12-01
Hello All

I have gone through most if not all of the threads on Backup Exec 11d, and Exchange 2007 issues.

Mine seems to be a bit unique.

Backing up Exchange 2007 (SCC) cluster 4 active 1 passive. Jobs runs and completes with no errors, but the logs are not getting flushed. We are doing "full" backups, and have it set as such within Backed Exec to flush the logs.

But no dice, logs are never truncated..

NT backups are running for now nightly and works perfectly, and flushes the logs.

Any ideas?

Im sorry i ahve nothing to go on because there are no errors.

Any help is greatly appreciated..
0
Comment
Question by:allwireless
  • 11
  • 6
  • 3
  • +2
23 Comments
 
LVL 7

Expert Comment

by:tcicatelli
ID: 20277293
Stupid question.  Do you have the backup agent for Exchange?  Backup Exec will not properly backup Exchange without the optional agent.
0
 
LVL 7

Expert Comment

by:tcicatelli
ID: 20277303
I did find this in another area of Experts Exchange:
"
Hmm, two years and this is the first time it has happened. Maybe you have reached the max number of  log generation of 1048559 (0x000FFFEF), i.e. Log sequence numbers have almost been completely consumed. If that is the case then you have to create a new storage group.

Assume your database is on E:\exchsrvr\SG1, so what you have to do is,
Wait for backup to complete.
Run msxstop, ensure IS stops gracefully.
Rename E:\exchsrvr\SG1 to SG1_old
Create E:\exchsrvr\SG1 directory
Run msxstart.
Checkout. Logfile sequence will now restart at the begining.

Assuming this is your problem then this is the correct method to restart your store."
0
 

Author Comment

by:allwireless
ID: 20277306
Well, here's the thing. Exchange is licensed when looking at the licensing screen, but there is no seperate Exchange agent that we can find to deploy.

We deployed the Windows agent, and Advanced Open File agent. I have been reading around about this, and many posts ( on other sites ) say there is no Exchange agent, it just has to b licensed.

Do you know different?


0
 

Author Comment

by:allwireless
ID: 20277317
tcicatelli:

This is a new install of Exchange 2007, with only 10 test user accounts. No real data, and the logs are only about 8mb.

I don't think this is my issue..
0
 
LVL 104

Accepted Solution

by:
Sembee earned 250 total points
ID: 20279020
The way that Backup Exec works is that the options are hidden until you enter the key. The only thing that you have to install on remote machines are Windows Remote Agent. Do ensure that you are doing an Information Store backup, as that is the only one that flushes the logs.

Simon.
0
 
LVL 3

Assisted Solution

by:GibbsSupport
GibbsSupport earned 125 total points
ID: 20280552
be sure that you are running release BE 11D Version 7170.

If you are running the prior release of 11d you will not be able to see exchange store listed under the backup selections. This because exchange 2007 was not supported until the 7170 release of 11d.

Without choosing the "information store" from the the backup selection BE will not FLUSH the logs. It will instead backup them and the database us as normal files.

Also make sure you have the Microsoft Exchange Server MAPI Client and Collaboration Data Objects package version 06.05.7888  installed on your exchange servers.

And that you have an dedicated Backup Exec user account with a MAILBOX on the exchange cluster that has Exchange Admin rights.

Good Luck
0
 
LVL 28

Assisted Solution

by:honmapog
honmapog earned 125 total points
ID: 20283141
You're right - there is no separate agent to install. The feature just needs to be licensed (which installs the Exchange agent on the main server).

To solve your problem: Try to uncheck the "Advanced Open File Option" for your Exchange Information Store backup job. That worked for me on all occasions I came across this with Exchange 2003. I've not seen the problem with 2007 yet.
If you need AOFO for the other resources you back up, just split the job off into 2 peices. Exchange without AOFO, and everything else with AOFO.
0
 

Author Comment

by:allwireless
ID: 20283789
Thanks for all the advice from everybody so far.

GibbsSupport:
Without choosing the "information store" from the the backup selection BE will not FLUSH the logs. It will instead backup them and the database us as normal files.

I don;t see "information store" I see file shares / drives of the storage folders.
Example:
G:\MBX1-SG1\Database


honmapog - I have tried several times to also uncheck the AOFO, and still no luck.
0
 
LVL 3

Expert Comment

by:GibbsSupport
ID: 20284013
You will have to un mount to info store for that to happen. But you should choosing infomration store from your selction list. That is best practice

if you dont see infomation store follow the instructions i had before about verifying your on version 7170 of Backup exec and have all your pre req on Backup Exec 11d and Exechange 2007 done.

Like you i had a simliar issue with not being able to see Information Store from the selection list, it was due having a older version of 11D and not 7170.


Good Luck
0
 

Author Comment

by:allwireless
ID: 20284059
GibbsSupport:

I would like to do online backups, thus the reason for 11d. I would be happy to select "information store" if it was there.

I have verified several times i am on 7170 build.

Not sure what else to do.
0
 
LVL 3

Expert Comment

by:GibbsSupport
ID: 20284145
are you running this backup exec service on a 32 or 64 bit machine?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:allwireless
ID: 20284170
This is a windows 2003 server standard 32 bit. Separate backup server dedicated to backups.
0
 
LVL 3

Expert Comment

by:GibbsSupport
ID: 20284229
https://forums.symantec.com/syment/board/message?board.id=115&message.id=18966

have you installed a the BE agent on all of your exhange nodes?
0
 

Author Comment

by:allwireless
ID: 20284296
Yes, we have the agents deployed to all the exchange servers. We even tried a seperate job with just a single mbx server being backed up..

Same result - no log truncation..

I think i need a new backup solution. This just doesn;t make any sense, and refuses to work for me.

Any other backup software you guys can recommend i look at?
0
 
LVL 3

Expert Comment

by:GibbsSupport
ID: 20284349
Just for fun do you have another server you can install BE on and try a backup to disk option? this is purely for troubleshooting.

0
 

Author Comment

by:allwireless
ID: 20284405
unfortunately no.. i am very close to doing a complete uninstall, and re-install though.

I may re-image the drive tomorrow to bring it back to a clean OS state, and do a new install.

What other 3rd party programs are available to backup Exchange 2007 that are reliable?
0
 
LVL 3

Expert Comment

by:GibbsSupport
ID: 20284458
nt backup is ok
0
 

Author Comment

by:allwireless
ID: 20284469
Thata what im using now until i get some 3rd party software to work.

I am looking for 3rd party software though..
0
 
LVL 28

Expert Comment

by:honmapog
ID: 20291336
Let me summarize:
You have a dedicated backup server and a remote Exchange server.
Backup Exec 11d build 7170 is installed on the Backup server. The remote agent is installed on the Exchange server.
When you browse the selection list, and select the remote Exchange server, you can see drives (c:, g:, ...) and network shares. You cannot see an "Information Store" entry in the selection list.


Have you verified that the remote agent on the Exchange server is also at build 7170. To check this, open the selection list, browse to the Exchange server, right-click it and choose properties. At the bottom of the dialog you'll see the version of the file. Make sure it's 11.0.7170.x

If that's OK, check what account the "Backup Exec Remote Agent" service is started with on the Exchange server. Localsystem is preferred.
0
 

Author Comment

by:allwireless
ID: 20294204
honmapog:

Yes, your summary is correct.
I have just checked the agent version, and confirm it is 11.0.7170.0

Right now i have the jobs running as dom\administrator
0
 

Author Comment

by:allwireless
ID: 20294228
The agent is logon as "local system"
0
 
LVL 28

Expert Comment

by:honmapog
ID: 20303915
Can you check if "Restrict Anonymous Support" is enabled on all cluster nodes and the Backup Exec server: http://seer.support.veritas.com/docs/238618.htm.
If not, enable it and restart Backup Exec services on all servers involved.
0
 

Author Comment

by:allwireless
ID: 20304940
Well, It seems I am an idiot!

This whole time i thought i should be backing up the stores off of the MBX server. But after looking at it again in the selection list, it seems i should have been backing up the virtual servers.

Like i said this is an active passive cluster. 4 Active, 1 passive.

Once i looked in the virtual servers, i saw "Information Store"

Running a backup now, but im sure it will work this time..

So, that leaves the question.. What do i do with the points..
I think i should divide them evenly between
GibbsSupport:
and
honmapog:
and
Sembee

Sembee was actually the onw who started me on the whole "information store" path as the problem..
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now