Solved

I have just setup initial asa, I need to have Terminal Services work. I have problems connecting.

Posted on 2007-11-13
2
351 Views
Last Modified: 2013-11-21
I have just setup initial asa, I need to have Terminal Services work. I have problems connecting.

Config

: Saved
:
ASA Version 7.2(2)
!
hostname bullitproof
domain-name tst
enable password pJ5.MVc3/8kd75Iq encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name bullittechs.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service RDP tcp
 port-object range 3389 3389
access-list outside_access_in extended permit tcp interface outside eq 3389 host 192.168.1.2 eq 3389
access-list acl_outside extended permit icmp any 192.168.1.0 255.255.255.0 echo
access-list acl_outside extended permit icmp any 192.168.1.0 255.255.255.0 time-exceeded
access-list acl_outside extended permit icmp any 192.168.1.0 255.255.255.0 unreachable
access-list acl_outside extended permit udp any host 192.168.1.2 eq domain
access-list acl_outside extended permit tcp any host 192.168.1.2 eq smtp
access-list acl_outside extended permit tcp any host 192.168.1.2 eq pop3
access-list acl_outside extended permit tcp any host 192.168.1.2 eq nntp
access-list acl-out extended permit tcp any host 192.168.1.2 eq 3389
access-list inside_access_out extended permit tcp host 192.168.1.2 object-group RDP interface outside object-group RDP
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask 255.255.255.255
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.3-192.168.1.129 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect http
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:8c2debc7b2c6dc94d5085abbef23543f
: end
asdm image disk0:/asdm-522.bin
no asdm history enable

Syslog displays  4      Nov 14 2007      05:37:33      106023      75.219.17.150      71.72.253.60       Deny tcp src outside:75.219.17.150/1693 dst inside:71.72.253.60/3389 by access-group "outside_access_in" [0x0, 0x0]

0
Comment
Question by:ltbullit
  • 2
2 Comments
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 20278522
Your config looks fine to me? on the server can you do the following

1. Start > Run > Regedit {enter}
2. Navigate to HKLM \ System \ Current Control Set \ Services \ TCPIP\ Parameters
3. In the right hand pane, Right Click > New > DWORD
4. Call it EnablePMTUBHDetect set its hex value to 1
5. Reboot the server

you should only need to do this on the server - but if it still does not wotk you can try setting it on the client as well though you shouldnt need to.

though I cant see what this line is doing?
access-list acl-out extended permit tcp any host 192.168.1.2 eq 3389


Theres no need to do this

access-list inside_access_out extended permit tcp host 192.168.1.2 object-group RDP interface outside object-group RDP

so remove it like this

no access-list inside_access_out extended permit tcp host 192.168.1.2 object-group RDP interface outside object-group RDP
no object-group service RDP tcp


and put in the following

access-list outbound extended permit tcp host 192.168.1.2 any eq 3389
access-group outbound in interface inside
write mem
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 20298418
ThanQ
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Radius ASA Authentication Failed 4 63
Etherchannel trunking 10 41
Configuring routing and ACL for Cisco 891 router 15 47
Expanding Subnet Mask 20 41
From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now