?
Solved

Stop Desktop.ini file from being regenerated

Posted on 2007-11-14
5
Medium Priority
?
1,807 Views
Last Modified: 2008-02-01
Hi everyone.
I am having a problem where Network home folders are being renamed to 'Documents'.  I have found out that this is a problem with the Desktop.ini file which is generated in their home folder.  When I delete the desktop.ini file the folder name reverts back their username which is correct.  Problem is... when the user logs off and back on again, the Desktop.ini file is regenerated... how do I stop this ?
Please see this link for details of my problem:
http://www.edugeek.net/index.php?name=forums&file=viewtopic&t=9452&view=next
Thanks
0
Comment
Question by:PURIM-E
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 59

Expert Comment

by:LeeTutor
ID: 20279583
Perhaps it is only a matter of editing the contents of the Desktop.ini file and resaving it.  It is an ASCII text file readable by Notepad.  Copy and paste the contents of the file to your next comment.
0
 

Author Comment

by:PURIM-E
ID: 20287774
Hiya... this is the contents of the file:


[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769
IconResource=%SystemRoot%\system32\imageres.dll,-183


Editing the file for each user will be a bit of a a pain.
0
 
LVL 59

Accepted Solution

by:
LeeTutor earned 1500 total points
ID: 20289075
Found an interesting Previously Answered Question at E-E of a somewhat similar nature:

http://www.experts-exchange.com/Networking/Novell_Netware/Q_22687315.html
shell32.dll,-12693   shows up as HOME folder name in My Computer

From one of the comments by expert ShineOn:

Windows won't bother reading the desktop.ini of any folder that doesn't have the read-only attribute set, for some reason....




If this is true, it suggests you might get your problem resolved by turning off the read-only attribute on your Home folder.


0
 

Author Comment

by:PURIM-E
ID: 20289486
Hi there.. was not able to do this... when I untick Read only and apply... it applies it but...
when I then check the folder attributes again... the 'Read Only' attribute is ticked again - help :-)
0
 

Author Comment

by:PURIM-E
ID: 20732221
I found the best thing to do was to use a log on script that deleted the file.
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So who is this article for? If you are like most of the computer users out there, you probably only realize the meaning of 'System maintenance' after something goes wrong. This article is for you if you care about keeping your system working opti…
I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question