• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 390
  • Last Modified:

Mapping network drives to a Network Attached Storage (NAS) device in Windows 2000

Hi,

I have a Windows 2000 Professional machine and a NAS (Network Attached Storage) device on the same home network. I can map network drives that point to the NAS within Windows no problem, and they work immediately when setup (I have to choose the connect with a different username and password option).

I also choose Reconnect at Logon. However everytime I reboot I get prompted for the password for the drive mapping even though I've told it to remember the credentials. It seems to remember the username but not the password. I put it in and the drives connect straight away no problem. Is there anyway I can get Windows 2000 to remember the credentials for the NAS resource? I know in XP you can store different credentials but can't see similar funcationality in 2000?

Anyone know how to  get round this? Why does it not remember the password?
0
grjitdept
Asked:
grjitdept
  • 2
  • 2
1 Solution
 
Michael PfisterCommented:
Create a small text-file containing 1 line:

net use X: \\NAS-DEVICE\Share password  /user:NAS-DEVICE\YourUser

Replace thje drive letter, NAS device name and share and username/password with your data.
Save this file with extension .cmd, i.e. nasconn.cmd
Place the nasconn.cmd in the autostart-folder of your Windows 2000.

Hope it helps,

Michael

0
 
grjitdeptAuthor Commented:
Thanks. I did consider writing a script to do it, but was slightly wary of the security implications of having the password in plain text.

Is this behaviour to be expected in 2000 then? Is a script the best way round it?
0
 
Michael PfisterCommented:
I understand your security concerns...
I have no Windows 2000 around to check if it can work, but I've seen this fail on XP as well.

Some things you may want to check (from XP, so your system may be different!):

Is the service "Protected Storage" running?
Is the service "security Accounts" runing?

Start gpedit.msc and verify that under Computer -> Security -> Security options
"Network access: Do not allow storage of credentials or .NET passports for network authentication" is disabled
0
 
grjitdeptAuthor Commented:
Thanks - that worked fine. Worth adding though (for anyone else that does this) that by default the cmd window will be visible as it runs the cmd script, thus showing your password in the string. I called the cmd file from a vbscript in a shell with the shell parameter set to not visible, meaning the cmd script is still run but in the background - just adds a little extra security.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now