Pfile - Spfile errors

Getting the following error when trying to restart my Oracle Database.  I have been getting errors from the database complaining that it was running out of processes.  I shutdown the database and opened the spfile specific to the database having the problem.  I increased the processes from 100 to 200 and saved file.  I then attempted to restart the database.  I get the following error.

SQL> startup
ORA-01078: failure in processing system parameters
LRM-00109: could not open parameter file '/opt/oracle/OraHome1/dbs/initMXTEST.ora'

Researching the error on the web I found a possible solution.

"ORA-01078: failure in processing system parameters
There was an incorrect parameter specified in the startup file for Oracle (init<SID>.ora).
Remove the incorrect parameter or value from the init file and restart the database.
Usually the init file can be found in your %ORACLE_HOME%\database (Windows) or $ORACLE_HOME/dbs (Unix) directory.
It might be that this pfile links to antoher pfile (ifile=) or spfile (spfile=). Just follow the location to find the correct startup file.
Should you be using an spfile instead of a pfile, you can create a pfile using following command:
create pfile from spfile;
This pfile will be created in the default destination, as specified above."


I have tried to run this create command with no luck.  It does not exist in the bin directory for oracle.  Can someone give me direction on how I can restart my database successfully?

Thank you,
JaziarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

amolghadgeCommented:
Hi ,
Try this :
1)  edit the /opt/oracle/OraHome1/dbs/initMXTEST.ora ( for processes parameter ) and save it.
2) startup mount pfile=/opt/oracle/OraHome1/dbs/initMXTEST.ora
3) now create a spfile from pfile . ( create spfile from pfile ) .
4) alter database open .

I think this should work .
Let me know if u still  have a proble ,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.