[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 890
  • Last Modified:

Visual Studio 2005 not building web site

I have a web site I'm building in Visual Studio 2005.

However, when I select Build or Rebuild, all I get is:

------ Rebuild All started: Project: R:\WebApps\Dashboard\, Configuration: Debug .NET ------
Validating Web Site

Validation Complete
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========

It clearly doesn't actually build the website. If it did, it would have the line:

Building directory '/Dashboard/'.

Between the two about Validating. It would also spit out some errors, which I know are there.

So far, I've tried a number of things to fix this:
1.    Created a new site, and copied all the content into it (in case it was the .sln or .suo file causing the problem)
2.    Reset all the settings in Visual Studio (Tools | Import and Export Settings ...) I tried both C# and Web development settings. However, I did not entirely expect this to work as settings apply to all projects and...
3.    I loaded another web project, and tried building that - it worked fine. The other project was on the same web server as the problem project
4.    I deleted all the files in the .Net temp folder for this project (at %systemroot%\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files). After restarting VS 2005, the problem was still there.

Any ideas? This is really frustrating. Although the project will build on the server when the first page is requested after an update, any compilation errors are only ever presented one at a time, which makes the whole development/debug process very slow.

Help me please!
0
Adam
Asked:
Adam
  • 4
  • 4
  • 2
1 Solution
 
cmhuntyCommented:
Not an ideal solution but may get you going - can you copy all your items to another folder, create a new website in VS2005 and then add existing items and select all?

0
 
cmhuntyCommented:
Does the solution consist of just the one web project? Can you put a new web.config file in there to ensure this hasn't been messed up?
0
 
raterusCommented:
Two things you can try,

1.  Under the VS toolbar, hit "Build" | "Configuration Manager", is the "Build" checkbox checked next to your website in the release you want.

2.  Go to the "property pages" of your website.  Have you accidently unchecked "Build Web site as part of solution", under the "Build" options.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
AdamSenior DeveloperAuthor Commented:
raterus
Point 1 you suggested is OK - it is checked.
Point 2 is strange - the menu link to 'Property pages' in the 'View' menu is greyed out, but I'm not sure why. Any ideas?

cmhunty
I've already tried copying all the files into a new project, but to no avail - the problem stayed. I haven't tried the web.config replacement yet (you normally get an error when running a web app if this is corrupt) but I'l try it soon

Thanks for the responses guys!
0
 
raterusCommented:
I get to "property pages" by right-clicking my website node in the solution explorer (usually on the far right in visual studio)
0
 
AdamSenior DeveloperAuthor Commented:
raterus
That worked (to open Property Pages). However, the "Build Web site as part of solution" option is checked.

cmhunty
It seems it was the web.config file. I excluded the original, and created a new one, and it all started to work again. I copied the lines from old file to the new one a section at a time, recompiling as I went.

I turns out that this is the line that makes the difference (with obvious changes to protect the innocent!):

<identity impersonate="true" userName="domainaccount" password="somethingsecure"/>

I wouldn't have thought this impersonation would be used during a build.
I've given the account modify access to the C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\dashboard folder, and it has read access to the rest of the path to this folder by being a member of the local Users group on my PC.
It obviously works OK on the live server, as the site compiles and runs there.

Any ideas what folders this account needs access to in order to allow compilation on my PC?
0
 
cmhuntyCommented:
That's strange. If you set impersonate to false, does that still build? Trying to work out whether the problem is with the whole entity or whether its a problem with the impersonation itself.
0
 
AdamSenior DeveloperAuthor Commented:
Yep, it builds OK if I just change impersonate to false.

As I've said, I've tried to make sure the domain account that's being impersonated has all the permissions it needs to do the job, both on the web server and my PC.

I just tried adding it to the local Administrators group - I even went as far as logging off and back on again in order to ensure the group membership change had been recognised, but it still doesn't work.

Very strange.

Any other ideas would be most appreciated.
0
 
cmhuntyCommented:
Sorry, I've got no more suggestions why this may be happening. At least it's working now! ;-)
0
 
AdamSenior DeveloperAuthor Commented:
Thanks guys, both of you, for your help.
I'll have to work out how the impersonate tag affects the build process, but that's a job for another time!
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 4
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now