• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 871
  • Last Modified:

Configure outgoing mail direct via dns

I am running exchange 2003.  Recently we've been having problems with outgoing mail queing up and not leaving the building.  I spoke to my ISP who said to configure exchange to send the email directly out using DNS rather than using "mailhost.isp.com"

How do i make this change??

The exchange server is on a private network 192.168.2.xxx  we use a NAT router for incoming outgoing traffic.
0
JCSUK
Asked:
JCSUK
  • 2
1 Solution
 
kristinawCommented:
check under your routing groups and see if you have a connector there that has an entry of mailhost.isp.com, or it's ip address. if so, check the radio button above it 'use dns'. the other place to look is directly on the smtp virtual server, delivery tab, advanced. removed the smarthost entry. restart exchange services.

kris.
0
 
feptiasCommented:
There is something else you should be aware of. If your Exchange server starts sending emails directly out then you should also check that the public DNS for your mail server is correct, otherwise it will look like a spamming server and it is quite likely that some of the mail you try to send will be rejected.

The DNS records you need are something like this (remember this is the DNS for your domain on the Internet, not the internal DNS that is used by Active Directory and usually runs on the Domain Controller):
Host (A)    mailsvr1.mydomain.com    <external IP address of your NAT router>
PTR (rDNS)   <external IP address of your NAT router>   mailsvr1.mydomain.com

Then make sure your Exchange server is announcing itself as mailsvr1.mydomain.com. This is on the same form as the Smarthost entry mentioned above: SMTP Virtual Server Properties->Delivery tab->Advanced button. It is the box called "Fully qualified domain name". (I used the name mailsvr1, but you can use whatever name you want or perhaps you already have a name on an existing Host A record).

The Host (A) record is probably located on the DNS servers run by the company that your domain name is registered with. Often they provide a web control panel for making changes to your DNS. However, the PTR record is located on the DNS servers operated by your ISP. You will have to contact their tech support department and ask them to add a Reverse DNS entry for your mail server - they should know exactly what you are talking about because it is a very common request.
0
 
JCSUKAuthor Commented:
Hi sorry for taking so long to reply.
ok i've checked my A record which points to the IP of my NAT router but looking at my PTR record which should be set to my email servers domain name it appears to be set to my ISP?? ( I starred out some of my IP address info)

***.**.68.82.in-addr.arpa 82-68-**-***.dsl.in-addr.zen.co.uk. [TTL=86400]
64.8.23.***.in-addr.arpa bastion04.mail.zen.co.uk. [TTL=14400]

So looking at this can i assume i need to call my ISP and change the PTR record?

Thanks
0
 
feptiasCommented:
Your ISP should be able to fix this for you. They "own" the IP address so they are the ones that have to configure the PTR record on their name servers. It is a very common request for users who have a static IP address - they should have no trouble understanding and implementing your request.
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now