Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook Web Access not working even after rebuilding virtual IIS dirs

Posted on 2007-11-14
4
Medium Priority
?
4,079 Views
Last Modified: 2008-02-01
Hi,
We're trying our darndest to get OWA working in our environment. I know it's supposed to work out-of-the-box when Exchange is installed, but this hasn't worked in some time.

I followed MS Article ID 883380 to rebuild the OWA virtual directories, but it still doesn't work.

Here's what we get when trying to access it internally.

TEST 1) http://server.domain.local/exchange - HTTP 404 error AFTER it asks for a username/password in a pop-up.
TEST 2) http://server/exchange - HTTP 404
TEST 3) https://server.domain.local/exchange - HTTP 404
TEST 4) https://serve/exchange - HTTP 404

I must be doing something very fundamentally wrong here since it never even tries to open OWA. Any direction would be helpful.

Thanks.
0
Comment
Question by:IT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 22

Expert Comment

by:kristinaw
ID: 20281377
what happens if you just go to http://server

kris.
0
 

Author Comment

by:IT
ID: 20281615
It opens the stock SharePoint site.
0
 
LVL 1

Expert Comment

by:ParvinderSohal
ID: 20281669
> Please provide the exact complete error.  But I am listing the details scenarios, lets see if one suits your issue:
Depending on the different scenarios, the error message may be one of the
following:

HTTP 400 - Bad Request (Request Header Too Long)
HTTP 400 - Bad Request (Header Field Too Long)
HTTP 400 - Bad Request (Invalid Hostname)
HTTP 400 - Bad Request (Invalid Header)
HTTP 400 - Bad Request (The data is invalid)
HTTP 400 - Bad Request (Invalid URL)
HTTP 400 - Bad Request

To troubleshoot this issue, we should narrow down the scenario first.

Scenario 1:
========
RSA client or RSA agent is installed.

a. Uninstall the RSA web agent
b. Sometimes RSA ISAPI filter may not unload after you removing the RSA web agent.
The solution is to manually remove ISAPI filter IISWebAgentIF.dll from IIS
metabase.
c. Sometimes people say that they already disabled RSA. Disabling RSA did
not help in this kind of case. You may need to open IIS Manager, take the
properties of Default web site, Click the RSA tab and enable the checkbox (Disable
Cookie API filter).

Scenario 2:
========
Getting  HTTP 400 error while opening some specific mails in OWA.

a. If the OWA is running on IIS 6.0. You need to set the key
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\AllowRestricted
Chars to 1. By default, this value is 0 and Http.sys does not accept hex-escaped
chars in request URLs that decode to U+0000 - U+001F and U+007F - U+009F ranges.
For example: TAB

Scenario 3:
=======
Caused by invalid hostname.

a. There may be invalid host headers configured in the web site. One quick solution
is to remove all host headers and added one blank host header instead.
b. Another unusual scenario occurs when you upgrade IIS 5.0 to IIS 6.0. There is an
entry "UseHostName" in Windows 2000 IIS Metabase. The entry does not take effect in
IIS 5.0 without a hotfix. After in-place upgrade, IIS 6.0 recognizes the entry and
caused the problem. The solution is to remove the entry "UseHostName" from IIS
Metabase by running adsutil.vbs.

Cheers!
0
 
LVL 22

Accepted Solution

by:
kristinaw earned 2000 total points
ID: 20281783
sharepoint breaks owa. remove sharepoint from the box (ideally).

823265      You receive a "Page not found" error message when you use Outlook Web Access (OWA) to browse the Exchange Server 2003 client after you install Windows SharePoint Services
http://support.microsoft.com/default.aspx?scid=kb;EN-US;823265
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
This article describes how to import Lotus Notes Contacts into Outlook 2016, 2013, 2010 and 2007 etc. with a few manual steps. You can easily export and migrate Lotus Notes contacts into Microsoft Outlook without having to use any third party tools.
This video discusses moving either the default database or any database to a new volume.
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
Suggested Courses

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question