Solved

Outlook 2003 connect thru RPC over HTTPS error

Posted on 2007-11-14
13
1,022 Views
Last Modified: 2008-08-15
I have received this error using OL2003 SP2 connecting via RPC thru HTTPS to Exchange 2003 SP2 Server. My firewall allows port 80, 443 and 444 to my server. I have tested my RPC/HTTPS OL2003 config in the office with success. My external tests have no proxy or firewall intervention from the sites that I have used. Logon seems to complete fine but the error occurs at Send/Recieve call.
Any ideas?
0
Comment
Question by:tcurtispc2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +2
13 Comments
 
LVL 13

Expert Comment

by:cshepfam
ID: 20282169
port 25.  smtp.


firewall is most likely blocking that.  thats used to send your email
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20282199
Port 25 has nothing to do with RPC over HTTPS.
When you tested it internally, did you verify the connection was being made over HTTPS? With Outlook connected, hold down SHIFT and right click on the Outlook icon and choose Connection Status. That will show whether it is connecting by TCP/IP or HTTPS.

Simon.
0
 
LVL 12

Expert Comment

by:weareit
ID: 20282843
Are you able to access your server using OWA?

Are clients who are not using RPC over HTTPS able to connect to the server?

-saige-
0
Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features

 

Author Comment

by:tcurtispc2
ID: 20282924
Sembee,
You are right...port 25 has nothing to do with this. Holding down the 'Ctrl' key and right clicking on the Outlook icon - choosing Connection Status, I found the conections to be TCP/IP. So my internal testing was not necessarily valid...good point. Any further ideas?
0
 

Author Comment

by:tcurtispc2
ID: 20282935
OWA is working great (internal and externally) as well as internal connectivity to Exchange.
0
 
LVL 12

Expert Comment

by:weareit
ID: 20283156
Well if connectivity to the server is good with OWA and Internally then something is wrong with your RPC configuration.

As Simon has stated so many times before:
Basically RPC over HTTPS fails on three points....

- SSL certificate acceptance
- Authentication
- Registry settings.

I'd say its time to double check the configuration of your RPC services.  8004011D makes me think SSL Certificate.  What does the issued to statement in the certificate say?

-saige-
0
 

Author Comment

by:tcurtispc2
ID: 20283159
I think that I may have it...upon review of the the article: Troubleshooting RPC over HTTPS (Part 2)
I checked the Auth at RPC under IIS. It was set to Anonymous, NT Auth and Basic. It should only be Basic. I reset it properly, restarted IIS and will be heading out for remote test. I will keep all posted.
0
 
LVL 12

Expert Comment

by:weareit
ID: 20283171
Good luck
0
 
LVL 104

Expert Comment

by:Sembee
ID: 20283340
The authentication settings can actually be basic and/or integrated. If you have basic only set then the clients will always prompt. If you have integrated set and set the relevant option in Outlook (NTLM) and the client is a member of the domain then pass through authentication will work.

Simon.
0
 

Author Comment

by:tcurtispc2
ID: 20284048
Well I fixed it.

Great help from articles: Implementing RPC over HTTPS in a single Exchange Server 2003 environment, Troubleshooting RPC over HTTPS (Part 1), Troubleshooting RPC over HTTPS (Part 2) from MS Exchange.org.

Turned out to be the registry setting for:
HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\RPC\RPCPROXY.

Change the data to what is shown in the following picture. You must use Port Range 6001-6002 for the NetBIOS and DNS FQDN and Port 6004 also for the NetBIOS and DNS FQDN.

Here was my example:
[old-existing]
myserver:100-5000

[new-change to]
myserver:593;myserver:6001-6002;myserver:6004;myserver.mydomain.local:593;myserver.mydomain.local:6001-6002;myserver.mydomain.local:6004

Voila! - Works like a champ!
Thanks to all!
0
 

Author Comment

by:tcurtispc2
ID: 20284114
That's all
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 20558564
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Track who logged into an Office 365 Exchange account 2 45
exchange, squid, proxy, linux 6 35
office 365 5 16
Outlook search issues 5 11
Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question