Slow Response to Query directory located on ISCSI SAN

When I  query a folder from an XP workstation to a mapped drive on an ISCSI SAN the response time is really slow.   Using Ethereal I am seeing alot of SMB traffic and it takes approximately 45 seconds for the folder information to be viewed.  

The typical information is alot of QUERY_PATH_INFO request and response by the workstation and the server using ISCSI.

I'm getting alot of complaints from users and need to know where to start looking as I can't decipher the captured packets.
YottaYottaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
kkransConnect With a Mentor Commented:
Hi!

iSCSI uses quite some processing power (Read TCP uses quite some...)
Some iSCSI boxes hate being connected to the regular Ethernet network.

Those 2 are most commom problems with iSCSI stuff.

The 1st one is an issue when running an older computer/server or a notebook. The encapsulation of packets consume all available processing power and the thing just freezes. Use a proper TOE card to offload the processor.

2nd is true to many boxes, just try it on a separate network to be sure...

0
 
Hypercat (Deb)Commented:
What types of files are on the SAN?  Does this happen with all files on the SAN or only certain file types? Were these files recently moved from another server to the SAN?
0
 
YottaYottaAuthor Commented:
Types of files are Microsoft office files.  It is generally happening to all folders but it really shows up on directories that have alot of files in them.  

I recently moved these files from a different server with DAS to a new server attached to the ISCSI SAN.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
Hypercat (Deb)Commented:
Try setting the Web Client service on one of your workstations to "manual" or "disabled," and then stop the service, and see if it helps.  If it does, then you can disable this service on all of your workstations with no negative effect that anyone on your network will notice.
0
 
Hypercat (Deb)Commented:
PS - forgot to say you want to reboot the workstation between changing the settings and testing.
0
 
YottaYottaAuthor Commented:
Stopped Web Client service on the WS and set to disable and rebooted the workstation.  Same thing is still happening.
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.