Visual Studio automatically entering double quotes on style attribute when typing

hi there,

Visual Studio 2005.

when i am typing away in my aspx file and start typing any attribute, like Class="MyClass", I have to type the double quotes. But when i type the STYLE tag, style="text-align: right;", the quotes are auto inserted.

This is most annoying because it is in consistent. I end up typing STYLE=""test-align: right;"".
To replicate, type the following in VS source mode.
<div style=
it should look like this after your type the equals sign
<div style=""

But since I am used to having to type the double quotes for every other attribute except for style,  *rant* :), I end up over double-quoting.
Is there a way to stop VS from doing this either by
1. Stop the auto quotes from being generated on the STYEL attribute.
or
2. Able to set all other attributes to automatically generate double quotes (i think this would be prefered).

cheers
LVL 1
ValimaiAsked:
Who is Participating?
 
Jorge PaulinoConnect With a Mentor IT Pro/DeveloperCommented:
You can go to Tools -> Options -> Text Editor -> HTML -> Format and select the Tag Specific Options. Then in the Client HTML Tags you can make the changes you want (add, change, delete)
0
 
ValimaiAuthor Commented:
Thanks, option 2 can be enabled by
Tools -> Options -> Text Editor -> HTML -> Format
turn on - "Insert attribute value quotes when typing"

also, found a different option i changed as when i copy and paste html, the IDs of the controls are made unique, quite annoying.
Tools -> Options -> Text Editor -> HTML -> Miscellaneous
turn off - "Auto ID elements on paste in source view"
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.