Solved

Can't configure factory default using "configure factory-default

Posted on 2007-11-14
10
1,208 Views
Last Modified: 2011-10-03
Hi. I am using a PIX 501 and somehow the inside address is 192.168.16.1 255.255.255.0

I am having two problems:

I am trying to change to factory default and when I type the command "configure factory-default" it seems to accept it, but the inside address is still the same. Or, if I try to change the inside address by typing

ip inside addr 192.168.1.1 255.255.255.0    I just get the error message "Interface address is not on the same subnet as DHCP pool."

I can post the configuration if you need it.
0
Comment
Question by:Bert2005
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
10 Comments
 
LVL 7

Assisted Solution

by:myin68
myin68 earned 200 total points
ID: 20285710
Make sure that when you type "configure factory-default"  you're in "configuration" mode.  Alternatively, you can delete the DHCP pool with the following command in configuration mode: no dhcpd addreess <starting addr>-<ending addr> inside, where the < > is the actual ip address shown in your config, probably in the 192.168.16.1 - 192.168.16.32 range....  Once you delete the pool, you can change the inside ip to whatever you want.
0
 
LVL 1

Author Comment

by:Bert2005
ID: 20285934
myin68

Thanks. Yes, we did the factory-default thing in configuration or privileged mode. We just tried your command to get rid of the DHCP pool. It seemed to work, but then when we did a show config again, it was still there. Rebooted and was still there.

This is in hyperterminal. It just seems like nothing takes. I have never had this problem with a PIX 501 before. If it helps, if we try to use the PDM interface from a browser, it will get to the point where it is starting the PDM and then just hang there.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20285979
You need to do a "show run" instead of "show config" to see the change for the running configuration.  Until you save your changes to NVRAM using the command "write memory", the "show config" command will not show the changes.  So, here's the order to try:

no dhcpd address <start_ip>-<end_ip> inside
ip address inside 192.168.1.1 255.255.255.0
write memory

You should then be able to reload the PIX and the changes should stick.  You can also apply another DHCP pool with the following command (assuming you changed the inside to the 192.168.1.0/24 network):

dhcpd address 192.168.1.2-192.168.2.33 inside

Don't forget the "write memory" if you add that last command  ;)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:Bert2005
ID: 20286006
Thanks batry,

Dumb question. Do I add the

no dhcpd...... etc.  hit enter  then:
ip address inside....etc.   hit enter  then:

type: write memory?
0
 
LVL 1

Author Comment

by:Bert2005
ID: 20286019
Or since so many changes have occurred, should I just do the

Configure factory-default and then write memory?  And at same time or separately?
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 300 total points
ID: 20286045
Yes, you can do what you stated in your post before last...or you can do the configure factory-default.  Just remember that whatever changes you make to the firewall that you want to have come back after a reload (reboot) you need to issue the "write memory" command.
0
 
LVL 1

Author Comment

by:Bert2005
ID: 20286100
Thanks again.

We did a whole new factory default which brought the configuration AFTER write memory to

192.168.1.1 255.255.255.0

Of course there is an http 192.168.1.0 255.255.255.0

and dhcpd is 192.168.1.2-192.168.1.33

The ONLY problem is after saving with write memory and then rebooting the PIX, we still can't access the PDM using https://192.168.1.1   It gets to where it says it is opening the PDM with the hourglass, but then it just hangs...
0
 
LVL 1

Author Comment

by:Bert2005
ID: 20286975
Finally got it to work. Nothing with the PIX. Internet Explorer wouldn't let it in. Got right in using Firefox. I changed I.E.'s security settings, but it still wouldn't work on that particular PC.

Thanks.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20288372
From the CLI on the PIX, check the version of PDM you have loaded with the "show version" command.  If it shows version 3.02 or earlier, then you need to upgrade it to 3.03 or higher before IE will work...
0
 
LVL 1

Author Comment

by:Bert2005
ID: 20289008
Thanks, I will check that out and get back. This is a great example of why troubleshooting can be so difficult when a variable that is not foreseen gets in the way. For instance, here we could not browse in to PDM due to the browser, so we continued to look at the configuration. We were just configuring this router on one of my computers, so it was only when I tried to get into MY PIX and couldn't, that we knew it wasn't his router. If that makes sense.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question