• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1572
  • Last Modified:

How to mount a FreeBSD drive to a folder on a OpenSuse Linux Box

I have a FreeBSD drive that I want to get its data. I have piggybacked it as a slave to my OpenSuSE box I can see it as /dev/sdb. The partition I want is /dev/sdb1. I am trying to mount it to /home/eric/data.

I have run a series of mount commands with different switches, but obviously, I am missing something. This was one of them:

mount -t ufs /dev/sdb1 /home/eric/data

This was its output:

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


HELP!
0
emherman
Asked:
emherman
  • 5
  • 5
  • 2
  • +3
3 Solutions
 
ibu1System AdministratorCommented:
) Install hard disk to your computer
2) boot your computer
3) dmesg | less
                                         From the output, look for an indication that the new hard disk was found. For example, if it is a secound IDE, you should see "hdb" in the output.Be sure you idenify the right disk.I mean to say u should find hdb1 or hdb2,etc
from the dmesg| less output.
Make one directory where u want to mount the partition
example /home/eric/data
14) Edit the fstab file
/dev/sdb1               /home/eric/data             ext3         defaults         1 1
0
 
rindiCommented:
You could also try ext2 or auto. It depends on the filesystem the partition was formatted with. As far as I know freebsd uses ext2 and ext3 by default. If you don't have luck this way, try booting with a LiveCD like knoppix, it tries to guess the filesystems used, and then you could mount the drives there and directly copy the data you need, or you could look at what fstab shows you and then use those settings when you boot to opensuse again.

http://knoppix.net
0
 
TeRReFCommented:
I mount it like this in fstab:

/dev/sdb1  /home/eric/data  ufs  auto,rw,ufstype=ufs2, nodev,nosuid  0  0
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
rindiCommented:
Then you probably don't have the ufs filesystem module on your system, as that isn't used very commonly. You'd either have to download the kernel sources and include the ufs module, or try knoppix which may have that module included.
0
 
emhermanAuthor Commented:
I did a /cat/proc/filesystems and "ufs" was listed (and ext3). It was missing the "nodev" entry if that makes a diff.

BTW - I don't need to permanently mount the drive. I just need to get temporary access to it to pull off data and get it on the Linux box. Will I need to set up the fstab entries or can I get away with juts using the mount command?

If I load Knoppix will I still have access to the hard drive to put the data or will it run entirely off the CD?
0
 
emhermanAuthor Commented:
... did not see ufs2 listed
0
 
rindiCommented:
With knoppix you should have access to all disks that the OS sees. It loads KDE and the disks normally are shown on the desktop. Click on it and it opens. If you then right click that icon again, you should have an option to change the read/write mode of the partition (knoppix loads everything in read only mode by default). You can also mount network folders and copy the data to those if you want.
0
 
emhermanAuthor Commented:
... btw - I would just need read-only access, since I do not plan to use the drive after I get the data off.
0
 
emhermanAuthor Commented:
The drive was running FreeBSD 4.11
0
 
rindiCommented:
You will need writing access to the disk you want to copy the data to.
0
 
emhermanAuthor Commented:
OK. I tried Knoppix, and got to the desktop. I see "hdb1" on the desktop and clicked on it. I get:

------------------------------------------

Could not mount the device.

The reported error was:

mount: I could not determine the filesystem type, and none was specified

-----------------------

What now?
0
 
rindiCommented:
Try installing a small freebsd pc with just the essentials, and then try mounting the Disk there.
0
 
TeRReFCommented:
Was the drive dismounted properly? Are there any errors that might prevent proper mounting of the drive?
0
 
gheistCommented:
Boot off latest FreeBSD CD Get into recovery mode
chroot /dist
mount_devfs /dev
fsck /dev/ad0s1[a-i]
0
 
CSecurityCommented:
I had a similar problem trying to mount by FreeBSD partition from OpenSUSE

add "-r -t ufs -o ufstype=44bsd" to your mount command like this:

mount -r -t ufs -o ufstype=44bsd /dev/sdb1 /home/eric/data
0
 
gheistCommented:
One should fsck from FreeBSD anyway.  UFS2 not supported in Linux kernel.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 5
  • 5
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now