Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2398
  • Last Modified:

Arcserve Exchange Agent Error

When trying to configure the agent with a user account called 'exchangebackup' it fails with the error 'Failed to configure your server'

Exchverify.log details below, server names and domain names have been replaced.

11/15/07,09:37:44 : Exchange Server Name from Registry is[SERVERNAME]
11/15/07,09:37:44 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:44 : OpenService()  failed : errCode[1060] - errMsg[The specified service does not exist as an installed service. (0x424)]
11/15/07,09:37:44 : ERROR: ExchRemoveService() failed: return[4]
11/15/07,09:37:44 : ExchVerify() Calling ExchInstallService() to install the verification service
11/15/07,09:37:44 : servicePath = "C:\Program Files\CA\BrightStor ARCserve Backup Agent for Microsoft Exchange\VService.exe"
11/15/07,09:37:44 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:44 : CreateService() [Exchange Agent Setup Verification Service] successfully installed
11/15/07,09:37:44 : ExchInstallService() successfully finished
11/15/07,09:37:44 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:44 : OpenService() [ExchVerification] successful with all ACCESS
11/15/07,09:37:45 : RegisterServiceCtrlHandler() successful
11/15/07,09:37:45 : Service start pending
11/15/07,09:37:45 : ERROR: EnablePrivilege() AdjustTokenPrivileges Failed-1300
11/15/07,09:37:45 : ERROR: ExchSetAllPrivilege() EnablePrivilege SE_CREATE_TOKEN_NAME Failed-183
11/15/07,09:37:45 : ExchSetAllPrivilege() return error code[0]
11/15/07,09:37:45 : Trying to start Service now ......
11/15/07,09:37:45 : CreateEvent() successful
11/15/07,09:37:45 : CreateNamedPipe() successful
11/15/07,09:37:48 : StartService() SUCCESSFUL
11/15/07,09:37:48 : ExchStartService() successfully finished
11/15/07,09:37:48 : ExchAuthenticate() Begin --------------------------
11/15/07,09:37:48 : ExchAuthenticate() called with NTServerName:[SERVERNAME] NTDomainName[DOMAINNAME] adminMailbox:[exchangebackup] adminLoginName:[exchangebackup]
11/15/07,09:37:48 : Calling ExchCreateProfile() to create the Profile[EXCH_AUTHENTICATE_PROFILE46801195119468]
11/15/07,09:37:48 : The Windows NT system directory of the local server is:[C:\WINDOWS\system32]
11/15/07,09:37:48 : GetFileVersionInfoSize() for [C:\WINDOWS\system32\MAPI32.DLL] successful: return Size[2212]
11/15/07,09:37:48 : VerQueryValue() return version [6:5:7638:1]
11/15/07,09:37:48 : Doing LogonUser() and Impersonate
11/15/07,09:37:48 : LogonUser() successful to Domain[DOMAINNAME] as userName[exchangebackup]
11/15/07,09:37:48 : ImpersonateLoggedOnUser() successful
11/15/07,09:37:48 : ERROR: OpenToken() OpenProcess Failed-5
11/15/07,09:37:48 : ExchSetAllPrivilege() return error code[0]
11/15/07,09:37:48 : MAPIInitialize() successful
11/15/07,09:37:48 : MAPIAdminProfiles() successful
11/15/07,09:37:48 : CreateProfile() profile[EXCH_AUTHENTICATE_PROFILE46801195119468] successful
11/15/07,09:37:48 : AdminServices() successful
11/15/07,09:37:48 : CreateMsgService()  for msgService[MSEMS] successful
11/15/07,09:37:48 : GetMsgServiceTable() successful
11/15/07,09:37:48 : HrQueryAllRows() successful, with [1] rows returned
11/15/07,09:37:48 : ExchCheckPropertyTag() successful: Property Tag correctly match
11/15/07,09:37:48 : microsoft Exchange Service found in row [0]
11/15/07,09:37:48 : ERROR: ConfigureMsgService() return [81002746]
11/15/07,09:37:48 : ERROR: GetLastError() return [0], MAPI ERROR Message unavailable
11/15/07,09:37:48 : ExchCreateProfile() return [2128]
11/15/07,09:37:48 : MAPI is initialized: cleanup resource
11/15/07,09:37:48 : MAPIAdminProfiles() successful
11/15/07,09:37:48 : Profile [EXCH_AUTHENTICATE_PROFILE46801195119468] is deleted
11/15/07,09:37:48 : Return back from impersonation
11/15/07,09:37:48 :  RevertToSelf() successful
11/15/07,09:37:48 :  CloseHandle() successful
11/15/07,09:37:48 : ERROR: ExchCreateProfile() profile[EXCH_AUTHENTICATE_PROFILE46801195119468] return [2128]
11/15/07,09:37:48 : ERROR: ExchAuthenticate() return[2128]
11/15/07,09:37:48 : CallNamedPipeA() successful
11/15/07,09:37:48 : ---> Authentication result: [Authentication Failure: Fail to Create Profile --- Check the [ExchVerify.log ] for detail and make sure the User Mailbox Name or Alias is correct and Unique.< case sensitive!!!>]
11/15/07,09:37:48 : ExchPerformVerification() return[4]
11/15/07,09:37:48 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:48 : OpenService() [ExchVerification] successful with all ACCESS
11/15/07,09:37:48 : ExchServiceControl() called with ControlCode[1]
11/15/07,09:37:48 : ControlService() Stopping service [Exchange Agent Setup Verification Service]......
11/15/07,09:37:48 : StartServiceCtrlDispatcher() successful
11/15/07,09:37:49 : Service [Exchange Agent Setup Verification Service] stopped
11/15/07,09:37:49 : DeleteService() [Exchange Agent Setup Verification Service] removed
11/15/07,09:37:49 : ExchRemoveService() successfully finished
11/15/07,09:37:49 : Exchange Server Name from Registry is[SERVERNAME]
11/15/07,09:37:49 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:49 : OpenService()  failed : errCode[1060] - errMsg[The specified service does not exist as an installed service. (0x424)]
11/15/07,09:37:49 : ERROR: ExchRemoveService() failed: return[4]
11/15/07,09:37:49 : ExchVerify() Calling ExchInstallService() to install the verification service
11/15/07,09:37:49 : servicePath = "C:\Program Files\CA\BrightStor ARCserve Backup Agent for Microsoft Exchange\VService.exe"
11/15/07,09:37:49 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:49 : CreateService() [Exchange Agent Setup Verification Service] successfully installed
11/15/07,09:37:49 : ExchInstallService() successfully finished
11/15/07,09:37:49 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:49 : OpenService() [ExchVerification] successful with all ACCESS
11/15/07,09:37:49 : RegisterServiceCtrlHandler() successful
11/15/07,09:37:49 : Service start pending
11/15/07,09:37:49 : ERROR: EnablePrivilege() AdjustTokenPrivileges Failed-1300
11/15/07,09:37:49 : ERROR: ExchSetAllPrivilege() EnablePrivilege SE_CREATE_TOKEN_NAME Failed-183
11/15/07,09:37:49 : ExchSetAllPrivilege() return error code[0]
11/15/07,09:37:49 : Trying to start Service now ......
11/15/07,09:37:49 : CreateEvent() successful
11/15/07,09:37:49 : CreateNamedPipe() successful
11/15/07,09:37:52 : StartService() SUCCESSFUL
11/15/07,09:37:52 : ExchStartService() successfully finished
11/15/07,09:37:52 : ExchAuthenticate() Begin --------------------------
11/15/07,09:37:52 : ExchAuthenticate() called with NTServerName:[SERVERNAME] NTDomainName[DOMAINNAME] adminMailbox:[exchangebackup] adminLoginName:[exchangebackup]
11/15/07,09:37:52 : Calling ExchCreateProfile() to create the Profile[EXCH_AUTHENTICATE_PROFILE62321195119472]
11/15/07,09:37:52 : The Windows NT system directory of the local server is:[C:\WINDOWS\system32]
11/15/07,09:37:52 : GetFileVersionInfoSize() for [C:\WINDOWS\system32\MAPI32.DLL] successful: return Size[2212]
11/15/07,09:37:52 : VerQueryValue() return version [6:5:7638:1]
11/15/07,09:37:52 : Doing LogonUser() and Impersonate
11/15/07,09:37:52 : LogonUser() successful to Domain[DOMAINNAME] as userName[exchangebackup]
11/15/07,09:37:52 : ImpersonateLoggedOnUser() successful
11/15/07,09:37:52 : ERROR: OpenToken() OpenProcess Failed-5
11/15/07,09:37:52 : ExchSetAllPrivilege() return error code[0]
11/15/07,09:37:52 : MAPIInitialize() successful
11/15/07,09:37:52 : MAPIAdminProfiles() successful
11/15/07,09:37:52 : CreateProfile() profile[EXCH_AUTHENTICATE_PROFILE62321195119472] successful
11/15/07,09:37:52 : AdminServices() successful
11/15/07,09:37:52 : CreateMsgService()  for msgService[MSEMS] successful
11/15/07,09:37:52 : GetMsgServiceTable() successful
11/15/07,09:37:52 : HrQueryAllRows() successful, with [1] rows returned
11/15/07,09:37:52 : ExchCheckPropertyTag() successful: Property Tag correctly match
11/15/07,09:37:52 : microsoft Exchange Service found in row [0]
11/15/07,09:37:52 : ERROR: ConfigureMsgService() return [81002746]
11/15/07,09:37:52 : ERROR: GetLastError() return [0], MAPI ERROR Message unavailable
11/15/07,09:37:52 : ExchCreateProfile() return [2128]
11/15/07,09:37:52 : MAPI is initialized: cleanup resource
11/15/07,09:37:52 : MAPIAdminProfiles() successful
11/15/07,09:37:52 : Profile [EXCH_AUTHENTICATE_PROFILE62321195119472] is deleted
11/15/07,09:37:52 : Return back from impersonation
11/15/07,09:37:52 :  RevertToSelf() successful
11/15/07,09:37:52 :  CloseHandle() successful
11/15/07,09:37:52 : ERROR: ExchCreateProfile() profile[EXCH_AUTHENTICATE_PROFILE62321195119472] return [2128]
11/15/07,09:37:52 : ERROR: ExchAuthenticate() return[2128]
11/15/07,09:37:52 : CallNamedPipeA() successful
11/15/07,09:37:52 : ---> Authentication result: [Authentication Failure: Fail to Create Profile --- Check the [ExchVerify.log ] for detail and make sure the User Mailbox Name or Alias is correct and Unique.< case sensitive!!!>]
11/15/07,09:37:52 : ExchPerformVerification() return[4]
11/15/07,09:37:52 : OpenSCManager() successful with all ACCESS
11/15/07,09:37:52 : OpenService() [ExchVerification] successful with all ACCESS
11/15/07,09:37:52 : ExchServiceControl() called with ControlCode[1]
11/15/07,09:37:52 : ControlService() Stopping service [Exchange Agent Setup Verification Service]......
11/15/07,09:37:52 : Service is started.
11/15/07,09:37:52 : StartServiceCtrlDispatcher() successful
11/15/07,09:37:53 : Service [Exchange Agent Setup Verification Service] stopped
11/15/07,09:37:53 : DeleteService() [Exchange Agent Setup Verification Service] removed
11/15/07,09:37:53 : ExchRemoveService() successfully finished
0
partymarty84
Asked:
partymarty84
1 Solution
 
dovidmichelCommented:
Perhaps one of these things will help.

   1. Ensure that all services including the exchange backup agent service had the domain administrators account set. This meant going onto the Exchange server, accessing the agent, and on the second screen of the wizard, I added the administrator account info. It has to display a message saying something like 'Please wait while the account is verified'

   2. Go to the server running ARCSERVE manager and access a job (select modify). Under the source tab I right selected the brick level exchange 2003 under the 'Network'. I then selected 'Security' and entered username = administrator and password = *******. It is important to note that on my server it would NOT take the domain\user format, rather it just used user.

   3. Once the security settings were accepted then the brick level became expandable in the BAB (network directory selection tree). For here I was able to select the Exchange accounts that I wanted to have backed-up.

   4. As I had already verified the job details hundreds of times in the last few days, I skipped directly to 'start' the job I had just configured in the last step.

   5. When the Security and Agent Information screen appeared I checked that all the correct UserNames and Passwords were set for the different shares. This is VERY IMPORTANT: don't try to set the Agent security for the Brick Level backups on this screen! If you succeeded earlier in selecting the Brick Level accounts in the 'source' tree then you LEAVE IT ALONE on this 'Security and Agent Information' screen. Yes it will show that there is no IP assigned, but this does not matter. If you select the Microsoft Exchange Backup Agent object on this screen and select Security or Agent it WILL INTERFERE with the security that you set in step 2 and you will have to go back to step 2.

   6. I then scheduled the job and it worked like a charm
0
 
bhanukir7Commented:
Hi,

When you are trying to setup the agent the user that you are using it is not able to create the profile.
Please check if the users mail box is active and not hidden from global address list.

use the profman utility to check if there is any error with this users profile.

bhanu
0
 
partymarty84Author Commented:
Bhanu,

Good work, I knew as soon as you mentioned the hidden from GAL option that was gonna fix it.
All sorted.

For anyone else with the same issue who's not sure where to hide the user from the global address list do the following:

1. Go to Active Directory Users & Computers on the Exchange server (or a mail enabled version elsewhere)
2. Go to Properties of the user account.
3. Click on the Exchange Advanced tab.
4. Uncheck the box!
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now