Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3303
  • Last Modified:

Can't recieve outside email

Hello, I discovered yesterday that our organization was unable to recieve emails sent from external sources. Are configuration is Firewall->Barracuda Spam Filter->Exchange mail server. In my tests so far, I have found that our DNS is correct. Emails sent from an outside source are let through the spam filter. This means that mail is making it through the firewall and then through the spam filter. There they dissapear. The senders are not recieving any type of error message about the email. I have check the queues of the exchange server and can still find no trace of the emails that made it through the spam filter. Any help would be appreciated.
0
MikeGeig
Asked:
MikeGeig
  • 10
  • 10
  • +1
1 Solution
 
ATIGCommented:
how are you validating they are leaving the spam filter?

is it possible to remove that from that mix?

you have restarted your transport services?

try running dcdiag on your ex server to see if its communication with the directory?

are 100% of messages failing to show?

try telent from spam filter to ex server on port 25 and send your self a message.

what has changed recently
0
 
Stacy SpearPresident/Principal ConsultantCommented:
Did you check your tracking logs to see if Exchange received the messages? If nothing is there, examine your SMTP logs for inbound mail from the barracuda. Does barracuda has telnet as one of its tools so you can see what Exchange said during the SMTP conversation. Also, it has logs, what do they state happened to the messages?
0
 
ATIGCommented:
Sup DarkStar3d :P
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
MikeGeigAuthor Commented:
How do I check these logs? I apologize, but I am very much a beginner in the ways of network administration. ATIG, all I can say is that I have no idea how to do anything you just said
0
 
CrownappraisalCommented:
Open the Exchange management console under organizational configurations > Hub transport then the Send connections tab, Then double click on send mail add an * to the list. Try that and let me know if that helps. Also it may be something to do with your MX records.
0
 
ATIGCommented:
heheh :)

1. Can you logon to your spam filter and telnet to port 25 on your Exchange server?
2. as mentioned by Dark..... an easy test would be to look at your message tracking logs (if they are enabled)
 -- open ESM -- tools -- message tracking center
this should help you find whats going on with the message
3. Are you running an Anti virus on the 2003 server?

last but not least have you rebooted your Exchange server or just tried to restart the services?
0
 
MikeGeigAuthor Commented:
Crown, * was already added to my list. As far as MX goes, I am not sure what it is or how to check it
0
 
ATIGCommented:
I did not pay attention you are running Ex 2007?
0
 
ATIGCommented:
If so open EMC --> toolbox --> mail flow troubleshooter

-- for message tracking if you have more than 1 server its best to do from EMS

however if you have 1 then in the toolbox is the message tracking tool as well....

Under  - Server config --hub transport -- validate your recieve connector is enabled

you can open EMS -- test-mailflow
0
 
MikeGeigAuthor Commented:
ATIG, yes I am. The lest message in my logs were yesterday at about 6 in the morning from my spam filter. Does this make it safe to assume that even though my spam firewall claims to be sending the emails that it it not? Or maybe there is a routing issue? I don't know how to check from here
0
 
MikeGeigAuthor Commented:
I did a barracuda diagnostic:

Could not send email to your default mail server. Please verify that your mail server is reachable and is accepting mail. If you are using a DNS name for your default mail server, verify that your DNS settings are properly configured

Supposedly valid email is being rejected by your mail server. Please verify your test email address, and configure your mail server to receive email for this address from the Barracuda Spam Firewall.

It does not look like the MX record for your default domain resolves to your Barracuda Spam Firewall's IP address. Please verify that your DNS servers are properly configured.
Inbound Mail Reception...


Could not send mail to your Barracuda Spam Firewall. Please verify that your network permissions (firewall) allow SMTP traffic from the Internet to the Barracuda Spam Firewall
0
 
ATIGCommented:
Can users send mail to each other-- if yes then most likely that EX is ok however

from you workstation --open a command window
telent youexservername 25 <enter>
help <enter>
mail from: youremaial <enter>
rcp to: youremail <enter>
data <enter>
. <enter>
quit

you should get an email from your self,

this will test you recieving email from a simulated outside source by your Ex server.

yes its possible that the spam filter is not passing the messages.. anything is possible
0
 
ATIGCommented:
so mail flow should be --- pass firewall -spam-exchange

what IP is live/routeable? are you Nating?

to find your MX
nslookup <enter>
set type=mx
youdomainname <enter>

this should poin to your fireall or spam (i dont know your setup)
0
 
MikeGeigAuthor Commented:
My MX ip points to my ex server, not my spam filter or firewall.

Firewall 10.1.1.1
Filter 10.1.1.4
ex 10.1.1.13
(physically in that order)

Users can send to each other and they can send outbound
0
 
MikeGeigAuthor Commented:
Also, I don't know what Nating is
0
 
ATIGCommented:
those are private ips....... what is your live external Ip...

you dont need an MX for internal usage either....

what is your domain name I can look it up if you willing to state it
0
 
ATIGCommented:
Nat -Network Address Translation
http://en.wikipedia.org/wiki/Network_address_translation

which is looks like your doing

0
 
MikeGeigAuthor Commented:
ymcastark.org
0
 
ATIGCommented:
your mx = mail.ymcastark.org
which = 66.94.84.178

this should be the external ip on your firewall.... from there you need a rule for smtp to point to Filter 10.1.1.4

then your filter will point to Filter 10.1.1.13
0
 
MikeGeigAuthor Commented:
Let me check that. I have to look into my firewall config real quick
0
 
MikeGeigAuthor Commented:
Well, ATIG, I thank you for your help. As it turns out, the problem was an error 4.3.1 Insufficient Resources. Apparently the resource watcher required the server to have an extra 5 gigs of space. My drive dipped into the 4.70 range and my server refused the smtp emails. For anyone in the future who reads this, go here http://exchangepedia.com/blog/2007/03/exchange-server-2007-transport-452-431.html
0
 
MikeGeigAuthor Commented:
By the way, I gave you the points. Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 10
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now