Solved

Cannot copy files from MAC to Windows Sever share

Posted on 2007-11-15
14
4,294 Views
Last Modified: 2013-11-24
Hi All,
Hope someone can help.
I have a client that uses mostly Windows PC's but has a few MAC's as well.
They recently moved offices and since then the MAC guys cannot copy files over to a Windows 2000 Server share. They get an error stating the filename is too long or contains invalid/corrupt characters.
The Windows PC's have no problems. But, if a PC copies a file over that has a filename over a certain length(possibly 8 characters) then the MAC cannot open the file.
The folder is setup as both a windows share and a MAC share.
As far as I'm aware nothing has changed apart from their physical location.
The files that are being copied are images, mostly jpgs.
The wndows server is located in their DMZ.

The MACs are running Tiger(not sure of exact version) and the server is Windows Server 2000 SP4.

Many Thanks
Andy
0
Comment
Question by:sycomites
14 Comments
 
LVL 13

Expert Comment

by:cshepfam
ID: 20288809
I had this happen to me.



In order to resolve it, I did two things:



1.  Had the guy who works on the Macs change the file names.  Had him exlude anything with / or !.  Those will mess the file copying up.  The thing that makes it more frustrating is that when it runs into one error like that, the whole file copying stops.


to take care of that we got good software


2. Vice Versa Pro.  Copies everything over from Mac to PC.  I'm actually doing that right now.  It will ignore errors and continue to copy regardless.  It'll log the files it couldn't copy over so you can go back to it and change it.  After you change it, you can update and will bring those corrected files over.  Great software.


download it here:

http://www.tucows.com/preview/209297
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20289169
Sounds more like an AFP or SMB issue.  

If they were able to copy perfectly beforehand then the filename issue is probably a red herring.

Are they connecting to the Share via SMB or AFP.  Perhaps since the move over they are using SMB instead of AFP which may be causing the problem.
0
 

Author Comment

by:sycomites
ID: 20289288
Thanks for the suggestions guys.
Yes it was working beforehand so I'm guessing the client will not be interested in purchasing software to fix it.

Sorry, not sure how I would tell if they are connecting via AFP or SMB?
The Appletalk protocol is installed on the server if that helps?

Cheers
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20289345
On the Macs ..  are they logging into the AD domain on the 2000 server and authenticating like Windows users or are they just connecting across the network using the Connect to Server command in the OSX Finder?

On a Mac . in the Finder .. go to the Tools menu and select  Connect to Server

try
Apple File Sharing - afp://SERVERNAME or afp://SERVER_IP_ADDRESS
SAMBA - smb://SERVERNAME or smb://SERVER_IP_ADDRESS

You should be able to connect using both SMB and AFP protocols.

Try the copying issue when connected one way and the other to see if it is common to both protocols
0
 

Author Comment

by:sycomites
ID: 20289551
Thanks for your speedy response.

I've left a message for the client to try this but as he is away from his desk I'm not sure when he will try it.
I will update this when I have more info.

Just so you know, the server is not part of their AD domain. Its is standalone in their DMZ.
So they authenticate to this server using its local username passwords.

Thanks
0
 

Author Comment

by:sycomites
ID: 20313289
I have an update from the user. He says :

"Have just tried all these and the only one that actually tried to connect is the Smb.
Unfortunately it pushed up an alert that said it was unable to connect as the ip may not exist or is not operational.."

Which is strange as the server is definatley running and has valid records in their DNS servers.

Any further help appreciated.

Cheers
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20313376
It sounds like communication may be blocked in some manner.

Can he PING the Server OK?
0
 

Author Comment

by:sycomites
ID: 20318936
Yes, just got the client to run a ping to the server and all looks fine.
He can ping the server by its name with 0 packet loss.
Cheers
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20319038
V. Strange.
Sounds like the Server is blocking or in some way hasn't  got the proper access enabled.

If the Ping returns responses with IP and servername then you know the path between the 2 is clear.

Now you need to look at what may have changed on the server or network.
If all the Mac Users can connect and mount the share (as you say at the top of this question) but cannot copy files because of filename errors it sounds like Apple File Sharing is not working.
Is this enabled on the Server?  Can you unshare and reshare the relevant folder and ensure Apple File Services is enabled.
I note that your client could not connect using the afp:// protocol implies that Apple File Sharing is not working properly

0
 

Author Comment

by:sycomites
ID: 20320766
I think you are right with the Apple File Sharing not working as the client still cannot connect with AFP://.

Anyway, I have removed and re-created the MAC Share and setup the file security.
Unfortunately this hasn't made a difference as the client can mount the share and browse to his hearts content but still has issues with long file names.

The AppleTalk protocol is installed and running on the server. Also the File Server for Macintosh service is installed and running. Is this the same as Apple File Sharing?
If not, do you know how I can get this running?

Many Thanks
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20321743
File Server for Macintosh service  .. IS the AFP Apple File Sharing Protocol

It is strange as it would appear that either AFP services are not working properly .. as they are supposed to allow proper Apple Filenames
http://support.microsoft.com/default.aspx?scid=kb;en-us;147438


0
 

Author Comment

by:sycomites
ID: 20359338
Unfortunately the problem still exists.
I have uninstalled, rebooted and reinstalled the File Server for Mac on the Win2K server.
Asked the user to try to connect again using AFP://<servername>/<sharename> and SMB://<servername>/<sharename> and I also got the user to try without the <sharename> in both AFP and SMB. None of this has worked.
The user still gets an error message when trying to copy files from the Win2K server to his MAC(and vice versa) stating the filenames are too long or contain invalid characters.
As another test I ran a telnet from another server on the LAN to the server in the DMZ on port 548 which I'm led to believe is the AFP port. It looked like the server allowed the connection but didn't give any response which is probably how its meant to work.

Anyway, any further ideas would be greatly appreciated.
Thanks
0
 

Expert Comment

by:marselian
ID: 20570261
Windows NTFS/Dos has a file character limit.  The limit isn't only on the name of the file but the character limit includes the path, so if the path is several folders deep the folder characters will count towards the character limit and you will get this message.  On the file that you are having problems copying from the Mac to the 2K server, or from the 2K Server to a client try moving one of those files to the main share instead of several folder deep and see if you are able to copy successfully.

The other problem that you will face is that NTFS will try to auto name the files like Prog~1 or FileName = FileN~1 or FileN~2 and so on.

Check out this Technet discussion on Macintosh File Name Translation: http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/intwork/incf_mac_dvui.mspx?mfr=true
0
 

Accepted Solution

by:
sycomites earned 0 total points
ID: 21428648
can I close this question as long as everyone agrees? The client never did get a resolution and after a while scrapped the windows 2000 server! Thanks
0

Join & Write a Comment

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Resolve DNS query failed errors for Exchange
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now