Solved

Cannot ping any external ip's or configured dns servers

Posted on 2007-11-15
9
376 Views
Last Modified: 2010-04-09
Please help!  I'm have a Cisco Pix 515e in the office, I'm not extremely Cisco savvy but am familiar with the basics.

I'm finding that I cannot ping any external public ip addresses or the dns servers configured on my network.

What do I need to change on the firewall to allow pinging external ip's?

This is extremely urgent, I would offer more points if I could.

thank you!
0
Comment
Question by:cas_three
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 20288921
You will need to allow the ICMP traffic into the outside interface. Adding something like the following should do it but you will need to make sure the access-list name matches what you use.

access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit icmp any any source-quench
access-list outside_access_in permit icmp any any unreachable
access-list outside_access_in permit icmp any any time-exceeded
0
 
LVL 6

Assisted Solution

by:LectricX
LectricX earned 333 total points
ID: 20288957
Ping traffic is not regular TCP or UDP traffic.

It is ICMP traffic, which you need to ensure you have allowed through the PIX firewall.

You need an access list entry:
access-list outside_in permit icmp any any


Lastly,
The PIX will not pass traffic unless you have established a translation.

If you want each IP to represent itself, you can use
nat (inside) 0 external.ip.external.ip 255.255.255.0
if you do NOT want to permit new connections to the inside. This
nat's each address to itself.

Or you can use
access-list no-nat permit ip external.ip.external.ip 255.255.255.0any
nat (inside) 0 access-list no-nat
This "turns off" NAT (ports go out unchanged) and has the side effect
of permitting incoming connections. Proxy arp is NOT done for this form.

Thirdly, you can use
static (inside, outside) external.ip.external.ip external.ip.external.ip netmask 255.255.255.0
which also has the side effect of permitting incoming connections.
Proxy arp IS normally done for this form.
0
 

Author Comment

by:cas_three
ID: 20288994
I added the lines

access-list outside_access_in permit icmp any interface outside
access-group outside_access_in in interface outside

But still cannot ping?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 36

Expert Comment

by:grblades
ID: 20289065
Can you post your current configuration (remove 1st part of any IPs and passwords) as that will help us fix the problem for you.
0
 
LVL 28

Accepted Solution

by:
batry_boy earned 167 total points
ID: 20289119
>>I added the lines
>>
>>access-list outside_access_in permit icmp any interface outside
>>access-group outside_access_in in interface outside

That will not do it...grblades gave you the correct statement to use (as well as some extra ones) to allow echo replies back into the network...here are the two statements you absolutely have to have if you want to allow an internal host to ping an external one and receive the echo reply back from that external host:

access-list outside_access_in permit icmp any any echo-reply
access-group outside_access_in in interface outside

You specified "interface outside" and didn't specify the ICMP type "echo-reply"...try these and see what you get.  If those don't work, then like grblades said, post your current config.
0
 

Author Comment

by:cas_three
ID: 20289176
Still not working:


xxx# show run
: Saved
:
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxx
passwd wxxxxx
hostname xxxx
domain-name xxxx.com
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host xxxxxx
  network-object host 2xxxxxx
  network-object host xxxxxx
access-list 100 permit tcp any host xxxxxx eq lotusnotes
access-list 100 permit tcp any host xxxxxx eq www
access-list 100 permit tcp any host xxxxxx eq www
access-list 100 permit tcp any host xxxxxx eq citrix-ica
access-list 100 permit tcp host xxxxxxx host xxxxxx eq ftp
access-list 100 permit tcp host xxxxxxx host xxxxxx eq ftp
access-list 100 permit tcp host xxxxxx host xxxxxxx eq ftp
access-list 100 permit tcp object-group xxxxxs host xxxxxx eq smtp
access-list 100 permit tcp any host xxxxxx eq citrix-ica
access-list 100 permit tcp any host xxxxxx eq www
access-list 100 permit tcp any host 6xxxx eq https
access-list 100 permit tcp any host xxxxxx eq 3389
access-list 100 permit tcp any host xxxxxx eq 3389
access-list 100 permit tcp any host xxxxx eq 3389
access-list outside_in permit icmp any interface outside
access-list outside_in permit icmp any interface outside
access-list outside_in permit icmp any any echo-reply
access-list outside_in permit icmp any any source-quench
access-list outside_in permit icmp any any unreachable
access-list outside_in permit icmp any any time-exceeded
pager lines 24
logging on
logging trap notifications
logging host inside xxxxxxx
mtu outside 1500
mtu inside 1500
ip address outside xxxxxxxx
ip address inside xxxxxxxxx
ip audit name Info info action alarm drop reset
ip audit name Attack info action alarm drop reset
ip audit interface outside Attack
ip audit info action alarm drop reset
ip audit attack action alarm drop reset
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
alias (inside) xxxxxxxx 255.255.255.255
static (inside,outside) tcp xxxx smtp xxxx smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp xxx lotusnotes xxxx lotusnotes netmask 255.255.255.255 0 0
static (inside,outside) tcp xxxx www xxxx www netmask 255.255.255.255 0 0
static (inside,outside) tcp xxx5 citrix-ica xxxx citrix-ica netmask 255.255.255.255 0 0
static (inside,outside) tcp xxxx www 1xxxx www netmask 255.255.255.255 0 0
static (inside,outside) tcp xxxxx 3389 xxxxx 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp xxx 3389 xxxx 3389 netmask 255.255.255.255 0 0
static (inside,outside) xxxx xxxxx netmask 255.255.255.255 0 0
access-group outside_in in interface outside
established tcp 80 0 permitto tcp 80 permitfrom tcp 80
route outside 0.0.0.0 0.0.0.0 xxxxxx
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:10:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http xxxxxx inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt noproxyarp inside
isakmp enable outside
isakmp key ******** address xxxxxx1 netmask xxxxxx
isakmp nat-traversal 20
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption des
isakmp policy 9 hash sha
isakmp policy 9 group 1
isakmp policy 9 lifetime 86400
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
console timeout 0
dhcpd address sssssss inside
dhcpd dns sssss
dhcpd wins ssssss
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain nauticom.net
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:aa29d2fb2d088fb45f726fee62975939
: end
xxxxx#
0
 
LVL 6

Assisted Solution

by:LectricX
LectricX earned 333 total points
ID: 20289247
Here's a PIX I have that is allowing pings:
->  lines with this are important I think.

access-list outside_in permit tcp any any eq smtp
access-list outside_in permit tcp any any eq 161
access-list outside_in permit udp any any eq snmp
access-list outside_in permit tcp any any eq telnet
-> access-list outside_in permit icmp any any
access-list outside_in permit tcp any any eq 8888
access-list outside_in permit tcp any any eq ssh
access-list outside_in permit tcp any any eq pop3
access-list outside_in permit ip host x.x.x.x any
access-list outside_in permit ip any host x.x.x.x
access-list outside_in permit tcp any any eq 3389
access-list inside_in permit ip host x.x.x.x any
access-list inside_in permit ip host x.x.x.x any
access-list inside_in deny tcp any any eq smtp
access-list inside_in permit ip any any
access-list inside_in permit tcp any any
access-list inside_in permit udp any any
-> access-list inside_in permit icmp any any
access-list nonat permit ip x.x.x.x 255.255.255.0 x.x.x.x 255.255.255.0
0
 

Author Comment

by:cas_three
ID: 20289324
I added the access-list outside_in permit icmp any any, still nothing.
0
 
LVL 36

Expert Comment

by:grblades
ID: 20289381
You dont appear to have access-list 100 applied to the inside interface. Is that correct or did you remove that command when you pasted the config here?

Regardless you could add the following. If the access-list is applied to the inside interface then it should get it working. If it isnt then all outbound traffic should be permitted anyway.
access-list 100 permit icmp any any echo
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (https://kb.isc.org/article/AA-01272), affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question