Solved

Word 2003 automatically changes to read only file after saving

Posted on 2007-11-15
87
3,853 Views
Last Modified: 2011-06-07
I have one user here with Office 2003 SP3, Windows XP Pro.  When she opens a file through Word, the first time she hits save after making changes, it automatically changes the file to read only after saving the first time.  I'm sure she checked a box somewhere by mistake, but what box would it be?
0
Comment
Question by:rsoxhater
  • 31
  • 8
  • 8
  • +9
87 Comments
 
LVL 11

Expert Comment

by:bsharath
ID: 20289525
Do you mean read only on the files properties or when you open word in the top most you get the filename (Read only).
0
 

Author Comment

by:rsoxhater
ID: 20289573
Yes, it changes to read only on the title bar as well.  The first time she opens a file, makes a change, and hits save, it saves fine.  Right after that it becomes Read Only
0
 
LVL 11

Expert Comment

by:bsharath
ID: 20289671
Are you using office 2007 .
Is there any sharing...
Can you move the file from that location to a different drive and see what happens.

Does this happen with all files.
0
 

Author Comment

by:rsoxhater
ID: 20290449
Office 2003, SP3.  It only happens on this one computer, this particular office has 3 computers who access the same group of files, and the two other computers don't ever have this problem.
0
 
LVL 11

Expert Comment

by:bsharath
ID: 20290491
Have you changed the location anc checked.
Are the files in a remote machine shared folder.
Try moving them to local machine and try.
Then we can see if it is some sucurity issue on the shared folder.
0
 

Author Comment

by:rsoxhater
ID: 20290544
Yes, they are all in a mapped drive on a server.  I will try moving some files and see what happens.
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20299083
Hi,

When you open the file you get a prompt like this.

c:\.... should be opened as read only unless changes needs to be saved. Open as read-only?

regards
Chandru
0
 
LVL 11

Expert Comment

by:bsharath
ID: 20341888
Did the problem be solved...
0
 

Author Comment

by:rsoxhater
ID: 20349287
Sorry, I was on vacation last week. I will check with the user when they come in and see what the result of copying files to the local computer was.
0
 

Author Comment

by:rsoxhater
ID: 20375530
I think i nailed down the problem.  We did a upgrade about a month ago to our document management software (xerox docushare).  After that, the new client seemed to take over the save function completely. I disabled that part of the client and it still was having the same problem.  I completely removed the xerox docushare client it fixed the problem.  

Oddly enough, the problem started happening a while after the upgrade not right away.  None of the other computers have the problem that use the same client, so maybe the install of the xerox client just went bad on this one computer itself.

Thank you for all the help!
0
 

Author Comment

by:rsoxhater
ID: 20403830
I'll take my foot out of my mouth now - it wasn't that.

I've narrowed it down though. If its a a file on the local computer its fine.   It only happens in word they they are doing a file on the shared drive.

It does not happen in Excel or Notepad when doing a save, only Word.  

Anymore suggestions?

Thanks,
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20404184
What is the share drive? IS it a windows machine?

Did you try the same with sharing on a differetnt server with necessary permission for the user?

regards
Chandru
0
 

Author Comment

by:rsoxhater
ID: 20404672
it is a windows 2003 file server that serves all of our files for every department.  Noone else is having the problem.  I will try to replicate it with a drive mapped to another server.  
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20404705
Is it happening to only one user?
0
 

Author Comment

by:rsoxhater
ID: 20404968
Yes, one user.   It seems to come and go - she'll be able to save fine for hours, and then all of a sudden it will become read only on save.  
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20408513
Did she try the same from a different machine?
0
 

Author Comment

by:rsoxhater
ID: 20410963
I did - it only seems to happen from one specific machine.
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20411378
I think it is better you try repairing word or try creating the profile for the user once again in that machine

regards
Chandru
0
 

Author Comment

by:rsoxhater
ID: 20412362
i actually recreated her profile this morning, guess we were thinking of the same idea...hopefully this will take care of the problem!
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20412456
Hope she got a chance to check

cheers
0
 

Author Comment

by:rsoxhater
ID: 20412515
so far so good - no problems yet!
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20412570
That great news!

:-)
0
 

Author Comment

by:rsoxhater
ID: 20422024
Well...the news didn't stay good. It happened again this morning. Any other suggestions?  

Thanks!
0
 

Expert Comment

by:Télé Québec
ID: 20492216
I am having the exact same problem. Office 2003, files on a shared drive. Only one user with this problem. Can save a couple of times but eventualy, the title bar mentions (Read only). The file itself is not read only in the filesystem. only one user have access to this file. My whole team is not aware of any server-based service that would access this file either.
0
 

Author Comment

by:rsoxhater
ID: 20505937
What operating system are you running on the computer and server, and what steps have you taken so far to troubleshoot it?
0
 

Expert Comment

by:Télé Québec
ID: 20513188
Workstations are on Windows XP SP2 (French)
Server is on Windows Server 2003 R2 (English)

If the file is not on a shared drive, it does not do that.
If the file is on the shared drive, you can sometimes save up to 10 times, before the file locks itself.
It seems to have nothing to do with permissions, either.

From that point on I started googling and decided to subscribe to this site =D I'd be more than glad to hear any subsequent steps that would be worth trying =)
0
 

Author Comment

by:rsoxhater
ID: 20513409
I'm in the exact same boat.  I've tried recreating the user profile, resetting all permsions, etc.  

Are you using roaming profiles or local ones?
0
 

Expert Comment

by:Télé Québec
ID: 20513663
Local Profiles
0
 
LVL 12

Expert Comment

by:chandru_sol
ID: 20522048
0
 

Expert Comment

by:Télé Québec
ID: 20599795
Hi Chandru

The link you posted describes a different behavior (a doc file is considered read only after being opened when it shouldn't) The problem me and rsoxhater have is different (a doc file is opened and gets tagged as read only after a couple of saves).

The information regarding the methods word use to open a file are interesting though, thanks =)
0
 

Expert Comment

by:dfinklez
ID: 20602046
Having the same issue to flies on a network share.   80 People using the same share and happening to two of them.  Really odd issue, seems to disapear for days and then return.  Even had a call with M$ and was refunded because we couldn't reproduce the issue.  A day later it returned.  I don't get it.  
0
 

Author Comment

by:rsoxhater
ID: 20626435
I am copying the files for this specific office to another server now, and am going to see if it happens again.  I have all the offices using the server, and only this one specific office is having a problem.  

dfin - whats your network setup there?  What version office, server, and computer OS?
0
 

Expert Comment

by:dfinklez
ID: 20626665
Using Office 2003 SP3 on Windows XP SP2 for clients
Server is 2003 SP2

Interested to see if changing servers resolves your issue as I really want to peg this as a network issue.
0
 

Author Comment

by:rsoxhater
ID: 20626678
I copied over all the files and will post back if that solves the problem.  We have older switches here, but if it was a network issue, it seems people outside of this one office would have a problem to, since we have all the other departments on this file server as well.  
0
 

Author Comment

by:rsoxhater
ID: 20627610
Well that didn't work.  I copied over all their files back to the old server (which is windows 2000, and stored all the files before moving to the new server), and she still got the same error message.

Any else have any ideas?
0
 

Expert Comment

by:dfinklez
ID: 20627635
rsoxhater... when you say error message just want to make sure you mean 'read only'.

How reproducible is this issue for you?  My 2 users here experience it maybe once a week
0
 

Author Comment

by:rsoxhater
ID: 20627684
Yes, read only.  They will go a day without, but then get it a bunch of times in a day.  Very random.  I thought network, but no other programs are having problems, and noone else is having problems saving.
0
 

Expert Comment

by:Télé Québec
ID: 20628169
I'm pushing SP3 to the user that has the issue... will see if there are any changes.

Are any of you guys using SP3?
0
 

Author Comment

by:rsoxhater
ID: 20628305
My user that is having the problem is SP3.  I had installed it after she started having the problem.  That didn't change anything, maybe it will in your case.
0
 

Expert Comment

by:dfinklez
ID: 20628328
SP3 here as well
0
 

Expert Comment

by:Télé Québec
ID: 20628563
ah yeah sorry dfink, I misread your post.
0
 

Expert Comment

by:dfinklez
ID: 20717543
Any updates on this from anyone?
0
 
LVL 4

Expert Comment

by:dgage123
ID: 20720471
Here is one article that might help:

http://word.mvps.org/FAQs/AppErrors/LockedFiles.htm

Also, you probably have done this already, but you can go to: Tools, Options, Security, and make sure the "read-only recommended" box is not checked.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Expert Comment

by:dfinklez
ID: 20720484
I have done both....
0
 
LVL 4

Expert Comment

by:dgage123
ID: 20720501
How about this???

"The only way she was able to get around the problem was to turn off the automatic backup file feature in Word (Tools | Options | Save tab, clear Always Create Backup Copy) while working in that document."
0
 

Expert Comment

by:dfinklez
ID: 20723097
I don't think I have tried that specifically, but will give it a shot.   Would be interested in finding the root cause of this issue though...
0
 

Author Comment

by:rsoxhater
ID: 20758847
Any luck with that solution?   My next step is to wire her computer right into our main switch instead of the stack of switches everyone else is plugged into (their office is right next to our server room so luckily I can try that)

0
 
LVL 5

Expert Comment

by:drmarston
ID: 20905950
I hope I can revive this thread, I have a user experiencing the same issue (slightly different config)
User is working from "My Documents", which in turn has been redirected to a network share via group policy. Otherwise identical issue.
Client = XP SP2 / MS Office 2003 SP3
Server = Win 2003 server Std x64 SP2
0
 

Expert Comment

by:dfinklez
ID: 20922070
drmarston...

That is the exact same configuration that I had (My doc redirect) is this happening to all users or just  a few?  

I reinstalled office to SP3 and haven't had the issue since... but doubt this is permanent.
0
 
LVL 5

Expert Comment

by:drmarston
ID: 20922123
A single user (out of 100)
You said reinstall of SP3 seems to have worked, I will try that as well.
0
 

Expert Comment

by:Télé Québec
ID: 20922654
My single user that had this problem did not have SP3, I installed it for him and that made no difference= (
0
 

Author Comment

by:rsoxhater
ID: 20927280
I've done the SP3 reinstall as well.

drmartson - my user also has their my docs redirected to a network share.  It is mapped via a login script, so their H: drive is on the server.  Are yours via  drive letter or directly to share?  ie \\servername\share

I don't think that'd matter, but i'm reaching here for ideas.
0
 
LVL 5

Expert Comment

by:drmarston
ID: 20929251
It's done in Group policy: basic setting, set to: " \\server\users\%USERNAME%\My Documents "
0
 

Expert Comment

by:Télé Québec
ID: 20957875
We are also redirecting "my documents" to a network share via group policy
0
 

Expert Comment

by:BuddyWeaver
ID: 20978700
I have this same exact problem.  I too am using group policy to redirect the my documents location to a network share.  I only have one user with the issue you describe here.
I would like to add the following
I am getting the following event in my security event logs for all of my users, intermittenly.  I don't get the message in my event log everytime they open a file, only intermittently.  I have been trying to figure out why I am getting this in the event log for 6 or 8 months, but I cannot find an answer.  I have left it alone because for the most part my users are oblivious.  until now, I have a user with the exact same symptoms as you describe above.
This is not an access permissions issue, my user has full access, everywhere.
Do any of you have the following in your event logs and have any of you found a solution?

Failure Audit
event type 16.  event id 560. source security. category object access
Object Open:
      Object Server:      Security
      Object Type:      File
      Object Name:      D:\jerry\My Documents\Blazier Michelle loan application.doc
      Handle ID:      -
      Operation ID:      {0,376227647}
      Process ID:      4
      Image File Name:      
      Primary User Name:      BOCADSERVER$
      Primary Domain:      BOCNET
      Primary Logon ID:      (0x0,0x3E7)
      Client User Name:      Jerry
      Client Domain:      BOCNET
      Client Logon ID:      (0x0,0x164919E4)
      Accesses:      DELETE
                  READ_CONTROL
                  ACCESS_SYS_SEC
                  ReadData (or ListDirectory)
                  ReadEA
                  ReadAttributes
                  
      Privileges:      -
      Restricted Sid Count:      0
      Access Mask:      0x1030089
0
 

Author Comment

by:rsoxhater
ID: 20983164
Mine aren't done via group policy, just remapped the actual my documents to the network drive on their desktop.
0
 

Expert Comment

by:KevinAtBerkeley
ID: 21107128
I have been experiencing this same random anomaly for over 6 months.  In my environment it is occurring on Windows XP-SP2 with Office 2003 - SP2 and SP3.  The files are always on one of our file servers yet it is not confined to any one of them.  We redirect the My Documents via GPO to their homeshare which resides on the network.  Has anyone found a work around or solution?
0
 

Expert Comment

by:BuddyWeaver
ID: 21116684
I too am continuing to have this problem with the same environment as KevinAtBerkeley
and cannot find a solution.  Please post here if anybody has any ideas thanks,
0
 

Author Comment

by:rsoxhater
ID: 21116876
Mine is still ongoing as well.   Still only one user.
0
 

Expert Comment

by:BuddyWeaver
ID: 21118162
I found another post with an off the wall suggestion.  the sugestion seemed to work.
I re-created the problem by doing this.  created a test document, saved it to my network share.  changed it, clicked save about 3 times and it automatically changed to read-only.  

then... I changed the NIC to 100mb full, enabled flow control and disabled power mgmt.
after that I repreated the above steps and saved the documents 40 times without a problem.  
hoping this fixed the problem and hoping it fixes yours.
this is where I got the suggestion.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22614560.html
0
 

Author Comment

by:rsoxhater
ID: 21118502
I tried that and didn't get the save problem after changing to 100mb full and turning off WOL.  I will see if she gets the error anymore.  That would be one nice find buddy!
0
 

Author Comment

by:rsoxhater
ID: 21124875
Happened again this morning....so close..yet so far...lol
0
 

Expert Comment

by:BuddyWeaver
ID: 21124901
damn.... One of my machines is the bank president's......
I'll continue to post here if I find anything.
0
 

Author Comment

by:rsoxhater
ID: 21125249
Did yours happen again?
0
 

Expert Comment

by:BuddyWeaver
ID: 21125294
not yet, but if yours did, I'm expecting mine to.  my peeps are just not starting to work this morning.
0
 

Author Comment

by:rsoxhater
ID: 21160252
Buddy, did yours come back?
0
 

Expert Comment

by:BuddyWeaver
ID: 21160441
They have not mentioned it to me.  I will be back at that location in a couple of days and will check on it.
0
 
LVL 1

Expert Comment

by:proservis
ID: 21169322
I have the same exact issue, only difference is that (domain) users are working on Windows 2003 terminal server (SP2 + all updates, application mode). Tried all previously mentioned workarounds, none helped, including changing network card's options.
0
 
LVL 1

Accepted Solution

by:
proservis earned 500 total points
ID: 21169428
Found a tip in Microsoft newsgroups that offers uninstall of WDS (if you are working with a document and WDS indexes original document sometime in between saves, Office thinks it is locked).

I have removed redirected folders from indexer options and problem seems to be gone. Waiting for some confirmation from users, as this problem can be tricky to reproduce.
0
 
LVL 1

Expert Comment

by:proservis
ID: 21169534
It is very simple way to verify if it is WDS that is messing with your folders:

1. Remove all search locations except one shared folder with 1 flie in it.
2. Open WDS status window that show how many files are indexed and how many are faiting for the index.
4. Make shure indexing isn't on "snooze".
3. Open that 1 file that is in the folder marked for indexed.
5. Edit&save, you'll see activity in indexer (widnow of step 2), after that next save should be read-only prohibited.
0
 

Expert Comment

by:BuddyWeaver
ID: 21169858
Thanks proservis.  WDS was installed on my server via automatica updates.  I can't see the reason for it on the server, therefore I'm going to remove it.  What about WDS on the workstations?  should it be removed from there also?  and, in your opinion, what is the benefit of WDS? faster searches?
0
 
LVL 1

Expert Comment

by:proservis
ID: 21171777
I think You need to remove or make him ignore shared folders on workstations computers, but i'm not sure. In my case it looks like reconfiguring on workstation did the trick, time will tell if that is enough.

Windows Desktop Search makes index of all the files (those that are included in search) for quick search later. Some apps, like Outlook 2007, use it to for their search, that is why disabling it may be undesireable. In my case, I just got to "Windows Desk Search Options", clicked "Modify" and cleared checkboxes from shared folders - I still get mail indexed.

0
 

Expert Comment

by:frocko
ID: 21172707
We have been having the same issue described above with a few exceptions:

1)  Indexing Service is turned off (Server)
2)  Indexing Service is turned on (Workstation)
3)  We don't use WDS (as it is not installed yet) on either the Server or Workstation

 We are using Windows XP SP2 and Office 2003, Windows 2003 Server SP2.  I have too many users to turn off indexing on each workstation to test the latest theory on the locking issue, but am very interested to see what the final answer is here.
0
 

Expert Comment

by:KevinAtBerkeley
ID: 21172771
This is the first lead to make sense so far.  I will try and isolate this by eliminating search for a couple of the impacted users.  BTW we have WDS deployed on everyone of our standard XP client builds.  In the past I have been more worried about the impact to the servers of having all clients indexing the data to which they have access to.  I have been working on an Enterprise Search project to centralize the search functions to move away from our client sided distributed search model and with the release to manufacturing of the MS Enterprise Search Express, I can move this project ahead into a pilot production status.  I'll keep everyone updated as I get more data.
0
 
LVL 1

Expert Comment

by:proservis
ID: 21178485
Just a quick note - Indexing Service (as found in services.msc) has not much to do with Windows Desktop Search.

Uninstalling is possible with logon script:
%windir%\$NtUninstallKB917013$\spuninst\spuninst.e xe /quiet /norestart

after that it's up to WSUS to stop MS from pushing it back ;)
0
 
LVL 1

Expert Comment

by:proservis
ID: 21178512
http://download.microsoft.com/download/D/2/7/D271C570-0C2F-4B8D-9A17-50750D28DBB3/DesktopSearch.adm

this GPO template did my day :) import it, configure setting for indexer, assing to domain and you are done.
0
 

Expert Comment

by:KevinAtBerkeley
ID: 21205411
Well, so far so good with removing the Windows Desktop Search V3 (WDS).  We have removed it from over 20 clients who were chronic victims of the Read Only / Save As problem and we are yet to see it again on any of them.  
0
 

Expert Comment

by:frocko
ID: 21206215
This solution (remove WDS) would not work in our case or others who have not deployed WDS on XP or Windows 2003 Server, yet have the same issue described by rsoxhater.
0
 

Author Comment

by:rsoxhater
ID: 21208100
So far so good from my end.  Removed it from the computer of the one user having the problem and no problems in two days.  

Thanks
0
 

Expert Comment

by:darlenet
ID: 21213804
Frocko:
The problem can also occur using MSN Toolbar (which includes WDS) because of INDEXING the shared network folders. So if you have any indexing of the network folders this could happen.....also AV programs and Backup Agents/Programs (or both together) have also caused these kinds of issues. This occurs because MS Office documents are saved thusly:
 Open the file/ then user saves......and here is what happens in the background:
·Delete the original file
·Rename the temp file to the original file name
·Open a new temp file
·Open the original document requesting Read/Write Sharing
Somewhere in this process, a lock is being put on one of these files/temp files. Apparently.

Because in a network trace that captures the packets when the file has become read only, this is what you will see:

· Delete the original file
· Rename the temp file to the original file name
· Open a new temp file
· Open the original document requesting Read/Write Sharing
· Server responds with a SHARING VIOLATION (NT Status: STATUS_SHARING_VIOLATION (0xc0000043))
· Client then tries to open the file with Read Only, which completes successfully.
0
 

Expert Comment

by:frocko
ID: 21214130
darlenet:  Excellent point and very well said!
0
 

Author Comment

by:rsoxhater
ID: 21244330
The problem hasn't returned on my end, how about anyone else?  I'm ready to mark this question closed if noone else has experienced a problem after using the above fix.  
0
 

Expert Comment

by:darlenet
ID: 21246172
I believe Frocko has one open with the same symptoms but not the same cause. I also am dealing with this same symptom but WDS is not installed...And it's not AV or Backup Agents either! Nor does anyone else have the file open.....
0
 

Expert Comment

by:KevinAtBerkeley
ID: 21246806
Removing WDS 3 seems to be the silver bullet in our environment as we have yet to experience the problem since removing it.  We need to evaluate a replacement solution as indexing/search has become a must have application around here.  We will be evaluating the WDS V4.0 preview (http://support.microsoft.com/kb/940157) and Google Desktop search as possible replacements.  We are also evaluating Microsoft's new enterprise Search Server 2008 (http://www.microsoft.com/enterprisesearch/serverproducts/searchserver/) to help augment our search solution.  I would really rather have one central index of our file servers rather than having each individual desktop indexing the servers themselves as this solution does not scale well at all.
0
 
LVL 1

Expert Comment

by:proservis
ID: 21284080
darlenet: my only advice would be to set up some monitoring tool (like Filemon froi Microsoft, available as a free download) and inspect what program accesses the file.
0
 

Author Comment

by:rsoxhater
ID: 21470346
Kevin, have you checked out dtsearch?  
http://www.dtsearch.com/PLF_network_2.html
0
 

Author Closing Comment

by:rsoxhater
ID: 31409335
Thank you!  This will help countless people!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

User Beware!  This is a rather permanent solution to removing your email from an exchange server.  The only way to truly go back is to have your exchange administrator restore your mailbox from backups.  This is usually the option of last resort.  A…
My experience with Windows 10 over a one year period and suggestions for smooth operation
This video shows where to find the word count, how to display it, and what it breaks down to in Microsoft Word.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now