• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 730
  • Last Modified:

upgrade the ios software

Hi this is the current version ios i have on the router C1700

Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-IPBASE-M), Version 12.3(6c), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 20-Jul-04 07:00 by kellythw
Image text-base: 0x80008120, data-base: 0x80C74650

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

Dublin uptime is 1 week, 3 days, 21 hours, 11 minutes
System returned to ROM by power-on
System image file is "flash:c1700-ipbase-mz.123-6c.bin"

cisco 1721 (MPC860P) processor (revision 0x400) with 55686K/9850K bytes of memory.
Processor board ID FOC08383HN9 (2102898216), with hardware revision 0000
MPC860P processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

im looking to get an ios installed that will have isis and bgp running on the router

can you explain how this is done or can be done on the router C1700?
0
IRLHELP1
Asked:
IRLHELP1
  • 4
  • 3
1 Solution
 
Jan SpringerCommented:
Go to Cisco.com download section (requires a CCO login).

Download the file to a server under a user home directory.

Configure the router with an ftp username and ftp password.

FTP the file from the server to the flash (check to see that you have sufficient total space for the new image and sufficient remaining space -- otherwise the old image will be erased first.

If your flash holds two images,  you will need a 'boot system' statement in your configuration so that the new IOS gets loaded.

Cisco has historically offered free IOS upgrades when there is a security vulnerability associated with a particular IOS.  You may not need a software contract to download an updated image.  Cisco's TAC should be able to help you with this.
0
 
IRLHELP1Author Commented:
cheers what im looking for is the correct image to run BGP and ISIS routing protocols would you know which one?
0
 
Jan SpringerCommented:
According to Cisco's software advisor the following supports IS-IS and BGP4 with the 1721:

c1700-advipservicesk9-mz.124-17

Minimum DRAM is 96
Minimum flash is 32
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
IRLHELP1Author Commented:
yeh the c1700 i have meets the required spec but i cant download from cisco website it couldnt find the image
0
 
Jan SpringerCommented:
It's there along with an newer release -- 12.4(17a):

 c1700-advipservicesk9-mz.124-17a.bin        96        32        14-NOV-2007

Login to www.cisco.com.  Go to downloads -> IOS -> 12.4 -> 1721 -> advanced ip services
0
 
IRLHELP1Author Commented:
yeh my login wont let me download it i only have guest access to the website? any idea?
0
 
Jan SpringerCommented:
Downloading IOS requires a CCO login.

If you do not have CCO login and your IOS is vulnerable, TAC may get you the image you need.

Standard IOS upgrades requires a SmartNet [software] contract.

Contact Cisco TAC and see what they say.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now