Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Direct push only partially working

Posted on 2007-11-15
7
Medium Priority
?
472 Views
Last Modified: 2013-12-05
Here goes....

We are running Exchange 2003 SP2.  We have 10 users with windows mobile phones.  We have a mix of PDA and Smartphones.  We have a mix of Mobile 5 and Mobile 6.  Lastly we have a mix of mobile connectivity, EDGE and 3G.  We use AT&T wireless as our provider.  The problem is, users on the 3G network are missing three things in reguards to Direct Push. All users on the Edge side of connectivity are working as normal / as they should be able to sync! What is missing is... the ability to set Activesync on the phone to 'As Items Arrive', Tasks are missing, and (while minor) picture's for contacts sync'd from Exchange show up in Outlook, but not on the phone.  

The best I can point at is our Firewall.  We have a Watchguard Firebox X 1250.  The part that bewilders me is that Edge phones (2125, 3125, 8125) all sync just fine, new emails hit the phones within seconds.  So I know we are setup correctly in Exchange, and on the phones.  But there must be something that is causing phones running on the 3G network not to "talk" correcty to Exchange.  Hence all the features are not avaliable. Amongst those phones are (8525, and the Pantech Duo)

I have tested a phone that does not work correctly, and connected it with an account at Mail2Web (a free hosted exchange account, that supports direct push) and low and behold it worked just fine. So, it isn't something on At&t's end!  Any thoughts on what would cause a 3G phone not to sync with our Exchange server, while an Edge phone would work just fine?  Thank you so much in advance!
0
Comment
Question by:brytonic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 48

Expert Comment

by:Mikal613
ID: 20292245
This is a goodone.

Ive been with the 3125,8125,8525 and now the 8925 and I have had the same results from all of them.

Is the 8525 running Mobile 5.0 or 6.0?
0
 

Author Comment

by:brytonic
ID: 20292296
With my 8525 specifically it is running the Official Mobile 6 Rom from HTC / AT&T.  But two other 8525s having this problem are running Mobile 5.0.  The fourth 3G phone having trouble is the brand new Pantech Duo, which is a Mobile 6.0 Smartphone.

I should also add I have exhausted the "top tier" AT&T data support.  From their end things look correct!

Hehe, I haven't tried a tilt, yet.  Although I am leaning towards that one.  But I am sure it will have the same trouble!
0
 
LVL 48

Expert Comment

by:Mikal613
ID: 20292306
have you tried to add the server source (exchange) from your desktop via activesync?
0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 

Author Comment

by:brytonic
ID: 20292342
I have, through all of my searching I did read, and atttempt that.  Perform a clear data on the phone, then dock with the desktop.  Pass on the server settings via Activesync / Windows Mobile Device Center (I run Vista at work and at home) and then attempt a sync.  The really odd part is upon the very first sync, I can quickly go in to the Schedule settings, and it will say As Items Arrive, but as soon as the first sync completes it will revert back to 10 minutes on peak, and 2 hours for off peak.  With no option in the dropdown for As Items Arrive.  8-(
0
 
LVL 48

Expert Comment

by:Mikal613
ID: 20292499
Interesting i have the same problem and you canonly change the schedule from activesync on your desktop.
0
 

Author Comment

by:brytonic
ID: 20292576
Sorry I mislead you there.  I can change the schedule on the desktop, or on the phone itself.  It just doesn't matter which way the setup is done.  Be it by desktop first, or all from the phone, I will end up with the same limited options.  

So the 3G users are left with syncing every 5 - 10, 15.  Calendar, and Contacts mostly work fine, and no Tasks.  

I just cannot figure out why our setup is partialy working, but if I switch to my Mail2Web account, BAM everything works.  The phone even pops up with the message "Would you like to be kept up to date?" and takes you to the schedule screen with both drop downs set to "As Items arrive".  But as soon as I delete that and go back to my server, those settings are not an option!  It is rather frustrating.  Direct push is a really good and useful feature, and not being able to use all of it stinks!
0
 

Accepted Solution

by:
brytonic earned 0 total points
ID: 21217303
SOLVED FINALLY!!!

Man this one took a while.  The solution ended up being in the firewall.  Based on this blog...  

http://blogs.technet.com/vik/archive/2006/10/17/push-mail-and-gal-lookup-missing-when-syncing-to-exchange-2003-sp2-with-a-msfp-device.aspx

And posting to my firewall vendors forum.  Our firewall was blocking the "verb" Options from reaching our exchange server.  When that happens Exchange Activesync reduces functionality in the Airsync protocol to version 1.  As we confirmed on our Mobile 6 devices through the IIS logs.  Mobile 5 was not affected by that option.  So finally, all of our phones are able to get every option in direct push.  I hope this is able to help others!!

Thanks everyone for your help!

0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question