Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

configure all 9 ports to the same subnet

Posted on 2007-11-15
2
Medium Priority
?
326 Views
Last Modified: 2010-04-17
This will be a really simple question to someone who knows what they are doing.

I've got a cisco 1801 with fa0 connected to a dsl router. I've assigned a valid public ip to fa0. I now need to connect some servers, all with public ip's in the same subnet as fa0 to the 8 switchports, and confure an acl on fa0 to only allow certain ports to certain public facing servers on the switchports.

I've configured fa0 with a public ip, configured a default route to point to the dsl router connected through fa0. from the cisco i can ping public ip's no problem, but when i plug a server into a switchport, i can't even ping fa0 from the server.

Should be a very simple config, i think?

Cheers
Paul
0
Comment
Question by:beplas
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 

Author Comment

by:beplas
ID: 20293247
Forgot to add my current config for clarity

Building configuration...

Current configuration : 1312 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 <removed>
enable password 7 <removed>
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
username paul password 7 <removed>
!
!
!
!
!
!
interface Loopback0
 no ip address
!
interface FastEthernet0
 ip address 84.71.77.212 255.255.255.248
 speed auto
 full-duplex
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn point-to-point-setup
!
interface FastEthernet1
!
interface FastEthernet2
 shutdown
!
interface FastEthernet3
 shutdown
!
interface FastEthernet4
 shutdown
!
interface FastEthernet5
 shutdown
!
interface FastEthernet6
 shutdown
!
interface FastEthernet7
 shutdown
!
interface FastEthernet8
 shutdown
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface Vlan1
 no ip address
 shutdown
!
ip route 0.0.0.0 0.0.0.0 84.71.77.214
!
!
ip http server
no ip http secure-server
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password 7 <removed>
 login
!
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
end


0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 2000 total points
ID: 20293766
There's a couple things going on here.

First is that fa0 is a routed port. Fa1-8 are switched ports. They only way to get from fa0 to any of the other ports is to go through the router. Which means they will be on different networks.

If you really need to have multiple devices on the same network as your internet connection, you'll need to have the DSL modem connected to one of the switched ports. (BTW 2 - 8 are shutdown now)

The other devices will also connect to port 1-8.

With all the connections on the switchports, you won't be able to use a typical router ACL. I don't know if this platform supports VLAN ACLs but that would accomplish what you're asking.

From global config mode, try entering "vlan access-map ?" and "vlan filter ?" and see if recognizes those commands.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question