Invalid recipient on when sending

I try to send an email to, using one of my email accounts I get it bounced back instantly with an "invalid recipient" message.
The mail server is, if I try any other of my email accounts with different isp's it works fine.
Why might this be happening?
Thanks for any help.
Who is Participating?
grahamnonweilerConnect With a Mentor Commented:
I have myself just tried to send an email to "" and got 2 errors - the first was a graylisting command from the ATLANTIC SMTP server (the host mail server for which is normal and nothing to worry about, the second was a 550 error saying the account  "" does not exist.

So it seems the error is with "" and not your ISP.

If you have another way to contact "" then you should tell them that their email is returning "transient" sending errors - it could be that they have some capacity limits or other issues with their host.

It may be that the ISP for the account you are trying to send email from is blocking ".biz" tlds (top level doman names)

.biz domains are frequently used by spammers and as a consequence get blocked for both outgoing and incoming mail.
RickJAuthor Commented:
Hello thanks for the quick reply,
How would I verify that is happening without contacting the ISP?
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

If you have another ".biz" email address try sending an email to that address - if it goes through then your ISP is not blocking .biz domains.

However, the best solution is to ask your ISP.

By the way what is the exact bounce message you receive?
RickJAuthor Commented:
Thanks I will try another .biz address.
The error is as follows;

Your message did not reach some or all of the intended recipients.

      Subject:      test email
      Sent:      15/11/2007 8:09 PM

The following recipient(s) cannot be reached:

      '' on 15/11/2007 8:09 PM
            550 Invalid recipient: <>
RickJAuthor Commented:
I tried another couple of .biz and they sent successfully.
Do you still think this is likely to be an ISP problem?
RickJAuthor Commented:
Thanks for that.
I am now trying to deal with the hosting company to rectify the problem, like drawing blood from a stone...
Thanks again for your help.
RickJAuthor Commented:
Hello again,
Wondering if you could please help me out.
The hosting company is asking for another mail server that is not that cant send to this address.
You mentioned that you tried and it wouldnt work, are you able to tell me the server you are using to send?

Thanks again for your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.