Solved

Software Update from 10.4.10 to 10.4.11 failed and now machine won't boot

Posted on 2007-11-15
10
1,544 Views
Last Modified: 2013-11-24
Here's the situation.  User tried to run software update to install the recent 10.4.11 OS X software update.

The update failed, and according to the user, he was shown a dialog box that said that the update failed and that the update was in the trash.  The instructions said to remove the item from the trash and then run the update again.

So the user pulled the update from the trash to the desktop and executed it.  When he saw that it appeared to be downloading again, he cancelled the update.

Then he tried to run software update again, but it wouldn't run.  So he tried to reboot the machine (properly), only after the shutdown, the machine would only go to the gray screen with the apple and the spinning circle.  After that, nothing.

There was a data CD in the media drive which I ejected by holding down the touchpad key, but still no joy.

I then inserted the 10.4.6 Boot DVD, and tried restarting while holding the C key, but the machine will not boot from the CD/DVD either.  However, when I connect a bootable firewire drive (made from another machine) and boot from that (also by holding C during power-up), I am able to boot the machine.  And it does seem to see the internal hard drive.

I even tried the NVRAM reset to see if it made a difference, but nothing changed.

Oh -- the hardware is a 17" Powerbook, Core2 Duo.

How can I fix this machine so that the internal hard drive is usuable again?

Any suggestions will be appreciated.  Thanks.
0
Comment
Question by:guyking
  • 6
  • 3
10 Comments
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20297032
Sounds like OSX has been compromised in some way.

Can you boot from that Firewire Drive .. insert the OSX System DVD into the laptop and do an OSX Archive & Install on the Laptop?
This would install a CLEAN system folder, backup the old Systemand retain all the user files.
You could then do a cumulative update from 10.4.6 to 10.4.11

Any missing preferences will be in the Backed up Library folder from the old system.
0
 

Author Comment

by:guyking
ID: 20297573
I thought that you needed to be booted from the System DVD in order to do that.  Are you saying that that one can do this even though the DVD isn't the boot drive?

Furthermore, even if I can do it, don't you find it extremely odd that the machine will boot off an external firewire drive but won't boot from the system DVD?

Lastly, given that we have already purchased (but had not yet installed) 10.5 for this machine, is there any reason not to archive & install 10.5 instead of 10.4?

Please let me know.  Thanks.
0
 
LVL 39

Expert Comment

by:Eoin OSullivan
ID: 20297640
Q1. As long as you are booted from a DVD or any external device then you can install   OSX onto the Hard Drive.

Q2. Yes, it is strange that the Laptop will not boot from the DVD drive, it should.  Perhaps the C key is not fully responsive or sometimes it can take a try or two to get it to work.

Q3. Seeing as you have Leopard 10.5 then this might be a good time to install.  
As always .. I recommend a full backup of the Laptop HD (if you can do it to the external firewire) try using Super Duper to create a drive image.  It might take a few hours.
Then do an archive and install with 10.5.
If there are any issues you can do an erase and install and then copy the user folder back from the drive image.  Just gives you that extra bit of security.

Good Luck.

0
 

Author Comment

by:guyking
ID: 20298792
I have been thinking about this further, and now I have a new theory.

What if the problem is hardware level, and actually has to do with the firmware on the machine and how it boots from internal drives?  

I think we are both assuming that the o/s is corrupt on the internal drive (seemed likely given the recent events described in the original question), making the machine unbootable.  But since it also won't boot from the internal DVD, perhaps it is a more basic problem that the machine cannot boot off of _any_ internal (ide? scsi?) device.

Keep in mind that when the external drive is connected and the DVD is in the drive and the 'C' key is held at boot time that the machine STILL boots off the firewire drive instead of the DVD.  That seems to point to it being more than just the C key boot not happening.  I think it means that it doesn't recognize the internal drive or the DVD as bootable, and fails to the third choice.

Have you seen/heard of anything like this?  

I think I would like to rule this out before I overwrite the internal drive...

Thanks again for you help.
0
 

Expert Comment

by:miztermoo
ID: 20299249
I could not get the SHIFT or C options to work on bootup either, but I was able to boot off the system dvd by inserting it and on boot up holding down the OPTION key and then selection the CD-ROM, have you tried that?
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 39

Accepted Solution

by:
Eoin OSullivan earned 500 total points
ID: 20300154
Holding down the Option key on bootup will allow you to select from any valid OS either on external drives, internal HD or DVDs.  It is different from the C option which tries to force the computer to boot from the DVD drive.  You can also boot with T to turn the computer into a Disk-only mode where it works like an external disk.

guyking - I don't think your unbootable DVD is a fundamental problem .. the option key may also work.  Have you tried that?

I just found another person with a similar issue
http://forums.macnn.com/90/mac-os-x/350477/powerbook-g4-wont-boot-after-10-a/

If you have DiskWarrior it can often recover problems that no other solution will fix .. but it costs $100.

If .. when you boot from the Firewire Drive .. you can see the internal Hard Disk .. you could try and run Disk Utility on the Internal HD
If that fails .. then run fsck -y in terminal .. as explained on that link above
If that fails then you either try Disk Warrior or do a Archive & Install of Leopard.

Personally I'd try the 1st 2 options .. if they fail .. backup the HD and then do the Leopard Archive & Install.


0
 

Author Comment

by:guyking
ID: 20305755
Ok, here's the update.

First, I found out that the non-booting 10.4DVD was a red herring -- it was a PowerPC disc, not an Intel disc.  Once I found an Intel 10.4 disc I could boot fine, as did the 10.5 Leopard DVD (which is how I figured this part out).

So, booting from the DVD, I ran the apple Disk Utility on the drive, but it said everything was fine.

Before running fsck with any -y type args, I ran fsck -n as a matter of principal to see first what was going on.  The results weren't good:

fsck -n /dev/disk0s2
** /dev/rdisk0s2 (No write)

BAD SUPER BLOCK: MAGIC NUMBER WRONG

LOOK FOR ALTERNATE SUPERBLOCKS? no

Even worse, running fsck /dev/disk0s2 and telling it to look for alternates returns that the search for alternate super blocks failed  "YOU MUST USE THE -b OPTION TO FSCK TO SPECIFY THE LOCATION OF AN ALTERNATE SUPER-BLOCK TO SUPPLY NEEDED INFORMATION; SEE fsck(8)

I can't get Disk Warrior easily, and I am concerned about Archive and Install for two reasons:
1)  I am not convinced it will see or correct a problem at this level
2)  The inherent issues with badly behaved applications that installed files in system areas (the Adobe, CS Suite, etc. all do this).

Any other thoughts?

Please advise.  Thanks.
0
 

Author Comment

by:guyking
ID: 20306146
Ok think even the fsck/superblock problem may be a red herring as well.

When I tried to boot to single user mode, I watched the output and it died very quickly.  Googling the error message eventually led me to this thread:

http://discussions.apple.com/message.jspa?messageID=5873890

Seems many people are having the exact same problem with the 10.4.11 update, and there are a few variations of how to recover by booting from an Install DVD and then manually installing the update package via Terminal.  Still reading more before trying one of the varients myself...

Will update again once I try something.
0
 

Author Comment

by:guyking
ID: 20308239
Booting from the CD and then manually reinstalled the 10.4.11 update package (downloaded earlier to an external firewire drive) via terminal worked.  Others did a similar re-install that avoided command-line/terminal usage by using another like-processor machine and booting in target mode.

I suggesting reading the
http://discussions.apple.com/message.jspa?messageID=5873890

thread for the details about a few varients of the solutions.  

I will treat eoinosullivan's response as the solution for here as one of his posts put me on the right track, but I consider the best solution to be the ones outlined on the Apple discussion board listed above.

Thanks again.
0
 

Author Closing Comment

by:guyking
ID: 31409502
The "solution" actually led me to the best solution.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Deploystudio is a system which can be used to deploy OSX clients and servers within the small/medium or large business environments. The system is built onto of the OSX Server NetBoot system and uses images & workflows as its core assets. While work…
Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now