Solved

Site to Site VPN--Cisco phones can call each other, but no Audio

Posted on 2007-11-15
7
1,933 Views
Last Modified: 2009-01-10
I have two cisco routers:  Main office (Call Manager)-->pix vpn-----vpn 871<---cisco 7940 phone.

VPN is working and phone at remote site is registering with Call Manager.  Phone can make calls to extensions.  However, there is no audio/voice after answering call.

Thanks
0
Comment
Question by:tashmore
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
7 Comments
 
LVL 1

Expert Comment

by:siegemus
ID: 20296560
Check that you have allowed VoIP traffic trough the firewall.  The port used to register with call manager is not necissaraly the same.  The other thing to check is that you are using a codec with enough compression to cope with the speed of your VPN.
0
 

Author Comment

by:tashmore
ID: 20305102
That makes sense.  I will need to create an access list that allows skinny protocol.  However, I am a little confused about the access list.  Since the VPN is created do I bother with Global IP address or just use local network IPs?

192.168.1.0 (Call Manager Network)
192.168.1.250 (Call Manager)

Remote Site
192.168.4.0 network
0
 
LVL 1

Expert Comment

by:siegemus
ID: 20307095
It should work with local network IP's

If you can connect to Call Manager then the VPN is working and the 2 LAN's can communicate ok.  Your only problem is that when you try and send packets containing sound they aren't getting trough.  I would say that once the firewall passes skinny packets that the voice should be delivered.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:tashmore
ID: 20355400
Siegemus

I have narrowed the problem down to a subnet issue.  My remote site is 4.0 network and my main site is 1.0 network.  The problem is the phones at main site are on the 11.0 network.  Can you advise on how to configure routing so that VPN recognizes multiple subnets?  Should I close this question and ask another?

thanks
0
 
LVL 1

Expert Comment

by:cscorbet
ID: 21081540
you did say: "Phone can make calls to extensions nut no voice"

so maybe this is the issue:

Ive seen this when the Cisco pix denies the voice stream and youll need to Configure Application Inspection (Fixup),

On the pix had to do something like:

fixup protocol skinny 2000
Thats it!
You may also need to do this for other voice protocols that you may have in use (e.g. sip etc)
0
 

Accepted Solution

by:
tashmore earned 0 total points
ID: 23078869
Cisco TAC provided the solution:

Background:  The remote IP phone was registering with Call Manager using a VPN.  

Problem:  The IP phone was calling another office with a different subnet than main office.  That particular office has their phones on a VLAN.

Solution:  Create VPNS with other office including VLANs.
0

Featured Post

Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question