Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cannot receive email from specific address

Posted on 2007-11-16
7
Medium Priority
?
1,595 Views
Last Modified: 2013-11-30
Hey all,
 I have a customer who is routing incoming mail through softscan (managed spam solution) which for some reason is unable to deliver mail from one specific email address to their Exchange 2000 mail server, fails to deliver the mail with the following error:
reason: "IP" failed after I sent the message. Remote host said: 554 Transaction failed

Other email addresses from the same sender domain get through fine, just this particular email address. When I try to send a test mail spoofing this email address through telnet I get the following error:

554 Unable to process message: msg.1195215309.247295.4273 - error: Illegal breakage found in header: <Test_>

If I try the same test without putting any data in the mail it gets queued for delivery. Has anyone come across this error before? Incidentally I get this same error when I try putting any data regardless of the sender email address. Thanks in advance.
0
Comment
Question by:ajwuk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
7 Comments
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 20298053
I've never seen this before, but if it happens for only one email address, it might be possible that there's something wrong with the format of the address (like a non-ascii character, or an apostrophe).  There are some exaples here:
http://en.wikipedia.org/wiki/E-mail_address
0
 
LVL 10

Author Comment

by:ajwuk
ID: 20298167
Nope, there is nothing malformed in the sender email address, interestingly when I send a blank email (just a period after specifing data) it gets queued for delivery. I'm beginning to think it's softscan doing something bizarre. Example below:

250-dkcphmx58.softcom.dk Hi host1-2-3-4.in-addr.btopenworld.com [1.2.3.4]
250-PIPELINING
250-8BITMIME
250 STARTTLS
mail from:support@domain.com
250 <support@domain.com>, sender OK
rcpt to:another@domain2.com
250 <another@domain2.com>, recipient ok
data
354 go ahead
Test
.
554 Unable to process message: msg.1195220520.635620.11870 - error: Illegal brea
kage found in header: <Test_>
421 Connection Timed Out
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 20298232
Ah well, it was just a thought.  I don't know anything about softscan, I'm afraid.  I wonder if it expects you to supply a complete set of headers at that point?  Mind you, if it does, why only for that one address?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 10

Author Comment

by:ajwuk
ID: 20298354
Think I've found it, one of the mail relay servers specified in the NDR has been blacklisted by TQMCUBE. Suspect softscan might be using this RBL.

Still not sure why it thinks I've put a break in the data part though. Bizarre.

Thanks anyway.
0
 
LVL 1

Accepted Solution

by:
Luxtech earned 2000 total points
ID: 20395416
I've had the same problem.

I've found though if the first data line is just a carriage return, it works fine.

For example:
354 go ahead
TEST
.
The above will return the illegal breakage line.
However the following works:

354 go ahead

TEST

.

Good luck!
0
 
LVL 10

Author Comment

by:ajwuk
ID: 20395861
How wierd is that?!?

Thanks, it works.
0
 
LVL 1

Expert Comment

by:Luxtech
ID: 20395871
great! Please can you accept my comment as a solution!
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
We aren’t perfect, just like everyone else.  Check out the email errors our community caught and learn the top errors every email marketer should avoid.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question