Solved

Group Policy, Active Desktop, and Hide Desktop Icons = Blank desktop?

Posted on 2007-11-16
3
7,350 Views
Last Modified: 2012-08-14
I have a small lab environment of about 25 machines, both Windows 2000 and Windows XP SP2 being managed by a Windows 2000 Server.

I'm trying to lock down the workstations a little bit, and I'm at the point where I came across an interesting issue I haven't been able to solve, even through excessive googling.

Basically, I have the windows 2000 user logins in one OU in active directory, and the XP user logins in another.  Each OU has a seperate group policy.  The workstations are set to log these users in automatically.  

What I'd like to do is set the webpage as the background and hide all the desktop icons.  

Under user configuration/administrative templates/desktop/active desktop/, I enabled "enable active desktop", "active desktop wallpaper", and "add/delete items".  "add/delete items" is set to "About:Home", so it will display the home page as the desktop wallpaper (so, I can change the homepage URL via group policy).  Like this, there is a strip down the left side on the workstations that the webpage doesn't fill.

Also, if I enable "hide all desktop icons", the webpage disappears from the background along with the icons, even though it looks like all the active desktop settings are still configured correctly when looking at the settings on the workstations.

Are these some weird active directory group policy quirks?  How can I fix this?

Thanks :)
0
Comment
Question by:computerslayer1
  • 2
3 Comments
 
LVL 21

Expert Comment

by:dan_blagut
ID: 20338266
Hi
Did you try to browse the page that you specified on about:home? The "strip down the left side on the workstations" means that the image is not available. What I reccomend to do is to put the image on all computers then to set that image as wallpaper in the GPO.

Dan
0
 

Author Comment

by:computerslayer1
ID: 20340294
I can view the page set as About:Home in a browser with no problem.

There is no background image specified.  I have tried enabling, disabling, and setting no configuration on the "Active Desktop Wallpaper" policy.  There is nothing entered for a file path.

On the workstations themselves, "None" is selected for the desktop image, with the default blue appearing as the background color.
0
 

Accepted Solution

by:
computerslayer1 earned 0 total points
ID: 20858483
This question is no longer an issue.  

While I wasn't able to enforce this through GP, I was able to get it working by going around to each workstation to set the active desktop manually, expanding the active desktop window, and locking the desktop.
0

Featured Post

NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you need to start windows update installation remotely or as a scheduled task you will find this very helpful.
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question