urgent smtp banner advertising the wrong thing

i have gotton bounce back errors from recipents.

      See, Danielle on 11/15/2007 2:35 PM catholic.org
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            <servername.mydomain.local #4.7.1 smtp;450 4.7.1 Client host rejected: cannot find your hostname, [12.xxx.xxx.xxx]>

this is the error i get so it is advertising .local when we need it to advertise .org for validation on the internet.  how do i do this???
do i change the smtp banner??
or do i have to change the actual metabase.xml file on the server???

thanks
amoosAsked:
Who is Participating?
 
Stacy SpearConnect With a Mentor President/Principal ConsultantCommented:
Yes, once you fix that you should be good. go back to the tool and check for blacklisting as you have been sending out mail that is not right, so you may have made it to one. Hopefully not.
0
 
amoosAuthor Commented:
this is happening to the internal emails to the outside world.  when i go into a web browser from the outside and type into the browser mydomain.org i get the username and password box to log into my domain .org so i am assuming that web access is advertising the .org instead of the .local or am i wrong??
0
 
Stacy SpearPresident/Principal ConsultantCommented:
your server FQDN should match its outside address. Go here and put in your domain, do a lookup, then a diagnostic

http://www.mxtoolbox.com/
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
amoosAuthor Commented:
since my internal domain is .local and the external is .org.  can i just change the smtp banner or the metabase.xml file on the server to advertise the .org instead of the .local???
0
 
amoosAuthor Commented:
ok on my dns i have forwarders set up to go to my isp which hosts my dns.  i was told that was correct.  now i do not have any mx or CNAME records in there.  do i need to create another zone??
if so should it be forward or reverse??
0
 
amoosAuthor Commented:
i did not set up this server a contractor did who is no longer being used.  i do realize it is probably a dns issue.  i have the host,soa,and mx records that the isp gave me but i am very curious how i put them in correctly.

all help is greatly appreciated
0
 
Stacy SpearPresident/Principal ConsultantCommented:
If your server is the receiving server for your domain then this --------
In Exchange system manager, expand your server, protocols, smtp, right click and choose properties on the virtual server that is listed there. go to the delivery tab, choose advanced. in the fully qualified domain name it should have the server name you have listed on your MX record there.

In your DNS control applet, you need to have the A record and mx record in the DNS. They probably are. The a record, mx and stuff must match on name, IPs, etc.

if ISP is where your mail should be going then this----
on your smtp connector (if one, if not on the virtual server) set the delivery smarthost as the mx they gave you.
0
 
amoosAuthor Commented:
ok i looked in the dns and there are no mx records in there.  only the forward lookup zone to go to the isp dns servers for lookups.  and that zone is mydomain.local.

so would i make another forward zone called mydomain.org and put the forwarders in there and then add the host and mx records there??

ok i used your mslookup tool and it returned 12.xxx.xxx.xxx which is correct
and mail.mydomain.org

now what do i do???  i am really confused because it was not setup right.  but i know with your help i can fix it
0
 
amoosAuthor Commented:
the server is advertising .local
i can change to where it advertises .org like it is suppose to.
so the outside will see myserver.mydomain.org instead of myserver.mydomain.local
will this fix the bounce backs that i am getting???
will this be good for the outside world to validate and not reject???

all help is greatly appreciated
0
 
Stacy SpearPresident/Principal ConsultantCommented:
That would be the first option I posted above. On the SMTP virtual server's delivery tab, advanced, change the name to myserver.mydomain.org
0
 
amoosAuthor Commented:
great help it was flawless
0
 
amoosAuthor Commented:
thank you so much for your help.  it was flawless
0
 
Stacy SpearPresident/Principal ConsultantCommented:
Glad to help, good luck in surviving the change from the previous contractor. that guy/girl giving us contractors a bad name!
0
All Courses

From novice to tech pro — start learning today.