?
Solved

Best way to connect a switch  to a  router port map as a vlan

Posted on 2007-11-16
14
Medium Priority
?
549 Views
Last Modified: 2008-02-15
We have a Cisco 3550 w/ vlan 1(60.60.60.10). All  devices connected to switch are 60.60.60. 0 network and switchport are configure to dynamic desireable and administrative encapsulation negotiable. weneed to connect to a router that has an uplink port set to:
vlan 5
interface giga 2/4
switchport access vlan 5
switchport mode access

The gigaport on the cat3550 connected to cat4506 is set as:
inteface 0/2
switcport access vlan 5
switcport mode access

What iconfiguration we need to set the other switcport in cat3550 to talk both to vlan 1 and vlan 5?
0
Comment
Question by:fredsanmateo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
14 Comments
 
LVL 8

Accepted Solution

by:
yasirirfan earned 2000 total points
ID: 20300609
Hey you have one option configre the interface in the switch in following format it can allow two vlan to communicate

Core_1(config)#interface gigabitethernet 1/1
Core_1(config-if)#switchport encapsulation negotiate
Core_1(config-if)#switchport mode dynamic auto
Core_1(config-if)#switchport trunk allowed vlan add 10
Core_1(config-if)#switchport trunk allowed vlan add 20
Core_1(config-if)#switchport trunk allowed vlan remove 2-1001


also remove all the vlans you don;t require


0
 

Author Comment

by:fredsanmateo
ID: 20301372
yasirinfan,
Assume the above entries are made, how will the interface read when the show running interface gigabitethernet 1/1 is enter? It important that the device connected to inteface gi 1/1 do loose the connection to vlan 1.
0
 
LVL 8

Expert Comment

by:yasirirfan
ID: 20303353
yes it do lose if you want vlan 1 to be added then  add vlan 1 or else if you want to remove then use the remove command
0
Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

 

Author Comment

by:fredsanmateo
ID: 20305982
yasirirfan,
 Following your listing above:making certain to have both vlan 1 & 5 flowing to switchport  fastethernet 1/15?
cat3550(config)#interface fastethernet 1/15
cat3550(config-if)#switchport encapsulation negotiate
cat3550(config-if)#switchport mode dynamic auto
cat3550(config-if)#switchport trunk allowed vlan add 1
cat3550(config-if)#switchport trunk allowed vlan add 5
cat3550(config-if)#switchport trunk allowed vlan remove 2-100
Will applyto interface to confirm resolution
Many thanks!!!
0
 
LVL 8

Expert Comment

by:yasirirfan
ID: 20306604
Sure do check and let me know
0
 

Author Comment

by:fredsanmateo
ID: 20321515
Hi Yasirirfan,

Sorry for delay, but is not working. Perhaps we recap our objective and connection.
1) cat4596(Route)r Giga 0/1 is on access mode on vlan 5 (60.60.60.3)/vlan 1(10.79.120.3)
2) cat3550(switch) Giga 0/2 is on access mode  on vlan 5/vlan 1(60.60.60..10)
3) we need the fasethernet ports on the cat3550 to have data flow both vlan 1 and vlan 5
4) Is giga 0/2 on cat3550 correctly configured?
5) How to configure the fasethrnet port of the switch to data flow both vlan 1 and vlan 5?

Thanks for your immediate attention
0
 

Author Comment

by:fredsanmateo
ID: 20325569
I have made many interface configuration a port in cat3550 so it will data flow vlan 1 & vlan 5 :
cat3550(config-if) switchport access vlan 5
cat3550(config-if)#switchport trunk allowed vlan 1
cat3550(config-if)#switchport mode access

The result is I can ping to any device passing thru vlan 5 but can not ping any in vlan 1.

Kindly request help , many thanks
0
 
LVL 8

Expert Comment

by:yasirirfan
ID: 20325752
If don't mind can you post the running config for  4596 & 3550 switch.
0
 

Author Comment

by:fredsanmateo
ID: 20327527
yasirirfan,
 Listing below is from the runninn config of the Cat4506 i

vtp domain US_01                    
vtp mode transparent                    
vlan internal allocation policy ascending                                        
vlan 2-6
!
interface GigabitEthernet1/1                            
 description                                    
 switchport trunk encapsulation dot1q                                    
 switchport mode trunk                      
!
interface GigabitEthernet1/2                            
!
interface GigabitEthernet2/1                            
 switchport access vlan 4                        
 switchport mode access                      
!
interface GigabitEthernet2/2                            
 switchport access vlan 3                        
 switchport mode access                      
!
interface GigabitEthernet2/3                            
 switchport access vlan 2                        
 switchport mode access                      
!
interface GigabitEthernet2/4                            
 switchport access vlan 5                        
 switchport mode access
!
interface GigabitEthernet3/1                            
 switchport access vlan 6                        
 switchport mode access                      
!
interface GigabitEthernet3/2                            
 switchport access vlan 6                        
 switchport mode access  
!
interface GigabitEthernet3/17                            
 switchport access vlan 6                        
 switchport mode access                      
!
interface GigabitEthernet3/18                            
 switchport access vlan 6                        
 switchport mode access
interface Vlan1              
 ip address 10.79.75.14 255.255.255.0disabled                            

!N
interface Vlan2ranslation is d
 ip address 55.55.55.3 255.255.255.0          

interface Vlan3              
 ip address 10.51.10.3 255.255.255.0d is disabled                      
!
interface Vlan4
 ip address 10.49.10.3 255.255.255.0            
 !i
interface Vlan5              
 ip address 60.60.60.3 255.255.255.0 up                                
!I
interface Vlan6is 55.55.55.3/2
 ip address 10.79.120.3 255.255.255.0 Broadcast address is 255.255.255.255



Listing below is from the runninn config of the Cat4506

User Access Verification

#show running-config
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname SW3-3524-RM2109
!
enable.
!
!
ip subnet-zero
!
!
interface FastEthernet0/1 thru interface FastEthernet0/24
!
!
interface GigabitEthernet0/2
 description Router link
 switchport access vlan 5
 switchport mode access

interface VLAN1
 ip address 60.60.60.12 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
0
 

Author Comment

by:fredsanmateo
ID: 20327564
oops!!!!  last listing is for cat3550 not cat4506
0
 

Author Comment

by:fredsanmateo
ID: 20357489
Issue resolved
0
 

Author Comment

by:fredsanmateo
ID: 20824603
Yasirfan,

Please accept apology for delay. I was moved to another task. I accept solution your solution. We removed the vlan designation and stayed w/ default vlan 1 of Cisco3550

Very soory and many thanks,

Fred
0
 
LVL 1

Expert Comment

by:Vee_Mod
ID: 20901900
Force accepted.
Vee_Mod
Community Support Moderator
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question