Powerpoint in Webbrowser control

I am showing a power point presentation inside a webbrowser control (.Net 2.0)
But the problem is :
Everytime i run the application the webbrowser control asks me with a dialog open,save or cancel.
There is any way to don't let this dialog not showing?

Or there is a better control to show powerpoint presentations in.


VB.Net Windows Applications .Net 2.0

Thanks
LVL 1
amrelgarhy81Asked:
Who is Participating?
 
McExpConnect With a Mentor Commented:
The WebBrowser control works just like having IE embeded in your app. the following describes how to change the setting for IE. This will have to be done on every client and you can't be sure they won't un-set it after you've gone. I Certainly would it drives me crazy when Office docs open in IE.

it is not controlled by Internet Explorer, but by Windows Explorer. In Windows Explorer menu, select Tools menu, Folder Options... menu item, File Types tab. Click on the file extension of the file type you want to change, e.g., PPT, and click Advanced push-button. You make the PowerPoint presentation appear in the IE browser window from which it was selected by checking the box labeled "Browse in same window". Unchecking it will cause PowerPoint presentations accessed from the IE browser to open in their own separate window. Click OK pushbutton to save your changed setting. Of course you must have PowerPoint installed on your PC to view PowerPoint files.
0
 
McExpCommented:
Powerpoint is not really designed to be played inside of a browser. Powerpoint will only work on computers that have Powerpoint installed and if a user has it. The application will be used. You can save a powepoint presentation as a Web Page, this will make it display in a web browser.
0
 
amrelgarhy81Author Commented:
no, i want to show the powerpoint presentation on my VB.Net windows form
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
McExpCommented:
It's all reated though. My understanding is that it's all to do with mime types. If you see the same when you try and view the PPT thorugh your normal Web Browser it's not realted to you app and is a machine specific issue.
0
 
amrelgarhy81Author Commented:
So how can i hide this dialog from showing??!!
0
 
GlennaShawCommented:
Do you have animations on the presentation?  If not, consider saving the slides as images and using those.
Better yet, check out SlideShare.net and see how they've done it.
0
 
amrelgarhy81Author Commented:
It may contain animations
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.