Solved

Cannot allow users to install ActiveX controls, via Group Policy.

Posted on 2007-11-16
5
9,714 Views
Last Modified: 2013-12-08
I'm having trouble granting my users the ability to install ActiveX controls on their workstations.  I've configured my policy according to the solution at http://www.experts-exchange.com/Security/Misc/Q_21917199.html, but it doesn't seem to work.  When the users go to, say, adobe.com and attempt to install Flash Player 9, all they see is a red "X" icon similar to the broken image placeholder.  Am I missing something?
0
Comment
Question by:g33x0r
  • 2
  • 2
5 Comments
 
LVL 13

Expert Comment

by:cshepfam
ID: 20301488
Go back to Group Policy


Go to Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Internet Zone


Click on and enable Run ActiveX controls and plugins and
Download signed ActiveX controls



You may see other things in there that you may want to enable also.  Afterwards, go to Start > Run and type in gpupdate



Also, if I may suggest...use a proxy to control internet activity such as websites allowed to visit, streaming music/video that will eat up your bandwidth, etc.

CC Proxy is a great software
0
 
LVL 3

Expert Comment

by:top_gizmo
ID: 20307942
Many time gpupdate or gpupdate /force will not actually make the changes take effect.  A good reboot should do it.
0
 

Author Comment

by:g33x0r
ID: 20315526
I've enabled Run ActiveX controls and plugins, and it's still not working (same result: broken image icon, and the gold Information Bar never shows).

Here's what my policy looks like in Group Policy Management Console:

Computer Configuration/......../Security Page/Internet Zone:
Policy Setting
Download signed ActiveX controls Enabled (Prompt)
Download unsigned ActiveX controls Enabled (Prompt)
Run ActiveX controls and plugins Enabled (Enable)
Script ActiveX controls marked safe for scripting Enabled (Enable)

It's exactly the same on the User side of the policy.  The policy is applied at the domain level, and is applicable by Authenticated Users.  I've verified it's applying correctly via RSoP.msc.

Am I missing a setting somewhere?
 
0
 
LVL 3

Accepted Solution

by:
top_gizmo earned 250 total points
ID: 20315625
Well, according to Adobe, you need admins to install flash player.  BUT, there is a work around if you give the user permissions on the folder and registry keys.

Here are the links...

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15511&sliceId=2#permissions

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19148&sliceId=2
0
 

Author Closing Comment

by:g33x0r
ID: 31409649
Correct about admin privileges, but I refused to believe it until now.

I signed up & requested a license from them, and downloaded & deployed the .MSI installer.
0

Join & Write a Comment

Resolve DNS query failed errors for Exchange
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now