Solved

Delivery Receipt's getting Queued

Posted on 2007-11-16
6
702 Views
Last Modified: 2009-01-04
We're running Exchange 2003 SP2 on three servers in the same site, one of which is a Frontend server, set up to act as a smarthost for the other two, which house the mailboxes.

Everything works great except that, when users request Delivery Receipts from the outside, the receipt ends up in the  "messages queued for deferred delivery" queue on one of the mailbox servers. When I look a the email in the queue, it shows "Envelope Recipients: SMTP:user@mail.mydomain.com;". My users do not have SMTP addresses with that domain name, but when I added one to my account and tested, received a receipt message. I realize that adding SMTP addresses like that through a recipient policy is an easy work around, but I'd rather keep it simple and figure out what I'm doing wrong.

It seems like this problem has something to do with the FQDN and Masquerade domain info set in the Advanced Delivery section of the Default SMTP Virtual Servers on the backend.

Any ideas?
0
Comment
Question by:IRADMIN
  • 3
  • 2
6 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 20302304
Why have you got masquerade domain and the FQDN set on the backend servers? It shouldn't be required.

How exactly do you have the servers configured? You have said the frontend is set as a smart host. Does that mean you have the frontend server configured as the smart host? If that is the case then you haven't done it correctly. What you should have done is set an SMTP connector with the frontend server only as the bridgehead. The backend servers would then send their email to the frotnend for delivery.

Simon.
0
 

Author Comment

by:IRADMIN
ID: 20303272
Yes, I set up my Frontend server as the smarthost for the backend servers because mail wouldn't route without that. I  started off with setting it as a frontend server, Routing Masterand Bridgehead, but I still couldn't send mail. Only after I set the backend servers to use the Frontend as a smarthost did mail start to flow and it's worked fine. I guess I did something wrong?

thanks,
Dan
0
 

Author Comment

by:IRADMIN
ID: 20303320
This is what I get when I don't set the Frontend as a smarthost for my backend servers and try to deliver mail to the outside. Very strange.

Your message did not reach some or all of the intended recipients.
      Subject:      Another test
      Sent:      11/16/2007 10:15 PM
The following recipient(s) could not be reached:
      personal@yahoo.com on 11/16/2007 10:15 PM
            A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients.  Contact your administrator.
            <backend1.firm.local #5.3.5>
0
 

Author Comment

by:IRADMIN
ID: 20303411
I removed the FQDN and masquerade domain and the smart host and got the same result as before. I added back the frontend server a smarthost on my backend servers and mail flows again, though for my delivery receipts, it's still trying to send to user@mail.ir-law.com. - Thanks
0
 
LVL 104

Accepted Solution

by:
Sembee earned 125 total points
ID: 20304241
The way that you are doing it at the moment is NOT correct. Therefore I suspect something else is wrong with the transport flow.
Smart host is basically a very blunt object way of sending the email between the servers - it is forcing it through. Exchange should route the email correctly on its own. Therefore something is wrong.

Removing the FQDN will cause problems, so you should put it back in. However it should be unique on each server and resolve correctly inside.
On the SMTP virtual server, ensure that it is set to a specific IP address, rather the "All Unassigned". If you then have routing group or SMTP connectors, recreate both.

SMTP connectors should be used to route email out of the Exchange org. Smart host on the SMTP virtual server should not be used under any circumstances - that is just a setting left over from the IIS SMTP and simply causes problems.

Simon.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Local Continuous Replication is a cost effective and quick way of backing up Exchange server data. The following article describes the steps required to configure Local Continuous Replication. Also, the article tells you how to restore from a backup…
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now