When logging into my workstations the login process is very long

When i log into my workstation it takes about 2 minutes to log into the domain.
I set up the whole network but i'm not sure i did it correctly. Everything is working ok except for the login part.

CABLE MODEM -----  SERVER  ---- SWITCH ------- WORKSTATIONS

Server settings
IP = 192.168.0.50
SUB = 255.255.255.0
GW  = 192.168.0.1
DNS = 192.168.0.1
DHCP = Not configured
DNS = Not configured

Workstations settings (DHCP)

Comcast SMC cable box
Private LAN= 192.168.0.1
DHCP = Enabled
DNS = Enabled
lcipolloneAsked:
Who is Participating?
 
Brian PierceConnect With a Mentor PhotographerCommented:
The correct way to set this up is:

Disable DNS and DHCP on the router
Enable DNS and DHCP on the server
Set up and authorize a DHCP scope on the server. Make sure that in the DHCP options you include :
   a) the DNS server (use the IP address of your server - this is option 006)
   b) the Default Gateway (this is the IP address of your router - this is option 003)

You should also set up forwarders in on the DNS console to refer external resolution to your ISPs DNS servers - see http://www.petri.co.il/configure_dns_forwarding.htm
0
 
Jay_Jay70Commented:
your problem is dns

on the server: make sure it points only to itself
on the clients: make sure they point ONLY to the server

reboot everything and watch thing flys
0
 
Brian PiercePhotographerCommented:
Yep
99 times out of 100 slow login is down to DNS. Do as Jay_Jay70 says.

The clients and server must point to your own internal windows DNS server as their preferred DNS server, NOT to an ISP DNS or similar asn thy MUST resolve internal names first.

As your clients are using DHCP you can set the address of the your windows DNS server in the DHCP options. (Option 006 - DNS servers)

You should also set up forwarders in on the DNS console to refer external resolution to your ISPs DNS servers - see http://www.petri.co.il/configure_dns_forwarding.htm


0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
lcipolloneAuthor Commented:
So my settings should be like these:

Server settings
IP = 192.168.0.50
SUB = 255.255.255.0
GW  = 192.168.0.1
DNS = 192.168.0.50
DHCP = Configure  (IP = 192.168.0.3 - 192.168.0.199)
DNS = Configure (Forwarders of 2 DNS IPs)

Comcast SMC cable box
Private LAN= 192.168.0.1
DHCP = Disabled
DNS = Enabled

Workstations settings (DHCP)

Questions:
Clients = how to I make sure that they point to the server DNS if they are DHCP? Do i have to go to each individual client and set this up? What about if I had 200 workstations?

What's option 006?
0
 
Jay_Jay70Commented:
you havent setup dhcp??/ Google DHCP and look at your options...
0
 
lcipolloneAuthor Commented:
Setup DHCP on my server or cable box?
0
 
tigermattCommented:
You should be looking to set DHCP up on the server. This way you get the advanced options of DHCP such as the ability to reserve addresses, set larger ranges, set an exclusion range of addresses, configure DNS as your server (most cable modems will default the DNS server to themselves) and various other things.

-tigermatt
0
 
Jay_Jay70Commented:
deff server, a router should never be a dhcp server in a domain environment where possible
0
 
lcipolloneAuthor Commented:
Ok, so i should:
Enable DNS on both Server and Router
Disable DHCP on Router
Enable DHCP on Server
Last time i tried this configuration everything worked ok but could not get to the internet from any workstation unless i used static IPs.
0
 
Jay_Jay70Commented:
all you need is DHCP and DNS on the server, the router is only used as a gateway and nothing else
0
 
tigermattCommented:
>>> Last time i tried this configuration everything worked ok but could not get to the internet from any workstation unless i used static IPs.

Sounds like you didn't configure the router setting in your DHCP scope. Make sure you go into the scope options and enter the IP address of your router (which would be the gateway) into the scope options.
0
 
lcipolloneAuthor Commented:
What about if i want to make a workstation static?
IP: 192.168.0.62
Sub: 255.255.255.0
DG: 192.168.0.50 (Server IP) or 192.168.0.1 (Router IP)
DNS: 192.168.0.50 (Server IP) or 192.168.0.1 (Router IP)
0
 
Jay_Jay70Connect With a Mentor Commented:
if your workstation is static the exact same settings apply

Gateway = Router IP
DNS = Server IP
0
 
lcipolloneAuthor Commented:
Everything works really fast now. Great answers!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.