Solved

IIS: Access to file on another system

Posted on 2007-11-16
6
801 Views
Last Modified: 2008-04-10
Hello,
I have my application written in VB.NET and have it deployed in IIS 7 on Windows Vista. In one of the pages, a file has to be opened that resides on a remote computer. I am building the path to the file, inside the code alright.

The problem I have is, when I launch this application using the local development server, I am able to click the link and open the remote file. But when I launch the application from IIS, I cannot open the application. Do I have to set the permissions for the IIS to access the file? The IIS server and the remote system are on the same LAN.

Thanks.
0
Comment
Question by:pavanbh
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:philsmicronet
ID: 20303283
The world wide web service on your Vista machine is probably set to use the Local System account which does not have network access.

Right Click  Computer and Go Manage.
Double click on services
Find the World Wide Web Serice and go into properties
Click on the Logon Tab and select a user that has permissions to the file you are trying to access

0
 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 20303292
It's not the service that needs the permissions.  It's the Identity account used in the Application Pool that is used to access resources.
0
 

Author Comment

by:pavanbh
ID: 20303432
Thanks for your replies guys.

A little more clarification please. So tedbilly, in my IIS manager, in the Authentication, the anonymous authetication is enabled and is configured to use 'Specific User' which is IUSR. What do you suggest I do next? Thanks.
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 51

Expert Comment

by:Ted Bouskill
ID: 20303719
No you aren't looking in the right place.  In IIS Manager you should see something called 'Application Pools' which will contain a 'Default Application'  If you right click that you will see a few tabs and one will be the 'Identity' tab.

You are looking at the role used to authenticate access to the site.  The Application Pool defines the access for the code that runs web applications.
0
 

Author Comment

by:pavanbh
ID: 20303859
I do not see the window with tabs when i right click the defaultAppPool. But if I open the advanced settings, I get a tabular window that has a section 'Process Model' in which the Identity is set to NetworkService with nothing in the 'IdentitySpecificUserCredentials' field. What and where do I need to change my settings? Thanks.
0
 
LVL 51

Accepted Solution

by:
Ted Bouskill earned 150 total points
ID: 20305490
Yes, now you are in the correct spot.  Here is the issue, you have give permissions to the remote file for 'NT AUTHORITY\NetworkService' or you have to create a domain account to use for the application pool then give that domain account permissions.

In order to protect web servers on the internet, IIS usually has very weak accounts that can basically only run the web application.  If you choose to give more permissions you have to do it manually and of course are putting your servers at greater risk.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
HTTP Error 403.14 - Forbidden 5 55
How to stress test an ASP.NET https website 3 71
How do I get my SSL Certificate Reissued for SHA-1 4 76
IIS redirect 1 65
First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now