Solved

Cisco Pix 501 unable to access internal network through vpn

Posted on 2007-11-16
5
212 Views
Last Modified: 2010-04-09
I am unable to access my internal network through my vpn. Below is my Pix 501 configuration. Any help would be greatly appreciated. I can connect to the vpn and split tunneling is working fine. I just can't access the internal network.

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname borlandpix
domain-name borland.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list remote_users permit ip 192.168.1.0 255.255.255.0 192.168.8.0 255.255.255.0
access-list inside_outbound_nat0 permit ip 192.168.1.0 255.255.255.0 192.168.8.0 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.8.0 255.255.255.0
access-list outbound permit ip 192.168.1.0 255.255.255.0 any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn_pool 192.168.8.1-192.168.8.5
pdm location 192.168.8.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group outbound in interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set esp-3des-md5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set esp-3des-md5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup borland address-pool vpn_pool
vpngroup borland split-tunnel remote_users
vpngroup borland idle-time 1800
vpngroup xxxxx password xxxxx
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group isp request dialout pppoe
vpdn group isp localname xxxxxxx
vpdn group isp ppp authentication pap
vpdn username xxxxxxx
dhcpd address 192.168.1.10-192.168.1.20 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username xxxx password Bbv/hpk/k1rYQnMJ encrypted privilege 15
terminal width 80
Cryptochecksum:d942e83f33d76a549798de8efaadce39
: end
0
Comment
Question by:jlgray48
  • 2
  • 2
5 Comments
 
LVL 28

Accepted Solution

by:
batry_boy earned 500 total points
ID: 20303280
Remote the access list on the inside interface:

no access-group outbound in interface inside

See if that helps...
0
 

Author Comment

by:jlgray48
ID: 20303291
That kills my internet connection to my switch.
0
 
LVL 28

Expert Comment

by:batry_boy
ID: 20303303
Meaning you can't get to the Internet or you can't get to a switch on the outside of your network?  Given your current PIX configuration, that should not kill your Internet connection.  While that ACL is not applied (removed), can you ping an Internet host from the PIX itself?
0
 

Author Comment

by:jlgray48
ID: 20303345
The way my network is setup is this.

dell switch ---------- pix 501 ---------- dsl router ----------- Internet

When that acl is not applied I can access the internet through any of the ports on the pix but can't access it from a port on the switch. When it is applied I can access it from both the pix ports and the switch ports.
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 20304752
"When that acl is not applied I can access the internet through any of the ports on the pix but can't access it from a port on the switch. When it is applied I can access it from both the pix ports and the switch ports."
  That doesnt make sense. I assume some other configuration applied on the switch. In this case, try plugging a client directly to PIX and check if vpn client can access to that specific client. Also I recommend you to upgrade your IOS to 6.3.5

Regards
 
 
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now