Solved

How do I configure my switch from scratch with the previous configuration?

Posted on 2007-11-17
43
1,237 Views
Last Modified: 2012-06-21
Hi,

I have a cisco switch 2950. Its all configured. However, I need to re-configure the whole switch back with the same configuration.

How do I erase the configuration and put the previous config back on?

Please advise.

Many thanks

P.S. I can post the running config if that will help.
0
Comment
Question by:jurjess
  • 20
  • 17
  • 6
43 Comments
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
So you want to erase the config and then put the exact same config back on the switch?

Take the existing config and copy it to notepad. Issue the command "erase start" on the switch. Then "reload" the switch. When it boots up, it will be unconfigured. Then get to config mode and paste in the config that you have in notepad.

But why do you want to do this???

0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
Hey

Here is the example
http://www.cromwell-intl.com/tcpip/switch-programming.html

Cheers

Yasir
0
 

Author Comment

by:jurjess
Comment Utility
Thanks very much guys.. reason i wanna do is because i am facing this problem that my users are not able to get on the network. It shows me blinking green light and i have done everything to resolve the problem and it didnt get resolved. After everything what i did was i reconfigured the whole switch back on and the issue got resolved.
0
 

Author Comment

by:jurjess
Comment Utility
guys,

I think am doing something wrong here. I wrote 'erase start' and then 'reload' the switch. When i type 'show running-conifg' it shows me the config exactly the same. It never asks me for any IP, Subnet mask and everything.. nothing at all..

Why I am getting the previous config back on without doing it myself?

Please advise
0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
dear use this is working fine and it is used to reset the configuration
erase startupconfig

and then reload the switch
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Are you in privileged mode when you're entering these commands? Do you get any error messages when you enter them.

0
 

Author Comment

by:jurjess
Comment Utility
erase startup-config worked fine. Now there is another problem. The problem is that it doesnt allow me to type... it just loads everything so quickly that i dont get time to type my host name. I managed to typed down the enable passwords and now I am stuck at :

Enter interface name used to connect to the
management network from the above interface summary:

What interface name does it want? And what shall i do next? Please help
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
You are in the setup dialog. This runs whenever the switch boots without a configuration.

Just press Ctl+C and it will exit the setup dialog.
0
 

Author Comment

by:jurjess
Comment Utility
Guys,

I have reconfigured the switch with exact the previous config. I have also tried to run the switch on factory settings.  However, when i connect my user to the switch it blinks green light. But the user is offline. Not on the network, not able to use internet.

Could anyone guide me what i should do to troubleshoot this issue?
0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
may be there is some problem with the switch, did u tried to ping from the switch the default gateway, can u post your running configuration. What about he POST is it passed or failed. Seems to be some problems with the interfaces.

Just port your configuration, did you checked the speed and duplex settings

0
 

Author Comment

by:jurjess
Comment Utility
SW001#show running-config
Building configuration...

Current configuration : 1646 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW001
!
!
ip subnet-zero
!
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
vlan 20
 name VLAN_1X2
!
vlan 30
 name VLAN_ADM
!
vlan 40
 name VLAN_AH
!
vlan 50
 name VLAN_GLB
!
interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/2
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 no ip address
!
interface FastEthernet0/6
 no ip address
!
interface FastEthernet0/7
 no ip address
!
interface FastEthernet0/8
 no ip address
!
interface FastEthernet0/9
 no ip address
!
interface FastEthernet0/10
 switchport access vlan 40
 no ip address
!
interface FastEthernet0/11
 no ip address
!
interface FastEthernet0/12
 no ip address
!
interface FastEthernet0/13
 no ip address
!
interface FastEthernet0/14
 no ip address
!
interface FastEthernet0/15
 no ip address
!
interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 no ip address
!
interface FastEthernet0/18
 no ip address
!
interface FastEthernet0/19
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 no ip address
!
interface FastEthernet0/24
 switchport mode trunk
 no ip address
!
interface Vlan1
 ip address x.x.x.x 255.255.255.0
 no ip route-cache
 shutdown
!
ip default-gateway xx.x.x.xxx
ip http server
!
!
line con 0
line vty 5 15
!
end

I have tried to ping the default gateway and the success rate is zero percent.
0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
here we go

there is a problem in ur interface vlan1

follow this
interface vlan1
no shutdown

interface range fastethernet 0/1 - 24
no shutdown

as your vlan1 is shutdown hence you cannot ping it.

Cheers
0
 

Author Comment

by:jurjess
Comment Utility
SW001#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
SW001(config)#interface vlan1
SW001(config-if)#no shutdown
SW001(config-if)#
21:06:15: %LINK-3-UPDOWN: Interface Vlan1, changed state to up
21:06:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state t
o up
SW001#conf t
SW001(config)#interface range fastethernet0/1 - 24
SW001(config-if-range)#no shutdown
SW001(config-if-range)#

SW001#ping xx.x.x.xxx
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
SW001#

And the user which is in vlan 40 (test user) is still offline ...

:(

                               
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
If your IP addresses are private, there's no need to hide them. It just complicates matters.

What is the IP address of the VLAN1 interface of your switch?
What is the IP address of the default-gateway and what port is it connected to?
What do you get with a "show interface f0/10"?
0
 

Author Comment

by:jurjess
Comment Utility
>What is the IP address of the VLAN1 interface of your switch?

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
 no ip route-cache

> What is the IP address of the default-gateway and what port is it connected to?
ip default-gateway 10.1.1.254

>What do you get with a "show interface f0/10"?

SW001#show interface f0/10
FastEthernet0/10 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 000f.9025.49ca (bia 000f.9025.49ca)
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     429 packets input, 68102 bytes, 0 no buffer
     Received 428 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 7 multicast, 0 pause input
     0 input packets with dribble condition detected
     5409 packets output, 392739 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out



0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
What port is the default-gateway connected to?

As for your VLAN40 device, you're getting a green LED, the interface show UP/UP... It's connected. If the device is showing that it's not, I'd focus on the device itself.
0
 

Author Comment

by:jurjess
Comment Utility
the default gateway is connected to port 24. And i think we should put that in vlan1. shall i try that?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
What is the default-gateway?
0
 

Author Comment

by:jurjess
Comment Utility
> donjohnston:What is the default-gateway?
default gateway is: 10.1.1.254
Do you mean the cable going to the router yeah?? :$

OK. I have done the following thing. Just for my own satisfaction. I know I could be silly. Anyway, These are the results. If you could notice there is no f/024 showing under vlan1. Its getting weird now i guess.

SW001(config)#int f0/24
SW001(config-if)#switchport mode trunk
SW001(config-if)#no shutdown
SW001(config-if)#end

SW001#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23
20   VLAN_1X2                         active
30   VLAN_ADM                         active
40   VLAN_AH                          active    Fa0/10
50   VLAN_GLB                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
40   enet  100040     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
SW001#
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
f0/24 is not showing up under VLAN because it's a trunk. That's why I was asking "What is the default-gateway". What I mean is, what type of device is it? A Cisco 3550? 2811? You've got an 802.1q trunk going to it, so hopefully it is capable of trunking, right?
0
 

Author Comment

by:jurjess
Comment Utility
ohhh i do apologize... yes, its cisco 2950 catalyst. And it is capable of trunking.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Okay. So a 2950 is conencted to this switch's f0/24. Is it configured to trunk on it's port? And what's the default-gateway and where is it?
0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
Hey if the trunk port your using is connected to a cisco switch
then make sure you use the following configurations

interface fastethernet 0/24
switch port trunk encapsulation dot1q
switch port mode trunk
no shutdown

make sure the the same configuration is used other switch too
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Yasir,

You can't use the "switchport trunk encap" command on a 2950.
0
 

Author Comment

by:jurjess
Comment Utility
>donjohnston:Okay. So a 2950 is conencted to this switch's f0/24. Is it configured to trunk on it's port? And what's the default-gateway and where is it?

I Think you are loosing me at this point. The hardware we are troubleshooting is a cisco switch 2950 catalyst. Now if you could tell me what do you mean by 'whats the default-gateway'?
0
 

Author Comment

by:jurjess
Comment Utility
>donjohnston:And what's the default-gateway and where is it?

OK. Now the default gateway is the router which is cisco 2600. And i am using port 24 on switch 2950 to connect it to the router which is the default gateway. It is right above the switch (physically) !! if that will help
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
At the end of your sixth post, you stated:

>I have tried to ping the default gateway and the success rate is zero percent.

In order to troubleshoot this, we need to know about the devices in question. You've provided the info about the 2950 switch. Now we need to know about the device you're trying to ping (in this case the default gateway).

What type of router (or layer 3 device) is the default-gateway of the 2950 switch that you are pinging from and where is it?
0
 

Author Comment

by:jurjess
Comment Utility
How can i find the type of the router ?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Let's try a different approach:

You said the default-gateway has an IP address of 10.1.1.254. What is the make and model number of the device with that IP address?
0
 

Author Comment

by:jurjess
Comment Utility
as i said earlier ... its a cisco router 2600 series.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Okay, sorry. I must have missed that.

Can you post the config of the 2600 and the 2950 between the the first switch and the 2600?
0
 

Author Comment

by:jurjess
Comment Utility
Now, the trouble is the router password has been changed by another disgruntled employee and hes been fired. I have to reset the password for the router. Thatswhy i cant send u the router config. I have just joined this position 1 month ago. And thatswhy i am just finding my ways a bit difficult at the moment here. And to reset the password I have to wait when all the users have gone off. But I am working for an online betting company i can't put the router down untill midnight...

And am sure there is no other way to reset the password while having the users online?
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
>And am sure there is no other way to reset the password while having the users online?

That is correct.

Can the other 2950 ping the 2600?
0
 

Author Comment

by:jurjess
Comment Utility
SW003#ping 10.1.1.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

This is the other 2950 which i have used to ping the router. And the result is same. This switch is working all good. All the users connected to this switch are up and running.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Then the problem is either the link between the 2600 and the 2950 or the 2600 is configured correctly.

0
 

Author Comment

by:jurjess
Comment Utility
Now I think that the trouble is not the link between 2600 and 2950. Because I had the same trouble earlier. And i found out that the port wasnt under the trunk mode and i fix it up and it got working. All the users got connected to the internet again. On this switch which we are troubleshooting is completely configured as the rest of the switches and the link between the router and switch is showing me the green light.(here am talking abt the port which is connected to the router)

I seriously think its a hardware issue. But I just need to make sure that it is a hardware failure.
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
Well, either way, the question should probably be closed as this topic isn't part of the original question.
0
 
LVL 8

Expert Comment

by:yasirirfan
Comment Utility
that's true this question should be closed as we are heading towards different direction.
0
 

Author Comment

by:jurjess
Comment Utility
GUYS

I HAVE SORTED OUT THE SWITCH. I POWER CYCLED THE SWITCH AND NOW ITS WORKING ALL GOOD. ITS CURRENTLY RUNNING ON FACTORY SETTINGS. I AM TRYING TO CONFIGURE IT THE WAY I WANT TO. NOW I AM COMING ACROSS AGAIN A STRANGE THING WHICH I AM PASTING AS FOLLOWS:

SW001(config)#interface vlan1
SW001(config-if)#

IF YOU GUYS COULD NOTICE IT GOES TO "CONFIG-IF". IT SHOULD GO TO "CONFIG-VLAN".  NOW WHAT DOES THAT SUPPOSE TO MEAN. AND HOW CAN I TROUBLESHOOT FROM THIS POINT FORWARD.

WE ARE BACK IN BUSINESS !! THANKS A LOT TO YOU GUYS... YOUR SUGGESTIONS REALLY WAS USEFUL... AND I DO LOOK FORWARD THAT YOU GUYS WOULD HELP ME TO SORT THIS NEW ISSUE NOW. I AM SURE ITS NOT GONNA BE A BIG ONE.... AS WE JUST NEED TO CONFIGURE IT ALL BACK ....

THANKS AGAIN
0
 
LVL 50

Expert Comment

by:Don Johnston
Comment Utility
No. You are going into INTERFACE configuration mode. Not VLAN configuration mode.

"vlan interface" will allow you to define the management interface for the switch.

"vlan" allows you to create a vlan.
0
 

Author Comment

by:jurjess
Comment Utility
ahh ok.... thanks

one more thing to ask you ... basically, i have connected this switch to another switch and the user is online now... the root problem is the port 24 on the switch which is connected to the router. the link between the router and the switch is down for sure....

0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
Comment Utility
You'll have to open a new question for this as it does not pertain to the original question.
0
 

Author Comment

by:jurjess
Comment Utility
okay sir ! thanks a lot guys.... i really appreciate your responses and you guys made it a lot more interesting troubleshooting this kind of situation.... luckily it wasnt that critical and i got a chance to play around .... anyway, cheers
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

As dyndns has reduced the capabilities of the free service, I looked around for other free providers of Dynamic DNS service. After testing several I decided to move my DNS hosting to Hurricane Electric as then domains that require dynamic hostnam…
Before I go to far, let's explain HA (High Availability) and why you should consider it.  High availability is the mechanism used to provide redundancy to any service at the same site and appears as a single service to the users of that service.  As…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now