?
Solved

Oracle 10g server installed on XP, sometimes down and sometime up ..

Posted on 2007-11-17
2
Medium Priority
?
692 Views
Last Modified: 2013-12-19
I installed the 10g v2 server on a laptop, just to learn the concepts related to Oracle systems.
I know it's too big a task to run for tha labtop, however it seem "working". I mean from the interprice manager I saw everthing is up and was able to use iSQLPlus as well as SQL*PLUS in both remote and local clients.

But it seems not stable or some configuration to be done or there should be a sequence of booting the service/listener processes. The sympton is: half of the time sthe system shows up in the EM as "Database instance is down" and "the Agent cannot connect to the instance, because it "currently" does not know the SID "  Here is the exact copy from EM
 
 Agent Connection to Instance
 
 
 
 
Status  Failed
 
Details  ORA-12505: TNS:listener does not currently know of SID given in connect descriptor (DBD ERROR: OCIServerAttach)
 
 However the listern on port 1521 is up:
 Listener
 
 
Status  Up
 
Host  SCIMAT11
 
Port  1521
 
Name  LISTENER
 
Oracle Home  C:\oracle\product\10.2.0\db_1
 
Location  C:\oracle\product\10.2.0\db_1\network\admin

I don't really have an clear idea of which service is responsible for which listerners and agents, but I do see there are serveral Oracle named services started automatically in Windows XP.  Is the Agent, the TNS Listener,actually listening on the port 1521? I would really appreciated some expert give me a quick drawing about the server/listerner/Agent architecture of Oracle and the sequence/logic they should boot up and their dependences, even if you can provide a quick answer to my problem.

Thanks in advance.

Ze
 
 
 
 

 
0
Comment
Question by:zzhang2006
2 Comments
 
LVL 8

Accepted Solution

by:
LindaC earned 2000 total points
ID: 20305879
First you don't need the agent.  The agent is used for monitoring purposes bases you have an Enterprise Manager grid control created.  So disable this service so that it won't start when you reboot your computer.

Also if you have your host name in the listener.ora, do this:

Go to your host file located in C:\WINDOWS\system32\drivers\etc   and add the following entry.

127.0.0.1     SCIMAT11

Also go to start- control panel-system -advance - environment variable and add the following in the user variables:

New avariable name - ORACLE_HOME
Variable value - your ORACLE_HOME path.  Mine is C:\oracle\product\10.2.0\client_1


Remove your sqlnet.ora (make a bakup first doing a copy /paste)

Be sure you have your remote databases listed in your tnsnames.ora

Another thing.  It does not matter if you start the database or the listener first.


0
 
LVL 1

Author Closing Comment

by:zzhang2006
ID: 31409730
Thanks Linda!
I got it working!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction A previously published article on Experts Exchange ("Joins in Oracle", http://www.experts-exchange.com/Database/Oracle/A_8249-Joins-in-Oracle.html) makes a statement about "Oracle proprietary" joins and mixes the join syntax with gen…
Cursors in Oracle: A cursor is used to process individual rows returned by database system for a query. In oracle every SQL statement executed by the oracle server has a private area. This area contains information about the SQL statement and the…
Via a live example, show how to take different types of Oracle backups using RMAN.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function
Suggested Courses

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question